IRC channel logs

2017-09-02.log

back to list of logs

<ArneBab_>amz3`: I think it looks good. … HTML would have been so much cleaner if it had been done like that …
<ArneBab_>is shift-reset.com down for you, too?
<ijp>ArneBab_:
<ft>Works for me.
<ijp>thanks for mentioning that
<ArneBab_>ijp: it’s back. Thanks!
<ArneBab_>what had happened?
<ijp>I think my instance got restarted a few days ago, because my znc wasn't running either
<ArneBab_>I just read your SoC Recap (that’s how I noticed you site being down ☺). It sounds good — and I hope it can be merged into Guile soon!
<ArneBab_>I think one powerful application would be to build a site where all logic is done by Scheme compiled to js with just an abstract interface in pure JS
<ArneBab_>(such that people could simply strap in their own Scheme and have it power a website)
<ArneBab_>integration with skribilo could pull all content creation and logic into Scheme
<amz3`>ijp: just to be precise, in the end, you are right among many things in particular the need for cheney on the mta whatever it is
<amz3`>guile can not rely on third party implementation of tco
<ArneBab_>amz3`: even if all major browsers were to provide it?
<ijp>cheney on the MTA is a really underrated strategy compared to trampolines
<amz3`>ArneBab_: maybe you are right, the thing is that there is always the problem of older browsers
<amz3`>maybe it's not useful
<amz3`>soon enough it will be in chrome I will be able to continue my work
<amz3`>like I said in the mail, TCO is implemented in recent nodejs with the correct flag
***_zxq9_ is now known as zxq9
<ArneBab>amz3`: here’s the FF bug for TCO: https://bugzilla.mozilla.org/show_bug.cgi?id=723959
<oriansj>just a stupid question but anyone else notice the implementation of unless in guile behaves weirdly?
<oriansj>for example (unless #t 3 4) doesn't return anything but (unless #f 3 4) does
<mange>That sounds about right to me. (unless #t 3 4) is the same as (if (not #t) (begin 3 4)). What did you expect?
<oriansj>hmm, I thought the definition of less is supposed to be (define·unless·(lambda·(p·c·a)·(if·(not·p) c·a))) thus was supposed to behave like (if (not #t) 3 4)
<oriansj>but I guess if it was defined as (define unless (lambda p . c) (if (not p) c)) that would make sense
<mange>unless is the inverse of when, so (when a b c d) => (if a (begin b c d)), and (unless a b ...) => (when (not a) b ...). They're useful for when you have one-armed ifs.
<amz3`>wrt guile-js I filled an issue against traceur-compiler https://github.com/google/traceur-compiler/issues/2140
<amz3`>please +1 that to get attention :)
<janneke>sneek: later tell mwette: congrats on the release! i'll be interested to see what asm does...mescc has been using its own construct to implement asm which looked like a function call :-)
<sneek>Okay.
<manumanumanu>are there any neat parser combinator libraries for guile?
<stis>manumanumanu: I use stis-parser
<stis>but there are a couple of other to choose from
<manumanumanu>stis: I need documentation :)
<stis> http://www.c-lambda.se/guile-log/parser-combinators.html#parser-combinators
<manumanumanu>thx
<amz3`>manumanumanu: there is also mine
<amz3`> https://gist.github.com/amirouche/72c24b7122b7067ca4ee03e7a5ba616b
<amz3`>there is documentation for min yet, but tha are tests
<amz3`>and it's ill-indented
<amz3`>manumanumanu: what do you want to parse?
<stis>yay I can run prolog code that I compile, autocompilation works beutifully with a patched guile
<amz3`>stis: if I understand correctly your proposal is to have something like racket #lang in guile?