IRC channel logs

2017-08-28.log

back to list of logs

<mwette>ping
<stratotanker>another help
<stratotanker>Guile manual tell me that when catching exception with key 'misc-error, args can be used with simple-format
<stratotanker>I'm not able to do it
<stratotanker>args is a list with (#f format-spec arg1...)
<stratotanker>so, (simple-format args) not valid, how i can pass args to simple-format?
<mwette>I use the following:
<mwette>(lambda (key fmt . args) (apply simple-format #t fmt args))
<davexunit>rekado: no yaml library that I know of. I wrote a really hacky subset of a yaml parser before, but the yaml standard is *terrifying* so I gave up going further.
<dustyweb>davexunit: YaML is really the worst of the *ML family of languages ;)
<ijp>We should have a bug tool in guile called guilt
<davexunit>dustyweb: hahaha
<davexunit>ijp: +1
<dsmith-work>Monday Greetings, Guilers
<cmaloney>(tzag)
<rekado>davexunit: I only really need strings and lists, so a small subset of the specs would probably be sufficient for my purposes.
<amz3>sneek! oh! sneek come back to our room, it's full of blooming conversation, that needs your presence to be the perfect place to be on the internet
<OrangeShark>hello
<amz3>hi OrangeShark!
<amz3>OrangeShark: how are you doing?
<OrangeShark>I am alright, how are you amz3?
<amz3>fine :)
<dsmith-work>amz3: Ah fouey! Forgot to check on sneek over the weekend.
<dsmith-work>I'll try to remember tonight.
<manumanumanu>Has anyone tried porting clojures data structures to guile?
<arximboldi>manumanumanu: i have been experiment with immutable vectors, by binding my C++ library: https://sinusoid.es/immer/guile.html
<arximboldi>these vectors are more powerful than clojure's though, they are based on rrb-trees so they support log-n concat/slicing/insertion at any point
<arximboldi>while having similar performance otherwise
<arximboldi>I think wingo has been experimenting with pure scheme implementations though
<ijp>Guile uses integer map/set types internally that come from clojure
<ijp>my own functional vector library (pfds sequences) is not based on clojure, but on fingertrees, and my (fectors) is a whole different thing that is only semi-persistent
<manumanumanu>arximboldi: wow. that's impressive!
<ijp>GSOC Wrap-up sent to guile-user
<ijp>fectors doesn't get any love, my code mostly acts as a reference point for when I want to talk about that implementation strategy
<dustyweb>ijp: yay!
<manumanumanu>ijp: why leftist tree and not a pairing heap?
<manumanumanu>I always managed to squeeze slightly better performance from pairing heaps
<ijp>manumanumanu: what's the context for that?
<manumanumanu>ijp: oh. sorry, pdfs heaps are based on leftist trees
<manumanumanu>I haven't tested in guile though, but for most other projects I have found pairing heaps to give slightly better performance
<ijp>Ah. At the time I was needing a priority queue, and wasn't focusing too much on speed, so I implemented the one I could do from memory
<manumanumanu>If you want you can have my pairing heap.
<ijp>pfds has some conflicting goals in mind. Portability really hurts its performance on guile
<manumanumanu>how portable?
<manumanumanu>my pairing heap is r6rs
<ijp>pure r6rs
<ijp>If you want to link me the code, or send a pull request, or whatever, I can take a look, but I haven't really been focussing on pfds
<manumanumanu>ijp: https://bitbucket.org/bjoli/nietzsche/src/1769998a800955d5831aa7c0c8b3c31ba00f7050/data/pairing-heap.scm?at=default&fileviewer=file-view-default
<manumanumanu>I'll have a look if I can make a PR
<manumanumanu>whatever you do, don't look at the other code. much of it is crap
<manumanumanu>That's it for me. good night
<ijp>night
<dustyweb>gnite ijp
<dustyweb>btw here's the link to ijp's guile-user update on gsoc https://lists.gnu.org/archive/html/guile-user/2017-08/msg00070.html
<dustyweb>#lazyweb
<dustyweb>#lazyirc?
<cmaloney>#l
<cmaloney>(too lasy to type the rest)
<cmaloney>s/lasy/lazy/g even
<daviid>ijp: congrat for the strong dedication and the good work!
<amz3>ijp: what's the option you use to increase stack frame limit?
<amz3>in browsers that is
<amz3>ACTION reading ijp post
<dustyweb>amz3: it's in the post
<dustyweb>see the command with "node"
<amz3>ah yes, I was looking for the same thing under firefox
<amz3>nvm
<amz3>ijp: great achievement, you succeed where I failed numerous times! very great!
<amz3>(and I know javascript :p)
<cmaloney>Isn't writing in JavaScript just taking a 1 in 6 chance of returning NaN or undefined? :)
<dsmith-work>ijp: Yes Congrats!
<dsmith-work>ijp: Talking to someone forces you to collect your random nebulous thoughts into clear language. That very act often brings solutions.