IRC channel logs

2017-08-22.log

back to list of logs

<edrex>hi, i am a scheme newb trying to configure xbindkeys, and I have a question about timers/threads:
<edrex>I want to evaluate a function after a certain timeout has passed, in another thread. How can I do such a thing?
<edrex>Is this a good place to ask language questions like that, or only for dev chat?
<ArneBab>manumanumanu: thank you for the info!
<cmaloney>edrex: it hink this is the place to ask a question like this
<cmaloney>So you're looking to do some form of event-based coding where a timer triggers an event?
<cmaloney>edrex: Also: have you looked at fibers?
<edrex>cmaloney: yes, i want to evaluate a function after a timeout.
<edrex>*looking..*
<edrex>ideal it wouldn't require any libraries outside the stdlib, since this is going in my xbindkeysrc.scm
<cmaloney>You can check out signals as well : https://www.gnu.org/software/guile/manual/html_node/Signals.html
<cmaloney>that might work?
<cmaloney>sig_alarm possibly?
<edrex>yeah, i was reading that. If I knew how to create a new thread, I could probably use that to block it until a timeout occurs?
<cmaloney>yeah, I'm sort of new here so I don't know how you'd do that
<cmaloney>though you might be able to create the alarm. I know under UNIX (iirc) it will still interrupt and run the alarm code
<cmaloney>since the alarm signal is sent separately
<edrex>oh, interesting.. ok, i've got to hop off, but I'll try that and report back.
<cmaloney>edrex: No worries. Let us know if it works. :)
<manumanumanu>Morning guilers!
<civodul>hey there!
<civodul>wingo: did you have a chance to look at the dreaded quadratic GC issue?
<cmaloney>(tzag)
<civodul>hi! :-)
<dustyweb>heya!