IRC channel logs

2017-07-30.log

back to list of logs

<ennoausb`>Hello
<ennoausb`>Is there a string-append variant that puts spaces between the string args? That might be useful to construct command lines for system() calls
<janneke>ennoausb`: there is string-join
<janneke>it takes a list and optional separator and grammar
<ennoausb`>janneke: Thank you. I knew guile provides something like that
<reepca>I don't suppose we have anything like getgrouplist? Something that takes a UID and gives supplementary groups, rather than just giving current supplementary groups?
<paroneayea>btw I misspoke pretty badly!
<paroneayea>not 125k messages per second but 12.k messages per second
<paroneayea>shift over a whole digit, oops
<ennoausb`>Hello, I just ran into a problem as I overengineered my first guile project. :)
<paroneayea>it was 25k before the port ot fibers
<ennoausb`>I played around with mcron and I wrote some guile files to describe the jobs
<ennoausb`>After a file I mentioned that most of the job code is identical so I just used a config file what setups the cron jobs. So far so good. But the next step failed. I softlinked the .guile files to the now refactored job file which uses (current-filename) to test which corresponding .cfg file to load. Unfortunately this file was compiled once and reused than.
<ennoausb`>So job1.guile,job2.guile,job3.guile seem to be identical even if job1.cfg job2.cfg and job3.cfg are different
<ennoausb`>So I guess there is no easy way to achieve different behaviour with linked files.
<ennoausb`>like shutdown halt poweroff commands under linux
<paroneayea>it looks like fibers, on its own, can spawn about 26k fibers per second. So really, the overhead of adding actors is not so high in that sense
<paroneayea>likewise for the pingpong test
<ArneBab>I now described my doctest implementation for guile-user