IRC channel logs

2017-07-20.log

back to list of logs

<paroneayea>:)
<roelj>Why can't I have "multipart/form-data; boundary=..." as content-type field in http-post?
<sneek>roelj, you have 1 message.
<sneek>roelj, rekado says: I still get an error: http://paste.lisp.org/display/351187#1
<roelj>sneek: botsnack
<sneek>:)
<ym>Cloned guile branch, reading README: "Generic instructions for configuring and compiling Guile can be found in the INSTALL file."...
<ym>y@d:~/src/guile$ find . -name "INSTALL"
<ym>y@d:~/src/guile$
<ym>Where is it?
<roelj>ym: It seems to be missing.. But this is a file that is the same across all autotools projects, so here's one: https://github.com/roelj/inklingreader/blob/master/INSTALL
<ym>Thank you.
<manumanumanu>is there any reason to use define-inlinable over a syntax-rules macro?
<rain1>it would be bad coding style to abuse syntax-rules to inline a function, define-inlinable is better because it both inlines the function when used and allows you to still pass the function around as a first class value
<manumanumanu>aight. thanks
<ym>Wow. INSTALL file appeared after guile built.
<ym>I don't sure on what stage exactly, though.
<manumanumanu>Any reason why the guile manual doesn't serve a last-modified header?
<manumanumanu>I am not always on a computer where I can use the offline version, and today I must have loaded the procedure index something like a billion times :)
<paroneayea>hi hi
<paroneayea>how's it going, *
<OrangeShark>hi paroneayea. It is alright, I feel sleepy though
<cmaloney>Good morning
<cmaloney>reading the fibers info page and learning much
<cmaloney>ACTION feels like he was sequestered in business computing for many years
<paroneayea>cmaloney: :)
<ym>Is there a way to build emacs-guile with debian's libjpeg62-turbo jpeg library?
<ym>Seems like it should, but configure script says it's not found.
<ym>libjpeg-dev package installed, jpeglib.h is in /usr/include/
<ym>hmm
<ym>Uh
<ym>WARNING: libjpeg found, but not version 6b or later
<ym>JPEG_LIB_VERSION=62 in my case.
<ym>Seems like configure script generated with autogen has missing "fi" keyword for condition which tests if libjpeg is needed on mingw32 system.
<ym>Not missing, but in wrong place.
<ym>Wrong nested.
<ym> http://paste.lisp.org/display/351300
<ym>Whole "${opsys}" = "mingw32" test corresponds to this one condition.
<ym>Nope, I'm wrong. There is elif in the middle.
<amz3`>héllo
<ym># 115 "confdefs.c"
<ym> version=
<ym># 115 "confdefs.c" 3 4
<ym> 62
<ym>gcc -E generated such output, that's why egrep failed.
<ym>So $CPPFLAGS should be -E -P
<ym>Yep, works for me now.
<joajjajo>whats a good guide on how to debug code and stuff using guile? i keep getting [n] things that bothers me until i type ,q.
<daviid>joajjajo: what do you mean by 'keep getting [n] things that bothers me '
<daviid>look for backtrace in the manual, and, carefully read the outputof the error, it often prints the cause and the source code line ... then if that fails, use pk (to display values at crutial pont/steps in your code ...
<joajjajo>ill try that ty:o
<daviid>wc!
<bavier`>has anyone else read https://www.cs.indiana.edu/~dyb/pubs/nano-jfp.pdf ?
<rain1>yes
<bavier`>they wrote another paper describing how they used the ideas to replace the core of the chez scheme compiler. Was that experimental, or was it upstreamed?
<rain1>yes chez uses that library now
<bavier`>interesting
<bavier`>perhaps because I'm still learning, but it seems like specifying the intermediate languages and transformations are the most difficult to understand and implement correctly.
<bavier`>A compiler library like that seems like it would make things much nicer.
<amz3`>ijp: what's up?
<amz3`>ijp: did you see that https://github.com/vishesh/racketscript
<amz3`>ijp: where is your code?
<ArneBab_>amz3`: "RacketScript doesn't support Racket features which are expensive, for example proper tail calls and continuations." ← I think ijp goes further