IRC channel logs

2017-07-14.log

back to list of logs

<daviid>just launch a repl and try ,use (yourmodule), youll see that it won't work either
<daviid>the main svript can't use modules that do not compile of course, so first make sure each indicidual module compile fine...
<newb>@daviid ah! works now, thanks.
<daviid>wc!
<paroneayea>wingo: I'm guessing this wouldn't be tail recursive:
<paroneayea>(let lp ()
<paroneayea> (perform-operation
<paroneayea> (wrap-operation (get-operation channel)
<paroneayea> (lambda (msg)
<paroneayea> (foo msg)(lp)))))
<paroneayea>I've been thinking of how to handle it, maybe returning #t or #f from the perform-operation indicating whether to lp
<paroneayea>current solution:
<paroneayea>(let lp ()
<paroneayea> (and (perform-operation
<paroneayea> (choice-operation
<paroneayea> (wrap-operation (get-operation channel)
<paroneayea> (lambda (msg)
<paroneayea> (handle-message msg)
<paroneayea> #t))
<paroneayea> (wait-operation halt? (const #f))))
<paroneayea> (lp)))
<paroneayea>is there a faster way to convert an integer to a string than number->string? (or even better, to make a new string with that integer appended)?
***shinra-chiron_ is now known as shinra-chiron
<OrangeShark>Happy Friday!
<paroneayea>o/
***random-nickname is now known as random-nick
<amz3``>what's up guile?
<cmaloney>not a lot
<OrangeShark>hey amz3`` how are you?
<amz3``>I started a new project again, but i don't think I will finish it
<OrangeShark>oh, what new project is this?
<amz3``>sotogu thing from the video
<amz3``>OrangeShark: I saw your mail regarding guile-git
<amz3``>OrangeShark: is the plan to rewrite libgit2 in guile?
<OrangeShark>well eventually :)
<amz3``>what's the goal of rewriting it in scheme?
<OrangeShark>remove the dependency on libgit2
<OrangeShark>so it will be pure scheme
<amz3``>I see the the intestest of doing that from an intellectual point of view but I fail to understand what's the long term goal
<catonano>amz3``: what are you talking about ? I arrived just now
<amz3``>what advantage does it provide to implement it in guile?
<amz3``>catonano: rewriting libgit2 in guile
<catonano>ah I see. Thanks
<amz3``>catonano: otherwise the channel is logged, there is a link in the topic :)
<catonano>amz3``: right, sorry
<amz3``>catonano: nop
<amz3``>catonano: what are you up to this days?
<amz3``>catonano: btw, I know have a better perspective on wiredtiger, is actually more complicated that I was thinking
<catonano>amz3``: it's too hot for doing anything, these days. I am preparing for autumn. I'd like to see if I can help with the integration of Gnunet and Guile/Guix. Also I'd like to start a Haunt based personal little indie web site. I'd also like to read Structure and Interpretation of Classical Mechanics
<catonano>we'll see
<amz3``>you should write your own blog engine
<amz3``>imoh
<amz3``>imho
<amz3``>I mean I recommend to anybody to write its own blog engin
<amz3``>that's the spirit of indie web anyway
<catonano>amz3``: about wiredtiger: are you referring to the dinamic wind or is this a general thoght ?
<amz3``>dynammic wind, is an issue among other stuff
<amz3``>yes it's more general
<amz3``>I am wondering how I got "there"
<catonano>amz3``: well, I want to explore haunt. Maybe I will integrate/expand it. Who knows !
<catonano>amz3``: eh :-)
<catonano>amz3``: you were brave !
<amz3``>actually, wiredtiger is the end of a long journey working with other k/v databases
<catonano>amz3``: it shows. I was wondering how you were so confident with the issue
<amz3``>catonano: I go disconnected
<amz3``>got*
<amz3``>backlogging on https://gnunet.org/bot/log/guile shows that i missed some of you messages
<amz3``>what about wingo package manager work?
<amz3``>at last it's the end of the celebration, I can now record a new episode