IRC channel logs

2017-07-03.log

back to list of logs

<wingo>sneek: later tell civodul regarding (lambda () (floor/ 1 2)) (lambda (x) x)) -- i think the 2.0 behavior was a bug
<sneek>Okay.
<wingo>sneek: later tell civodul the way to express truncation in 2.2 is (call-with-values thunk (lambda (x . rest) x)); the rest arg will not be allocated
<sneek>Okay.
<civodul>Hey Guilers!
<civodul>wingo: re call-with-values truncation, i agree with you
<civodul>after all, it's a wrong-arg-num error in this case
<civodul>i was surprised 2.0 didn't do that in fact
<wingo>i think it must have just "optimized" the (call-with-values thunk (lambda (x) ...)) case into (let ((x (thunk))) ...)
<civodul>i see
<ijp>hmmmm, I seem to have backtracked. I no longer have the bindings from psyntax :/
<janneke>psyntax...fun :-P
<ArneBab>wingo: regarding your talk: the sages were right, but you actually made that work. Thank you!
<ArneBab>with fibers I can get my underpowered homeserver to actually serve 300 requests per second over SSH-forwarding.
<ArneBab>under heavy load
<ArneBab>locally it does 1000 requests/s
<ijp>the psyntax thing was just a function I had modified for debugging that no longer called its continuation, but since modules were getting loaded with a fresh one, the rest of the main code was still being run
<ijp>(just for the record)
<paroneayea>ohshi
<paroneayea>wingo: it looks like I need to implement suspendable ports support for custom ports, specificlaly for our gnutls wrapped ports
<paroneayea>wingo: if you've got time / thinking power to talk about this, I'd love to
<paroneayea>also hi ijp
<paroneayea>also, is there a way to be able to tell if it should be possible to do the fcntl magic foo other than (yuck) catching an error?
<paroneayea>currently I can only set ports to async if they're non-https I guess
<paroneayea>I've been testing against http and localhost
<paroneayea>and didn't realize until I tried testing against some https foo
<paroneayea>and then stuff borked
<amz3>greetings all the people..
<amz3>I stumbled upon some guile work sometime ago
<amz3>but I don't remember the github link
<amz3>the code was drawing wireframes of 3D objects in latex
<amz3>I mean, like to render in latex doc
<paroneayea>uhoh
<paroneayea>ERROR: Throw to key `gnutls-error' with args `(#<gnutls-error-enum The TLS connection was non-properly terminated.> read_from_session_record_port)'.
<paroneayea>though this was fixed...
<paroneayea>oh
<paroneayea>it's fixed, but not in the latest release :)
<paroneayea>whew!