IRC channel logs

2017-07-01.log

back to list of logs

<davidl>Im getting formatting issues constantly for parts of guile-code that previously worked fine. Is there a trick to this? Using a special editor or something?
<davidl>e.g. "invalid field specifier"
<ijp>you'll need to give more context
<davidl>ijp: I have my config.scm for GuixSD where I added some parts, then all of a sudden when I run reconfigure it says "invalid field specifier" for the (file-systems line.
<davidl>it just seems like unrelated issues pop up.
<ijp>I can't say anything about guix or guix-sd
<davidl>ijp: do u know if there's something like shellcheck for guile?
<davidl>i.e. a syntax checking tool.
<ijp>I think there is a linter in guild, but I've never used it
<ijp>doesn't seem very featureful
<davidl>ok.
<daviid>OT: what would be the american english expression 'travailler main dans la main', which I can poorly trnslate to 'working hand to hand'?
<spk121>daviid: I think "work hand-in-hand" is alright, if slightly old fashioned.
<daviid>spk121: tx!
<rekado>davidl: a syntax checker probably wouldn’t help you here. “invalid field specifier” means that you have a record (e.g. operating-system) and you try to initialise a field that doesn’t exist.
<rekado>davidl: this can mean that you close an expression too early, which makes it seem that its contents are fields for the parent expression.
<rekado>davidl: but without more context it’s hard to say what’s wrong in your case.
<davidl>rekado: re: "..which makes it seem that its contents are fields for the parent expression." I think that was it thanks. I tried to add a dvd-drive and probably made some mistake there which got caught "further up".
<atw>sneek: later tell daviid "working side by side" (https://en.wiktionary.org/wiki/side_by_side ) might be a useful expression
<sneek>Will do.
<amz3>héllo
<OrangeShark>hello amz3
<happy_gnu>hello :)
<happy_gnu>I am reading simple scheme
<happy_gnu>simply scheme
<happy_gnu>and it has a file with defined procedures
<happy_gnu>simply.scm
<happy_gnu>what is the right way to load this file in guile so it recognizes it?
<random-nick>you can use the load function
<random-nick>(load "./simply.scm")
<random-nick>if the file is in the current directory
<happy_gnu>oh ok random-nick :) thanks