IRC channel logs

2017-06-24.log

back to list of logs

<ryoshu>Hello
<ryoshu>I have problems building guile - http://susepaste.org/76742671
<paroneayea>hi #guile
<catonano>hey paroneayea !
<paroneayea>hi catonano :)
<paroneayea>how goes?
<paroneayea>ACTION just finished contracting for the day...
<catonano>paroneayea: it goes well ! Today I had thhe best beach day in maybe 10 years, I had a dinner with a political leader that I admire and I also received 2 precious answers (as emails) about my current endeavour with Guile
<paroneayea>catonano: horray :)
<catonano>if anyone is reading, people I'll reply tomorrow, now I'm just too tired ! Your help is highly appreciated !
<void_pointer>Got a question. Which GUI bindings have people here used with Guile and found to be well made and very usable? Basically, I have to make a program and I am trying to figure out if I should do it in Guile or in Python. I want to do it in Guile to get better at scheme and guile even though it would take a bit longer even with easy to use bindings.
<void_pointer>But, if there are no good bindings, then the extra cost to do it in Guile will be much higher and may not be worth it for this project (would hopefully have more time on the next one).
<paroneayea>sneek: later tell void_pointer guile-gnome is pretty nice but it's gtk-2.0 only. there are some ncurses bindings. In other words, your options are pretty slim unfortunately!
<sneek>Got it.
<atw>is it possible to define a roman numeral literal syntax?
<catonano>what is g-golf ? https://git.savannah.gnu.org/cgit/g-golf.git/
<void_pointer>paroneayea: thank you
<sneek>Welcome back void_pointer, you have 1 message.
<sneek>void_pointer, paroneayea says: guile-gnome is pretty nice but it's gtk-2.0 only. there are some ncurses bindings. In other words, your options are pretty slim unfortunately!
<void_pointer>paroneayea: that is unfortunate
<void_pointer>Maybe next time on GUI stuff.
<void_pointer>Kind of surprised that there aren't even TK bindings
<void_pointer>Not that TK is easy to use (have used them in Python and I much prefer other bindings)
<void_pointer>Well, unless the difficulty was a python thing with them.
<catonano>I rememberr there's an idiomatic way in guile to deal with bookkeeping with things that need to be opened before use and closed after use; like (with-this-and-that (do-stuff-that-uses-this-and-that))
<catonano>can anyone introduce me to that idiom ? Shold I write a marco myself or iis there any ready made one ?
<catonano>I'm asking because of this https://gitlab.com/humanitiesNerd/guile-freexl/commit/caf781bbd3a3257a82aba3c59247028600d4e7b5
<catonano>ohh my
<catonano>the tests pass !
<quigonjinn>catonano: maybe you mean dynamic-wind?
<catonano>quigonjinn: maybe. For example I saw an example wit amz3 library for accessing wiredtiger. With-connection (query...)). with-connection opens a connection and then closes it
<catonano>I missed a paren: it was (with-connection (query...))
<amz3`>catonano: here is one implementation https://framagit.org/a-guile-mind/guile-wiredtiger/blob/master/wiredtiger/extra.scm#L328
<amz3`>catonano: it's based on http://git.savannah.gnu.org/cgit/guile.git/tree/module/ice-9/ports.scm
<amz3`>facebook through relex does allow to move a record to mutable style with the same definition
<amz3`>I am watching https://www.youtube.com/watch?v=AGkSHE15BSs
<paroneayea>sneek: later tell catonano yes there are various with-* procedures; if they don't exist, dynamic-wind is the core structure on which to build them
<sneek>Got it.
<paroneayea>sneek: later tell catonano (or, "core abstraction")
<sneek>Got it.
***Guest63175 is now known as micro`
<catonano>amz3`: thanks !
<sneek>catonano, you have 2 messages.
<sneek>catonano, paroneayea says: yes there are various with-* procedures; if they don't exist, dynamic-wind is the core structure on which to build them
<sneek>catonano, paroneayea says: (or, "core abstraction")
<catonano>paroneayea: thanks !
<manumanumanu>anyone has a good hum how literal identifiers works in syntax-case? https://pastebin.com/GP0yW8jU this doesn't match the literal in-list. It matches everything
<manumanumanu>which is a bummer, since that is a pretty neat optimisation.
<reepca>Curiosity question - anyone happen to know offhand the time complexity of delete-duplicates?