IRC channel logs

2017-06-20.log

back to list of logs

<ijp>ArneBab: it's an object that represents the guile vm
<ijp> https://gitlab.com/ijp/guile/blob/compile-to-js-2017/module/language/js-il/runtime.js
***micro` is now known as Guest13987
***sajith is now known as Guest60752
***ft_ is now known as ft
***jvalleroy_ is now known as jvalleroy
<mekeor>i'm running a web-server inside the guile-interpreter on a raspberry pi. why can't i access the page through a browser on another device inside my home-network? – code:
<mekeor>(use-modules (web server)) (run-server (lambda (request request-body) (values '((content-type . (text/plain))) "Hello World!"))
<mekeor>`netstat -tulpen` says "tcp 0 0 127.0.0.1:8080 0.0.0.0:* LISTEN 1001 14144 6045/guile"...
<mekeor>in the browser, i was trying to access <ip-of-my-raspberry-pi>:8080
<mekeor>when i run that web-server on my desktop computer, it's accessable through localhost:8080
<mekeor>mekeor: for sake of completeness: the solution was: (run-server handler 'http `(#:addr ,INADDR_ANY))
<ArneBab_>ijp: so I can run the code if I start by importing the runtime.js?
<ArneBab_>ijp: that doesn’t actually look that big; i.e. compared to brython: view-source:https://www.brython.info/src/brython.js
<ArneBab_>(I know that they are not the same, but still the small size suggests good startup times)
***handsome1pirate is now known as handsome_pirate
<catonano>a
<sneek>catonano, you have 2 messages.
<sneek>catonano, paroneayea says: well I'm not sure which one I linked you, if you mean propagators, probably https://www.youtube.com/watch?v=mwxknB4SgvM but there are also: https://www.youtube.com/watch?v=arMH5GjBwUQ https://www.youtube.com/watch?v=O3tVctB_VSU https://vimeo.com/151465912
<sneek>catonano, paroneayea says: (if previous truncated) there are also: https://www.youtube.com/watch?v=arMH5GjBwUQ https://www.youtube.com/watch?v=O3tVctB_VSU https://vimeo.com/151465912
<catonano>b
<catonano>mmm
<catonano>ah !
<catonano>sneek later tell paroneayea Thanks ! The one in Vimeo is the one I remembered. I saw it on youtbe but the deffinition was quite poor. On Vimeo it's way better !
<sneek>Will do.
<catonano>sneek later tell paroneayea it's so better that it looks like a totally diffferent footage !
<sneek>Okay.
<catonano>sneek later tell paroneayea I took a glimpse at his generics functionality that he uses in Structure and Interpretation of Classical Mechanics. It's really interesting and it'd be fun to work on that in Guile
<sneek>Will do.
<catonano>sneek later tell paroneayea I am preparing a war plan to work on several diferent guile based proects in parallel, starting next autumn
<sneek>Okay.
***eena is now known as meena
<dsmith-work>Morning Greetings, Guilers
<OrangeShark>morning
<catonano>morning dsmith-work
***dsmith-work is now known as dsmith
***dsmith is now known as dsmith-work
<paroneay`>moin moin #guile
<sneek>Welcome back paroneay`, you have 4 messages.
<sneek>paroneay`, catonano says: Thanks ! The one in Vimeo is the one I remembered. I saw it on youtbe but the deffinition was quite poor. On Vimeo it's way better !
<sneek>paroneay`, catonano says: it's so better that it looks like a totally diffferent footage !
<sneek>paroneay`, catonano says: I took a glimpse at his generics functionality that he uses in Structure and Interpretation of Classical Mechanics. It's really interesting and it'd be fun to work on that in Guile
<sneek>paroneay`, catonano says: I am preparing a war plan to work on several diferent guile based proects in parallel, starting next autumn
<paroneayea>catonano: Guile has generics through GOOPS, but it's also easy to define your own generics system; for Various Reasons (actually because GOOPS doesn't support composite types) I couldn't use GOOPS for my ActivityStreams implementaiton
<paroneayea>but I wrote my own generics system and it was less than 100 lines of code, pretty easy
<catonano>paroneayea: I see
<catonano>paroneayea: I don't know whhat composite types are, but it's ok, I'll find tat out
<catonano>I read that Racket has a way to reconcile car, cdr with stream-car and stream-cdr. Does anyone here know more ? What is this reconciliation about and jow is it achieved ?
<paroneayea>catonano: so in json-ld and other linked data systems you can have a type, like
<paroneayea>{"type": "Video", "content": "A cool video", "url": "https://.../foo.webm"}
<paroneayea>but, you can also do this
<paroneayea>{"type": ["Video", "Transcription"], "content": "A cool video", "url": "https://.../foo.webm", "transcript": "..."}
<paroneayea>so see, multiple types for one object
<ijp>ArneBab_: yes, but there is a catch. This is just the vm (well, the parts I had implemented previously). In particular it does not contain boot-9 which is going to be significantly bigger
<catonano>paroneayea: ah I see. Thanks
<ArneBab_>ijp: is it possible to include only the parts which are needed?
<ijp>maybe? module-ref could make it tricky
<ijp>I think if I can get rid of just the syntax-case stuff that we keep around, that'll cut down the size quite a bit
<ArneBab_>ah, yes …
<ArneBab_>ijp: anyway: looks great!
<stis>hello guilers!
<dsmith-work>stis: Hej
<ijp>wingo: is there a list of primitives that don't return values, e.g. box-set!, wind, unwind, handle-interrupts, push-dynamic-state, etc
<ijp>Also, does anyone know when the #<syntax> representation was changed?
<ijp>I want to read the discussion of the change from the special vector lteral
<ijp>is there anything we can do to break boot-9 into something more manageable
<ijp>looks like the syntax type is just a simple struct (make-syntax expression wrap module)
<ijp>but I can't pattern match on it, can I?
<civodul>ijp: the new "syntax" struct was introduced in 2.2.2
<civodul>essentially to have unforgeable syntax objects
<civodul>as opposed to the vectors that psyntax used before that
<ijp>that was roughly my assumption, but I'm surprised the change is so recent
<civodul>yeah this is to support the sandboxing feature used by 'guix potluck'
<ijp>civodul: do you know how the change to a struct effects compilation?
<civodul>you mean how structs are serialized?
<ijp>serialised and deserialised, yes
<civodul>not quite sure
<ijp>fair enough
<civodul>ACTION checks 64c5cc58fced3092f17639bbbddb46c1bae974c8
<civodul>looks like it's just an extra case next to pairs, strings, vectors, etc.
<ijp>okay, that's good to know
<ijp>Look upon my works, ye mighty, and despair: http://shift-reset.com/tmp/boot9.js
<ijp>(or don't, it's like 3MB, and this is "minimised")
<ijp>I'm surprised uglifyjs doesn't barf on indenting it
<ijp>I think I might look into when I can elide the syntax objects from the output, since they are hilarious to look at
***profan_ is now known as profan