IRC channel logs

2017-06-08.log

back to list of logs

<daviid>hey guilers!
<cmaloney>'lo
<roelj>Does guile search for modules in the current working directory?
<avoine>roelj: not by default, you must use the -L . as argument to guile
<ijp>from the repl, or in some modules, you might want to use add-to-load-path
<roelj>Oh, I see.. I thought it was weird it worked, but somewhere in my code I did (set! %load-path (cons (getcwd) %load-path))
<roelj>Is there a way to merge multiple files (the equivalent of "cat file1 file2 file3 > total.txt") in Scheme?
<roelj>I think reading the file line-by-line and wrapping it around "call-with-output-file" would be slow because of the line-reading..
<ijp>there isn't a copy-port, probably because it's not really that common
<roelj>Possibly get-bytevector-all could work, but that reads the entire file into memory, doesn't it?
<ijp>yes
<ijp>bytevectors are probably still a better choice though
<ijp>the only issue is that your block size probably isn't going to match up with guiles
<roelj>How can I make sure it does?
<ijp>+ you are assuming that there isn't going to be encoding issues
<roelj>Yes, the files are actually just plain-text ascii only
<ijp>pass, I'd just pick a decent size and not worry too much
<roelj>Right, okay
<roelj>thanks!
<stis>hello guilers!
<OrangeShark>hello