IRC channel logs

2017-06-06.log

back to list of logs

<ijp>has guile changed the version of bdw-gc it depends on?
<ijp>README on master says at least 7.2, but I'm pretty sure I have 7.4 and I'm getting a conflicting types errors
<ijp>nvm seems to have been a cache issue
<cmaloney>huh, seems Ubuntu 17.10 still has Guile 2.0
<nalaginrut>I've heard debian9 will use 2.0 too, since the time window doesn't fit, unfortunately
<cmaloney>ah, fun fun
<cmaloney>ACTION was debating on picking up the printed Guile manual but hesitated because it was still 2.0
<cmaloney>might pull the trigger on that then
<nalaginrut>I was planing to deploy product program on debian9, but now I have to compile guile-2.2.2 for it
<cmaloney>ACTION needs printed books like he needs holes in his head
<ijp>I agree, they are important for life an for providing new experiences
<ijp>seriously though, I'm probably going to need to get rid of a chunk when I move later this year
<cmaloney>(that should read: I don't need them, but I sure love buying them)
<ArneBab_>couldn’t guile do this, too? http://dev.mujs.com/docs/examples.html ← would the code be any more complex?
<ArneBab_>(with ecmascript as language)
<nalaginrut>ArneBab_: this is similar to my idea for communicating with Python modules
<ArneBab_>sneek: later tell nalaginrut: I thought about this, because Guile should already provide most of the tools required for it.
<sneek>Okay.
<ArneBab_>sneek: botsnack
<sneek>:)
<mg__>I'm writing a small interpreter in guile, and for now reusing guile's (define (..)) to also define functions within my language. I take a symbol as input, and want to define a guile function with this name, is this possible?
<cmaloney>mg__: Do you have an example of what you're trying to do? (pastebin perhaps?)
<mg__>cmaloney: sure, give me a sec
<mg__>cmaloney: this is very pseudocodey as obivously it doesn't work, but: http://paste.lisp.org/display/348255
<cmaloney>mg__: An OK.
<cmaloney>I'm just learning so I don't have any insight (sadly)
<mg__>cmaloney: thanks anyway :)
<cmaloney>np
<ijp>mg__: you can do this, but not with define
<ijp>you'll want module-set!
<ijp>or module-define!
<ijp>a bigger issue is the scoping behaviour of arg1 & arg2
<mg__>ijp: thanks!
<mg__>ijp: just dropped those in there, not going to be an issue in my actual code
<quigonjinn>mg__: would using macros be acceptable? something like http://paste.lisp.org/display/348256
<ijp>quigonjinn: since mg__ specified they were writing an interpreter, I would say macros are probably not appropriate, otherwise that would have been my response
<daviid>davexunit: hello! I can't remember where you host the freeimage (partial) binding syou made a wjile ago, could you tell me?
<ijp>latest compilation mistep -- ERROR: Value out of range 0 to 4294967295: 2305843009213693947
<ijp>this is on current master in cps/utils.go
<daviid>davexunit: I found it, no worry