IRC channel logs

2017-06-05.log

back to list of logs

<takside>hi, I'm encountering an issue with GnuTLS and guile, I get `(#<gnutls-error-enum The TLS connection was non-properly terminated.> read_from_session_record_port) when attempting to HTTP HEAD some pages, but not with others
<takside>wondering if anyone else has encountered this or has a workaround?
<Apteryx>Hello Guile! Is there a way to "reuse" a default argument list without totally overriding it?
<Apteryx>Or extend an arguments' default value rather than completely override it?
<Apteryx>I guess it's not possible (it isn't in other languages as well).
<Apteryx>Or maybe there exist an interface to access a default argument's value (for functions declared with define*)?
<daviid>I have a weird problem: http://paste.lisp.org/+7GMZ
<reepca>What's the functional difference between string= and string=?
<Apteryx>What are double single quotes used for in Guile?
<Apteryx>Is ''("a" "b") the same as (quote '("a" "b"))?
<Apteryx>Got my answer from REPL ;)
<spk121>reepca: string=? will not fail on only 1 argument, so it can be used with apply
<reepca>spk121: ah, thanks, subtle difference.
<Xeroth>can anybody tell me how to use scm_error from C ? I want an wrong-type-arg error, but SCM_WRONG_TYPE_ARG does not exist.
<paroneayea>hello, *!
<catonano>paroneayea: hello !
<paroneayea>hey catonano
<paroneayea>how goes?
<catonano>paroneayea: not bad ! I managed to disentangle myself from a trap I ad been cauught into
<catonano>paroneayea: may I ask you to take a look at this, please ? https://lists.gnu.org/archive/html/help-guix/2017-06/msg00019.html
<paroneayea>catonano: oh good ... ? :)
<paroneayea>catonano: looking
<paroneayea>catonano: oh... I'm not sure I'm the best one to answer this... I really don't understand much about C library linking. I pretty much snarfed all that code from civodul's stuff in guix
<paroneayea>catonano: thouh, eventually I will have to learn, because I need to add such things to guile-squee as well
<catonano>paroneayea: ok, we'll see. Thankks for looing at it !
<catonano>paroneayea: right. guile-squee needs to link to the postgresql lib too
<paroneayea>catonano: yeah, sorry I couldn't help more..
<catonano>paroneayea: it's ok
<daviid>hello guilers!
<daviid>anyone had a chance to look atthis paste: http://paste.lisp.org/+7GMZ
<random-nick>daviid: it seems to be a bug with libtool
<random-nick>daviid: if you add a sleep before the pipe close it works
<random-nick>s/pipe close/close-pipe/
<daviid>random-nick: tx to look at this, not sure I get it though :) to me, it is a guile problem/bug, since 'libtool --version' works fine...
<random-nick>daviid: what I wanted to say is that "libtool --version" can return an error code if you close it too soon
<sneek>I'll keep that in mind.
<random-nick>?
<random-nick>sneek: daviid what I wanted to say
<random-nick>hmm
<random-nick>what is daviid: what I wanted to say
<random-nick>sneek is weird
<daviid>random-nick: I thought (read-line s) was 'waiting till a line was available'
<daviid>so close-pipe could only occur at the right time
<random-nick>daviid: yes
<random-nick>daviid: libtool seems to still be able to fail after the line has been written
<daviid>random-nick: it systematically returns 141 it appears
<daviid>random-nick: anyway thanks
<random-nick>daviid: is 141 the error that it outputs when it receives SIGPIPE?
<daviid>141 is the status:exit-val returned by guile
<daviid>random-nick: http://paste.lisp.org/+7GMZ/2
<random-nick>I'm pretty sure it returns the 141 code when it receives SIGPIPE
<daviid>random-nick: so, iiuc, the 'only' problem is that it is slow, guile closes the pipe before libtool --version could write it all there ..
<random-nick>yeah
<random-nick>daviid: yes, libtool --version has multiple lines
<daviid>random-nick: they all have multiple lines
<daviid>try automake
<random-nick>yes, it's a libtools problem
<random-nick>does your function actually need to error on non-zero exit codes?
<daviid>random-nick: not in this particular case, I was curious...
<daviid>random-nick: it start to workf fine if I (usleep 3000), below 3000 it fails, for info :)
<random-nick>ok
<paroneayea>me: is there anything like and=> except it's for only when you get #f, so you can raise an exception or whetever
<paroneayea>me also: oh right or
<paroneayea>I sometimes forget how handy or is for such things.