IRC channel logs

2017-06-01.log

back to list of logs

<paroneayea>ym: it's in it a state where it runs, but not in a state where you want to use it :)
<nalaginrut>I'm wondering if it's really necessary to implement guile-es6 or it's just pure masochistic http://pbs.twimg.com/media/DBH9EHVVoAQlh1z.jpg:large
<wingo>nalaginrut: i don't think it is worth it. language is too large; a waste of time
<nalaginrut>wingo: then how about python3 ?
<rekado_>I had a really boring dream in which I implemented R on top of Guile.
<wingo>hehe :)
<nalaginrut>rekado_: I hope you did blas too, that's really important
<wingo>nalaginrut: honestly i think finishing lua would be a more finishable task :)
<wingo>haha
<rekado_>nalaginrut: it was a dream, not a nightmare.
<nalaginrut>wingo: well yes, I just hope the methodology could do more things ;-)
<wingo>:)
<nalaginrut>or maybe just implement new language, dunno
<paroneayea>hm
<paroneayea>could someone verify?
<paroneayea>did documentation disappear with geiser support and guile 2.2?
<paroneayea>C-c C-d C-d doesn't work for me anymore.
<amz3>tonight is the night...
<OrangeShark>hello amz3
<amz3>héllo OrangeShark!
<amz3>OrangeShark: I tried distcheck in guile-git but it failed
<OrangeShark>amz3: what did it fail?
<amz3>OrangeShark: http://paste.lisp.org/display/347930
<OrangeShark>amz3: hmm some sort of failure in creating files from the tests?
<amz3>yes
<OrangeShark>I will try it when I get home
<amz3>OrangeShark: tx! Have a good day in the meantime :)
<OrangeShark>amz3: I have question about wiredtiger, what is prefix compression and how is it good for time series?
<amz3>prefix compression is like it will group all rows that starts with the same prefix
<amz3>so you have 111 112 113 114 etc... collocated
<OrangeShark>oh, since time series will be dates, it can easily group them?
<amz3>and compressed, I guess it means it doesn't repeat the prefix
<amz3>OrangeShark: yes
<OrangeShark>makes sense
<amz3>it also support classic compression with bzip2 and snappy, but it must be recompiled
<amz3>I am not sure how to activate prefix compression
<amz3>it must be a configure flag
<amz3>I read prefix compression is desactivated by default
<amz3>github is down ?!
<OrangeShark>thanks, was just curious after I read your latest email release for your bindings
<amz3>ah ok
<amz3>I read it's compression is useful to save space
<OrangeShark>amz3: github is up for me
<wingo>moo
<ijp>baa
<OrangeShark>arg, can't stop thinking about databases now
<wingo>hehe i have that problem sometimes :)
<wingo>ACTION trying to figure out how much goops class redefinition is worth
<wingo>good evening civodul :)
<civodul>heya wingo!
<sneek>civodul, you have 1 message.
<sneek>civodul, bavier` says: re mumps/metis, the error looks familiar so I'll take a look at it
<wingo>paroneayea: how do you feel about class redefinition
<wingo>as a goops person
<paroneayea>wingo: I feel it's very useful for live hacking, as a user
<paroneayea>wingo: I don't understand how it works fully under the hood, and it seems like the mechanisms are complex
<civodul>there's a smart protocol behind it
<paroneayea>wingo: one example where I've found it useful is in 8sync the mapping of action of a message (a symbol) to a specific message handler is done on a class level
<paroneayea>so when I'm doing live network hacking
<paroneayea>I can change how actors work while the program is running
<paroneayea>a lot of mudsync was written this way
<paroneayea>and it was nice because I didn't have to restart the server as I was walking around and changing thigns
<wingo>ACTION nod
<wingo>in 3.0 i would like to simplify structs. there they incur some overhead in space and time because they support the goops feature of class redefinition
<wingo>i.e. a struct with one field has three words: one for the vtable, one for the single slot, and one pointing to the slots
<ijp>death to fat structs!
<wingo>to get to slot 0 you have to do a double-dereference: first to get the slots, then to get the slot
<wingo>hehe
<ijp>wingo: are commenters on your blog trying on purpose to defeat your spam filter? see e.g. https://wingolog.org/archives/2016/01/11/the-half-strap-self-hosting-and-guile#2eb3af8d2f1754b0e8ff97605b45d745793236ec
<ijp>or is this what the face of modern spam looks like
<wingo>i think this is just the face of modern spam :/
<ijp>I'm partly impressed, partly very confused
<paroneayea>wingo: I personally think that low-level structs shouldn't need to be redeinition'able
<wingo>heh yeah
<wingo>paroneayea: yeah i guess that's where i'd like to go. i wonder though...
<paroneayea>wingo: can goops slot rederinition still work even if low-level records don't follow that?
<paroneayea>*redefinition
<paroneayea>eg by making a totally new struct and etc
<wingo>like there's some GC implications that if we had a better GC, maybe we could support redefinition without the indirection
<wingo>that would require a moving gc though
<wingo>anyway :P
<wingo>paroneayea: yes it can but a goops object will have to contain that indirection itself
<wingo>basically all goops objects would become two-word structs; boxes that can be mutated
<paroneayea>wingo: I think I'm okay with that
<paroneayea>wingo: I expect GOOPS to be a bit more expensive than say srfi-9 records
<paroneayea>wingo: would it really be much more expensive leaving the indirection in goops than it is having it in the lower layer?
<wingo>paroneayea: i think it would be more expensive but i don't know by how much.
<wingo>but anyway i think we can continue to support it and not too expensive, so it sounds like a win
<paroneayea>wingo: sounds good to me :)
<wingo>in some ways i would like the expressiveness of goops without the overhead of the ability to redefine classes, but i think we can't abandon that capabilit
<wingo>y
<paroneayea>wingo: which other expressiveness... generic methods and etc?
<paroneayea>wingo: though iirc you were hoping to get generic methods to work with srfi-9 records too right?
<wingo>the expressiveness of goops relative to just records, i mean
<wingo>so yeah, generic methods and such
<wingo>good question about class-of on srfi-9 records tho
<wingo>hummmmmmmmmmm.
<paroneayea>wingo: if we could get records to support generic methods, we might be able to have goops basically be the place to go when you do want inheritance and/or redefinition live hacking foo, but have records be a lot more expressive than they are now
<paroneayea>over time I've come to feel like generics have simplified a lot of my code, though this may be influence from that Sussman talk on live hacking
<wingo>tx for thoughts
<wingo>ACTION zzz for now
<paroneayea>gnite wingo :)
<paroneayea> https://vimeo.com/151465912 is the Sussman lecture I was talking about I think