IRC channel logs

2017-05-21.log

back to list of logs

<paroneayea>aurgh
<paroneayea>my package is failing to install modules with make install and I can't figure out why
<paroneayea>oh
<paroneayea>derp
<daviid>I'm writing a latex.m4 macros that uses guile, that depends on a tiny module that I intend to place in buid-aux/latex.scm
<daviid>so the main macro looks like this (pasting 4 lines)
<daviid>AC_DEFUN([LATEX_CHECK],
<daviid> [#AC_REQUIRE([LATEX_GUILE_M4_SUPPORT_CHECK])
<daviid> $GUILE -c "(add-to-load-path $(top_builddir)) (use-modules (build-aux latex)) $2" > /dev/null 2>&1
<daviid> $1=$?
<daviid> ])
<daviid>
<daviid>though the above does not work of course, that is my question:
<daviid>what should I do to have this subsituted: (add-to-load-path $(top_builddir)), anyone ?
<mwette>$GUILE -L "$(top_builddir)" -c "(use-modules (build-aux latex)) $2" ???
<daviid>mwette: ah, let me try, thanks a lot for your help
<daviid>better, but still fails
<daviid>checking for \\documentclass{standalone}... ./configure: line 12111: top_builddir: command not found
<daviid>no
<daviid>probably some stupid tipo on my side, let me double check
<daviid>the substitution leads to this line
<daviid>$GUILE -L $(top_builddir) -c "(use-modules (build-aux latex)) ... so it miss the "
<daviid>hum, added, but now i see there is no substitution, here is the line after my last change:
<daviid>$GUILE -L "$(top_builddir)" -c "(use-modules (build-aux latex)) (exit ((lambda () (latex-check-for-document-class \\"standalone\\"))))" > /dev/null 2>&1
<daviid>gnulib relocatable.m4 does this: ... "\\$(top_builddir)" ... but here it does not trigger substitution, in the configure file I get "\\$(top_builddir)"
<daviid>gnulib gettext.m4 does almost the same, but: ... "\\${top_builddir}" ... no substitution either, so in configure i get this line
<daviid>very frustrating :(
<daviid>#autotools did not answer so far either, they probably all know ...
<rekado_>I’d like to edit some XML with Guile. There is apply-templates, but it requires unambiguous match descriptions for nodes.
<rekado_>is it possible to use sxpath to describe nodes instead?
<rekado_>that would be the prettiest interface: zoom to a node via sxpath and return a new tree.
<janneke>rekado_: i've used xml->sxml once, really great
<rekado_>janneke: oh, yes, I’m working on sxml, actually
<rekado_>I’d like to be able to write a few xpath specs and then ask for a new tree, where each match has been replaced with the result of a handler.
<wingo>is daniel hartwig still around?
<rekado_>the sxml tree fold seems to not support sxpath.
<snape>I can't get append! to work on empty lists. Is that normal?
<ijp>yes
<ijp>most of the confusion around foo! functions on lists stems from the fact that lists aren't single objects in scheme
<snape>I see. But set! works on empty lists. That's where I'm confused.
<snape>I'd expect the append! implementation to kind of re-use set! if its first argument is an empty list
<amz3`>snape: you rather not use ! procedures for the time being
<amz3`>fwiw I never used append!, but I do use set!
<ijp>snape: I think you are also a little confused about set! fwiw
<amz3`>also mutation doesn't necessarly provide optimisation afaik
<ijp>try writing out your idea using set! and see if you realise why it can't do that
<amz3`>ijp: fwiw, I created a small editor using your fingertrees datastructure :)
<ijp>ah cool
<amz3`>it's less featured than guile-on-zile tho
<snape>ijp: my idea works with set!. I wanted to do (append! list list2) instead of (set! list (append list list2))
<snape>to avoid the 'list' repetition
<ijp>snape: I mean write append! to use set!
<snape>ijp: that would be a bit overkill :)
<ijp>anyway, you are supposed to use set! with foo! on lists
<ijp>you can't get around it, in general, because lists are not a single object
<snape>yeah, got it
<snape>thanks
<rekado_>I’m now using pre-post-order, which is a bit heavy for my use case, but works fine.
<amz3`>rekado_: what are you talking about?
<AndroUser2>Hello
<amz3`>welcome AndroUser2
***AndroUser2 is now known as YellowSphere
<artyom-poptsov>YellowSphere: Hi!
<sneek>Welcome back artyom-poptsov, you have 1 message.
<sneek>artyom-poptsov, civodul says: here's the fix i used for Guile-SSH in Guix: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/ssh.scm#n230
<artyom-poptsov>sneek: Later tell civodul: Thanks, I fixed that bug -- see my email.
<sneek>Will do.
<civodul`>thanks artyom-poptsov
<sneek>civodul`, you have 1 message.
<sneek>civodul`, artyom-poptsov says: Thanks, I fixed that bug -- see my email.
<YellowSphere>artyom-poptsov: I'm the one who does shy project
<artyom-poptsov>YellowSphere: I see. Welcome to #guile!
<artyom-poptsov>Feel free to ask Guile/Scheme related questions here.
<amz3`>YellowSphere: what is shy project?
<artyom-poptsov>amz3`: We (I and YellowSphere) are trying to write a Bash lint (a static analyzer) in Scheme: https://github.com/artyom-poptsov/shy
<artyom-poptsov>It's a work in progress though, no stable version yet.
<YellowSphere>amz3`: my project's program checks deprecated syntax of .sh files
<amz3`>oh!
<amz3`>I am a bash noob
<YellowSphere>Just small program that checks syntax.
<amz3`>a linter of some sort?
<YellowSphere>Something like that
<spk121>Good morning, Guile. Here's a question. I needed a procedure to find the name of the current procedure. Here's what I came up with. http://paste.lisp.org/display/347217 Is there a better way?
<amz3`>we need something like that for Guile too
<amz3`>maybe you will come up with a framework for building linter in scheme :)
<ijp>I don't think __FUNC__ needs to be a macro, although the other two might need to be
<ijp>of course, if you do it as a function it might give weird results if it were ever tail-called
<artyom-poptsov>civodul: There are two segfaults during Guile-SSH tests with Guile 2.2 (I perform testing in a Docker container <https://hub.docker.com/r/avvp/debian-guile/>). Currently trying to pinpoint the cause of the errors.
<ijp>spk121: the only real improvement might be to make them identifier macros
<spk121>ijp: Thanks. "identifier macros"? I guess I'm unfamiliar with the term.
<ijp>spk121: (info "(guile) Identifier Macros")
<ijp>essentially it would let you use __FILE__ rather than (__FILE__)
<ijp>it might be possible to do __FUNC__ statically using syntax parameters, but my macro-fu is rusty
<ijp>but I think that would involve redefining define, which is not what we want
<spk121>ijp: Cool. Thanks again.
<ijp>I suppose the consolation is that the loop is probably never going to be more than a few iterations in practice
<amz3`>mwette you here?...
<amz3`>brendyn: what's up?
<janneke>i'm wondering about non-pre-compiled info
<janneke>would it be possible to have instead of (not compiled):
<amz3`>davexunit: did you have a look at my frontend framework https://amirouche.github.io/forward.scm/ ?
<janneke>#<procedure 2495d20 at ice-9/eval.scm:348:13 (a b c d e f)>
<janneke>instead have something closer to (compiled):
<janneke>#<procedure f22e60 at /home/janneke/src/mes/module/language/c99/compiler.mes:1765:45 (functions globals ta t d data)>
<brendyn>amz3`: Not much, just been doing a little bit more of SICP
<amz3`>ACTION did not read SICP yet.
<amz3`>I must be the only one here
<spk121>amz3`: nah. I never got around to it. But I was never much of a student of compsci. Just a poor engineer trying to make the computer do the things...
<amz3`>spk121: me too :)
<brendyn>Well I have to learn from somewhere since i self teach
<amz3`>brendyn: you don't prior CS knwoledge?
<brendyn>Nope
<amz3`>brendyn: then it makes sens you read SICP
<brendyn>There are many things even in the first few chapters/lectures that are profound and interesting, and they show you how to write good software instead of just mashing stuff together with guesswork
<amz3`>catonano: o/
<catonano_>amz3`: ehy ;-)
<amz3`>catonano_: doing good?
<catonano_>well...
<catonano_>I realized that packaging stuff for guix is daunting ;-)
<amz3`>daunting?
<catonano_>it' s ok, really. Just jioking ;-)
<catonano_>yes, daunting
<amz3`>I don't daunting, /me looking up wiktionary
<catonano_>lots of litte things to know
<amz3`>catonano_: yeah! completly correct statment
<catonano_>a lot of work
<catonano_>a not so much reward
<catonano_>I' d like to do something more fun, now
<amz3`>catonano_: we see various distro in the wild and you think it's like the pacific ocean, a natural ressources, but actually it's a lot of work
<catonano_>right
<catonano_>I can' t do concurrent programming
<amz3`>youtube UI is so painful, less painful that fbk but still
<catonano_>I have a hard time reading the Guile manual
<catonano_>I was reading about concurrency in Clojure
<catonano_>Clojure for the Brave and True
<amz3`>what does it says?
<catonano_>but I think I have read-o-fobia
<amz3`>yeah, coding is more fun ;)
<catonano_>it introduces promises and futures
<catonano_>and something else
<amz3`>ah ok I know promises from javascript hacking
<catonano_>I hope I can map those primitives to Guile things, later
<amz3`>and I think I've stumbled on future in Python, they are somewhat related
<catonano_>yes
<amz3`>fwiw I published a new video https://www.youtube.com/playlist?list=PL_jCPpfzyfeqqEcioz71x5XvXnq9UABdK
<catonano_>amz3`: thanks ! Now I' m busy but I will watch them !
<amz3`>catonano_: it's not verrrrrrrrrrrrrrrry interesting
<amz3`>it basically show how painful it is to code :)
<catonano_>amz3`: oh come on now ! Don' t be shy ;-)
<amz3`>catonano_: va bene :)
<catonano_>amz3`: -)
<paroneayea>bonk
<paroneayea>hello
<artyom-poptsov>paroneayea: Hi!
<paroneayea>hi artyom-poptsov
<amz3`>mwette: :
<amz3`>mwette: :)
<mwette>amz3: :)
<paroneayea> https://gitlab.com/dustyweb/pubstrate/commit/6b00373a3129ca511e0229a311508d8009391da6 that's a lot of removed code :)
<janneke>paroneayea: no longer needed code, good riddance :)
<paroneayea>janneke: :)
***ertesx is now known as ertes