IRC channel logs

2017-05-19.log

back to list of logs

<reepca>Is there a way to import symbols from a module that isn't exporting them? Sorta like common lisp's some-package::not-exported-symbol syntax?
<reepca>I have a need to shadow a function for a period of time, but it's in another module and not exporting it
<nalaginrut>morning guilers~
<reepca>Hm, it looks like I can get something similar to what I want by using module-variable, is there a "let" that operates on variable objects instead of symbols?
<reepca>Is there a way to create a binding from a symbol to a variable directly? I can create bindings from symbols to variables containing variables using ordinary define, set!, let, etc, but not bindings from symbols to variables as far as I can tell.
<reepca>(specified variables, that is)
<reepca>So that, for example, I could create an alias of a variable
<janneke>morning nalaginrut!
<nikita1>morning!
<reepca>wingo: regarding guile-sqlite3, will statements be finalized on program exit? Does it matter?
<wingo>reepca: nothing is guaranteed to run at program exit. i don't know if it matters; i assume not but i don't know
<wingo>been a while since i looked at the sqlite stuff
<reepca>I don't suppose there's a hook of some sort for program exit?
<manumanumanu>Good morning guilers!
<wingo>good morning manumanumanu :)
<lloda>ACTION very happy with the readline fix as a paster of whole files :D
<wingo>lloda: yeah!!!!
<wingo>a silly thing but zomg how useful is it
<wingo>ACTION is also a paster
<dsmith>Ya, pasting is why I don't enable readline in .guile
<wingo>dsmith: you can now :)
<wingo>just fixed it
<wingo>if you have readline 7.0 anyway
<dsmith>Bah! 6.3
<wingo>:)
<wingo>guix has 7.0 :)
<dsmith>Wooo! Confimed. Start new job on Monday.
<wingo>dsmith: congratulations :-)))
<nalaginrut>aha, fixed a big problem to avoid I/O exception to stop the server core
<nalaginrut>artanis is more robust now
<nalaginrut>to whom care, someone helped to build a docker for artanis: https://github.com/bopjiang/artanis-docker
<nalaginrut>not maintained by me
<civodul>arrrgh doooockeerr!
<nalaginrut>well, someone made it and mentioned me, I even don't know how to play with it
<civodul>sure, i was kidding
<nalaginrut>see you tomorrow, I can have a good sleep now
<stis>heya guilers!
<stis>I've been relaxing for months. Time to do some work.
<stis>maybe check somthing on wingo's list for 2.2
<wingo>heya stis :)
<wingo>relaxing is nice
<stis>yeah, especially since work is taxing ;-)
<stis>anyway you had a list, do you have an url for it?
<wingo> https://wingolog.org/archives/2016/02/04/guile-compiler-tasks
<stis>thx
<stis>So I start with stripping binaries
<stis>my question is how to control that feature?
<stis>I could just make an api that strip it and you can hook it in a good way later.
<stis>Also from what branch should I work?
<stis>wingo ^^
<wingo>it should be a compile option eventually controlled by a command-line argument -gN
<wingo>like -ON in guild compile
<wingo>-g0 == no debugging info
<wingo>well, then there is stripping. that's a little harder, i would get the functionality working first then figure out ui
<stis>ok
<wingo>i think you can work from stable-2.2, it's easiest, then we can merge to master if/when the work is merged to stable-2.2
<wingo>unless you have a reason to break compat
<wingo>in which case master
<stis>Oki, I make an api for the funcitonality first
<stis>that should mean stable-2.2
<amz3`>io #guile
<janneke>o/
<stis>OKey I taook a stab at it. diff sent to maillist. No I need to compile guile and test it
<stis>guild compile -O0 will test it
<stis>and then load the module and see if somethinf bails
<stis>Shall we have a specific guild compile option for removing debug information? Or is -O0 enough?
<stis>wingo ^^
<stis>argh did some simple misstakes with call-with-values. now fixed
<paroneayea>civodul: hey there
<civodul>hey hey!
<paroneayea>civodul: just pushed most of the guix code, sans tests, to guile-gcrypt
<paroneayea>civodul: re: tests, I'm really not sure what the "best" way to add tests is. The way I've been doing it is by borrowing this tests/utils.scm file I've copied from some repo of davexunit's and keep copying around since!
<paroneayea>it's served me well but clearly Guix is doing something different
<paroneayea>civodul: do you have any advice?
<civodul>paroneayea: Guix uses (srfi srfi-64), which Guile provides
<civodul>i'd recommend to just use that :-)
<civodul>that way you can take tests/gcrypt.scm as is
<paroneayea>civodul: right, that's what I use too, it's just, how to hook it up to "make check"
<civodul>right!
<civodul>we have build-aux/test-driver.scm by mthl, for srfi-64
<paroneayea>what davexunit's utils thing does is changes the way it exits I think?
<civodul>it's wonderful
<paroneayea>civodul: oh! I didn't know of this
<paroneayea>civodul: I'll take a look.
<civodul>hopefully it'll find its way in Automake
<paroneayea>civodul: aside from copying over the file, what else might I need to do to hook it up?
<OrangeShark>paroneayea: just need to change in the makefile to use it as a driver
<OrangeShark>paroneayea: https://gitlab.com/amirouche/guile-git/commit/e5b91503ce0b7a0938693109450ed96606ae9d3f
<paroneayea>OrangeShark: ok, thank you!