IRC channel logs

2017-04-29.log

back to list of logs

<apteryx[m]>How do I split a string on newline character?
<daviid>apteryx[m]: string-split
<apteryx[m]>I tried using #\\n as the char_pred but that didn't split it correctly :/
<apteryx[m]>#\\
<apteryx[m]>Hmm. irc client is being too smart: pound-backslash-n
<daviid>#\\newline
<apteryx[m]>thanks :)
<daviid>welcome
<chatter29>hey guys
<chatter29>allah is doing
<chatter29>sun is not doing allah is doing
<chatter29>to accept Islam say that i bear witness that there is no deity worthy of worship except Allah and Muhammad peace be upon him is his slave and messenger
<amz3`>io #guile!
<amz3`>ACTION sings
<amz3`>ACTION sings “I am running chickadee! I am running chickadee!”
<amz3`>sorry daviid
<amz3`>oh no!
<amz3`>my plan is to create a imap client using chickadee for the ui
<amz3`>I will port the termbox API to chickadee and implement somekind of imap4 client myself (because GNU mailutils is not documented in this regard)
<amz3`>there is also libetpan but...
<amz3`>seems like a complicated pieace of code
<amz3`>so I need to have regex!
<amz3`>guix has it hourra!
<catonano>ow hard would it be to have this thing running in Guile ? https://github.com/fisherdj/miniAdapton
<catonano>what are those .sld files ?
<amz3`>catonano: is there a documentation that comes with it somewhere?
<amz3`>found some stuff STFW
<catonano>amz3` well, there's this article http://scheme2016.snow-fort.org/static/schemeworkshop2016-miniadapton.pdf
<catonano>what does STFW mean ?
<amz3`>Search The F... Web
<amz3`>it's like RTFM for the web
<amz3`>it means I lookup on duckduckgo what it means
<catonano>amz3` ahh I see ;-)
<catonano>amz3` there is also this awesome talk https://www.youtube.com/watch?v=bmpu1N2yf-k&feature=youtu.be
<amz3`>that's what I am watching just right now
<catonano>I'd like having that thing running in Guile and play with it a bit
<catonano>it'd be cool and it could be useful to a project of mine
<amz3`>how to you plan to use it?
<catonano>also it is very similar to a clojure library used in Hoplon for web based GUIs
<catonano>I am trying to improve the prototype taht I made with your grf3 thing
<catonano>I need to coordinate a data structure in ram with the writes I make to the db
<catonano>it can happen that a package gets updated while there are some instances in ram representing that package
<catonano>I need to update thos instances too
<catonano>I solved it witha hhack. It works but it's ugly
<catonano>so I was mumbling wether that thing could fit
<catonano>amz3` could you manage to have that thing run in guile ?
<amz3`>idk
<amz3`>I see incremental computation can be useufl
<amz3`>useful*
<amz3`>catonano: I will have a look at it closely tomorrow
<catonano>amz3` thanks !
<catonano>amz3` do you mind if I ask on the mailing list too ?
<amz3`>catonano: I don't mind
<amz3`> byrd is using guile to make the demo
<amz3`>bad thing is that there is no licence in the repository
<catonano>amz3` I know Byrd is using Guile in the demo. I'm not sure I can manage
<catonano>amz3` I did post on the mailing list anyway
<catonano>I could ask the author to include a license
<amz3`>catonano: I filled an issue in the repository
<catonano>amz3` ah thanks
<manumanumanu>Why is using fx-specific operations slower?
<manumanumanu>By a lot?
<manumanumanu>fixnum operations, as in (rnrs arithmetic fixnums)
<manumanumanu>changed a project euler thing to use fixnum specific operations, and everything took 3x as long.
<manumanumanu>I suspect that they are the same as the regular ones, but checks whether the numbers over- or underflow. But I thought the whole idea of having fx-operations was speed and interoperability with C.
<manumanumanu>ok. no bug. it is known. Found info online.
<amz3`>who was trying to run chickadee recently?
<amz3`>anyway, it works with guix + ubuntu
<quigonjinn>in writing a guile wrapper for a c library, do preprocessor defined constants have to be defined explicitely in scheme?
<amz3`>yes
<amz3`>that said sometime some preprocessor defined constats appear in the header but are only used internally
<quigonjinn>amz3`: thanks. in my case, some need to be given as arguments to functions
<nikita1>nalaginrut: hi!
<nikita1>nalaginrut: Artanis, when crashes, cannot print properly a backtrace, it always prints "ERROR: In procedure vector-ref: Value out of range: 156". Where to find the issue?
<daviid>hello guilers!
<daviid>amz3 it is fine, you are free to choose the platform of your choice for your ui :)