IRC channel logs

2017-04-16.log

back to list of logs

<paroneayea>resuming prompts called from prompts when the inner resumed prompt might return to its original prompt seems to promptly result in a bad time
<paroneayea>but it's probably just that I've tried to do something outside of my smarts level
<paroneayea> http://paste.lisp.org/display/344368 is what I mean
<paroneayea>I seem to always forget that I can't do this
<paroneayea>but I think I've run into problems where I try to call the continuation in another prompt results in some weird thing with the stack building up prompts
<paroneayea>er, appending prompt tags, or something
<paroneayea>but maybe I'm wrong
<brendyn>So I'm interested in making myself a blog. Any recommendations for tools to use? Maybe Skribilo?
<adfeno>I'm currently trying to use GNU Artanis and Emacs Org mode to make something similar to a blog.
<brendyn>I'm currently typing up my ideas into an org file, so that may be useful
<adfeno>I have read that org has a functionality called "publishing" that migh come in handy.
<adfeno>And has an HTML exporter :)
<brendyn>Isn't Artanis for dynamic sites?
<adfeno>I don't know though.
<adfeno>I'm still testing :)
<adfeno>Trying to )
<paroneayea>brendyn: Haunt is pretty popular here
<paroneayea>for blogmaking and etc
<paroneayea>brendyn: Guix, Guile, and 8sync's websites are all done in Haunt
<paroneayea>same with http://activitypub.rocks
<adfeno>I wonder if Haunt is able to accept Org mode documents, or HTML documents that come from Org mode documents.
<adfeno>This would be an interesting test to do
<paroneayea>adfeno: you'd need a reader for it. For html, you could maybe use guile-lib's html reader
<paroneayea>for orgmode itself
<paroneayea>you'd want to write your own reader
<paroneayea>or
<paroneayea>have org-mode export to s-expressions or xml, which I think it can do both of
<paroneayea>and then read from that
<adfeno>My worry is that it might be also be needed to strip some tags from the HTML export, as far as I can remember.
<adfeno>I recall that Haunt seems to use some pre-HTML content.
<adfeno>Not too big of a deal if there is a way to tell Org to use a preamble of some sort.
<adfeno>But still, the HTML export would probably still have full <html><head></head><body></body></html> structure which needs some behavior test with Haunt. :)
<paroneayea>ACTION figured out what they were confused about earlier
<adfeno>paroneayea: What was it about? :)
<adfeno>Oh my...
<adfeno>Now it's the `art' executable (from GNU artanis) that has a setlocale right in the beginning of it, and that is giving me error. :(
<adfeno>Just because it does (setlocale LC_ALL "")
<adfeno>It gives: procedure setlocale: invalid argument
<brendyn>I thought I would try switching to gnus from thunderbird for mail. gave up after an hour of trying to connect to a pop server ;/
<daviid>adfeno: what version of guile are you running? (setlocale LC_ALL "") is fine here, both 2.0.14 and 2.2.2
<daviid>2.2.0 I meant
<adfeno>2.2.0
<adfeno>brendyn: Which is problem with connecting to pop?
<daviid>adfeno: just to convince yourself, fire a session and just copy paste that code
<adfeno>brendyn: I use it normally with OpenMailBox server
<adfeno>daviid: Will do :)
<daviid>adfeno: the problem is elsewhere
<daviid>adfeno: are you sure your locale are actually installed on your system?
<adfeno>daviid: Hm... the problem is elsewhere indeed...
<daviid>sure
<adfeno>I did as you said ::)
<adfeno>And (setlocale LC_ALL "") returns "pt_BR.UTF-8".
<daviid>yep, good!
<adfeno>I'll try rebuilding ARtanis here :)
<brendyn>adfeno: I have openmailbox too but I could never get pop to work even in thunderbird. can i see your config (without your password)
<adfeno>OK:)
<brendyn>my bank card expired so im just going to get my domain and and a new vps with bitcoin lol
<adfeno>brendyn: See http://paste.lisp.org/display/344371
<adfeno>For POP, the most important part is
<adfeno>mail-sources '(...)
<adfeno>And if you didn't set a storage backend yet, the other important one is: gnus-select-method '(nnfolder "")
<brendyn>I was gettin authentication failure
<adfeno>Hm....
<adfeno>I wonder if this happens again now.
<brendyn>Ok it's working. I wonder where my mail is going ^.^
<brendyn>I had to set my user to user@openmailbox.org, not just user
<adfeno>brendyn: Yep, thats right it's user@server.com
<adfeno>Strange indeed, but OK
<brendyn>All my mail is about 100MiB
<brendyn>99.9% Guix mailing list
<adfeno>daviid: Still, the art executable gives me that error... I'll try using Artanis through the guile executable instead of the art executable
<daviid>adfeno: I don't use artanis, try to grab a working example from its doc, and write a tiny snipset if it still fals, then file a bug to its bug mailing list ...
<daviid>* fails
<adfeno>Indeed, I'll definitely try that :)
<adfeno>I'll do that tomorow though... almost falling asleep, it's night time here. :)
<daviid>good night
<adfeno>Thank you all very much for helping out :)
<daviid>welcome
<Amynka>wingo: dont wanna complain but is it possible if I download guile-2.2 and open readme there is "This is version 2.0 of Guile," ?
<Amynka>(I thought I have bad tarball)
<Amynka>hm fro mchangelog seems i have good one
<amz3`>o/
<Saikyun>hello! I'm super new to guile and I'm having some trouble with using modules. I'm trying to run the sample at: https://dthompson.us/projects/chickadee.html
<Saikyun>but I can't run it, because it can't find sdl2
<Saikyun>I've built the libraries and included their paths in the %load-path
<Saikyun>is there another step I must perform in order to use modules?
<Saikyun>I'm using geiser + Emacs as my environment, and I've just tried running (load "main.scm") where main contains the sample that's on their website
<amz3`>is there any example app using guile-ncurses?
<amz3`>\\o/
<amz3`> https://github.com/jepugs/nc-snake
<adfeno>Hi #guile ! :)
<adfeno>In GNU Artanis, how do I get the "path" part of a route context ?
<adfeno>For example, suppose I have a HTTP GET rule like this (get "/test/complex/path:a" (lambda (rc) ...)), how can I take the "/test/complex/path" part for further evaluation?
<adfeno>In GNU Artanis, how do I get the "path" part of a route context ? For example, suppose I have a HTTP GET rule like this (get "/test/complex/path:a" (lambda (rc) ...)), how can I take the "/test/complex/path" part for further evaluation? [2]
***sethalves1 is now known as sethalves
***ertesx is now known as ertes
<rvmba>hello
<rvmba>i have been playing with guile recently and i have a question, why is there no function to check for containment on lists?
<rvmba>or is there one and i'm too blind to see it?
<paroneayea>rvmba: member ?
<paroneayea>and if you need to control the equality predicate, you can use the srfi-1 member variant
<rvmba>paroneayea: indeed i missed it, thanks !
<rvmba>i'll get going then bye :)