IRC channel logs

2017-03-29.log

back to list of logs

<amz3>hélllllllllo #guile!
<wingo>has anyone implemented zlib in guile yet
<wingo>or DEFLATE compression/decompression rather
<Apteryx>How do I split a string? I want the tail of a path which comes after ".../man/"
<civodul>wingo: i think Industria has a pure Scheme implementation of it
<civodul>otherwise there are bindings to the C lib
<Apteryx>string-contains looks like a contender
<wingo>ah right. i should take another look at industria
<wingo>i want to see how fast/slow guile is
<wingo>Apteryx: string-split
<wingo>see the manual :)
<daviid>lloda: heya! do you have a fast m,atrix multiplicatin algo somwehere? Coppersmith-Winograd maybe?
<daviid>or anyone else of course :)
<lloda>daviid: I use cblas, my own bindings
<lloda>I have published ffi bindings, unfinished, but the xgemm functions are there
<lloda> https://notabug.org/lloda/guile-ffi-cblas/src/master/mod/ffi
<lloda>I always thought winograd curiosity, since performance always seems to be dominated by cache issues, ime
<lloda>curiosity/a curiosity
<lloda>so much work goes into tuning these routines, it's pointless to write your own
<daviid>lloda: thanks. guile-cv which binds vigra, have images reprented by f32vector, would that work?
<daviid>it seems it would yes
<lloda>that would be sgemm/sgemv, yes
<lloda>cblas doesn't support all possible strides, so you have to be aware of that
<lloda>my ffi bindings don't support negative strides, either
<lloda>cblas does those in a strange way :-p
<random-nick>are 2 #f values always eq?
<lloda>iiuc there's only one #f value, so yes
<dsmith-work>Wednesday Greetings, Guilers
<Apteryx>How do I know what kind of exception I am dealing with? The error is: "ERROR: In procedure symlink: File exists", and I'd like to catch and handle this exception.
<Apteryx>Is it a 'system-error? How am I supposed to be sure?
<Apteryx>wingo: Thanks for the above answer! I had to use string-contains since I'm interested in spliting based on a substring rather than a character.
<Apteryx>dsmith-work: Greetings :)
<Apteryx>It's already Thursday here.
<janneke>ACTION is voting for a GNU standard time
<davexunit>GNU standard time is US eastern time since that's where the FSF is
<janneke>happy gnu evening, in that case ;-)
<janneke>oh wait... gnu afternoon
<Apteryx>hehe
<Apteryx>What do I put in my exception handler to do... nothing?
<Apteryx>In Python that'd be a "pass".
<davexunit>Apteryx: #f, #t, anything like that
<Apteryx>davexunit: OK :)
<Apteryx>Thanks!
<wingo>mew
<Muto>Meow
<sneek>wuf
<Muto>Arf!
<davexunit> /topic #guile - pet sounds
<Muto>Maybe I'll write a virtual pet in Guile.
<OrangeShark>Muto: a virtual pet Gnu
<wingo>aaah, i think i can include lots of nice things in a guile sandbox: datum->syntax, eval, and so on
<Muto>OrangeShark: That would be amazing!
<void_pointer>Wonder if the new syntax stuff will make debugging syntax-case macros easier
<void_pointer>Had just made my first syntax-case macro this last weekend and it was quite a bit of work to get it working and debug it
<void_pointer>And worst of all, once I got it working, turns out that it was insufficient for the job and had to come up with another solution (basically, another syntax-case was acting before it)
<void_pointer>Will be interesting to see the new syntax objects when they are done
<lloda`>void_pointer: I just suffered through some syntax-case pain recently.
<lloda`>iiuc the new syntax objects are just meant to make them a distinct type instead of vectors or whatever the were before. No new features (wingo correct me)
<lloda`>I think just copying a few of the racket facilities like syntax->e, syntax->list, (define-syntax (m stx) ...) etc would help, if only so that the racket tutorials are easier to follow
<lloda`>b/c they're the best tutorials I've found, but they're aren't 100% standard rxrs
<void_pointer>lloda`: that does sound useful
<void_pointer>Haven't actually used the Racket tutorials that much because of them not being RNRS exactly
<void_pointer>Though have certainly gotten a few ideas from a few
<void_pointer>things Racket
<lloda`> http://www.greghendershott.com/fear-of-macros/pattern-matching.html has been useful to me in Guile
<lloda`>a couple of things are different but they're very minor
<void_pointer>Page looks familiar. I think I glanced at it half a year ago
<void_pointer>Thank you