IRC channel logs

2017-03-23.log

back to list of logs

<akkad>ACTION has $$ to waste on paying to port 5 lines
<davexunit>does a load-u64 vm op cause allocation?
***heroux_ is now known as heroux
***Amynka_ is now known as Amynka
<amz3>héllo #guile
<amz3>so i've setup a cli framework where if a procedure '(main ARG0 ARG1)' exists inside the module (foo bar baz) it's can be executed using: culturia foo bar baz ARG0 ARG1
<amz3>neat!
<thomasd>Hi #guile
<thomasd>Who did the artwork (and website design) for the Guile homepage? It's really well done.
<amz3>the person is not around I think
<amz3>the person also did guix website http://gnu.org/s/guix
<amz3>I prefer guix website :)
<thomasd>I prefer Guile :)
<amz3>looks like a kid website :/
<amz3>for kids or something
<thomasd>maybe that's why it appeals to me
<amz3>^_^
<amz3>except that fact, the guile website is great
<amz3>a lot of people come to say so
<amz3>thomasd: what are up to?
<thomasd>not much, try to contribute to Guix a little
<amz3>you contribue packages?
<thomasd>yes
<amz3>that's great
<amz3>I don't have the patience for contributing packages
<thomasd>also would like to review more (all packages that I really need are in Guix now), but it's difficult to do it right :)
<amz3>since I started using GNU/Linux I never packaged anything
<amz3>for guix, I made one or two packages
<amz3>for guix it's easy to do
<amz3>that's a great advantage of guix compared to debian
<amz3>I also tried to package some mozilla stuff but... it's was very complicated
<amz3>because of the change from python cffi 0.x to cffi 1.0
<thomasd>hi #guile, is there a call-with-... form that would work with sockets?
<thomasd>or to put it differently: what is the canonical way to (open-socket ... do-stuff-with-socket ... make-sure-socket-is-closed) ?
<thomasd>... and return a value obtained
<amz3>afaik there is no such thign
<thomasd>I work around it here https://lists.gnu.org/archive/html/guix-patches/2017-03/msg00655.html but I think there must be a better way :)
<amz3>you create a macro that does what you need
<amz3>using define-syntax-rule IIRC
<amz3> https://www.gnu.org/software/guile/manual/html_node/Syntax-Rules.html#index-define_002dsyntax_002drule
<amz3>here is another example https://framagit.org/a-guile-mind/guile-wiredtiger/blob/master/src/wiredtigerz.scm#L421
<thomasd>amz3: thanks. so is there a reason call-with-output-file exists (I think as part of the standard), but a general “call-with-port” doesn't?
<amz3>idk
<thomasd>ok :) just wondering, as a scheme beginner
<amz3>the reason might that in theory you don't open/close a socket in the "same" code
<amz3>I mean most of the time you close the port in another procedure or something like that
<thomasd>perhaps, I don't know :)
<davexunit>did some hacking for the first time in awhile last night. playing with particle simulations as I often do. optimized rendering and doubled the amount of particles I can handle. woo!
<thomasd>e.g. python has a “with” statement that's very nice for managing all kinds resources (which might actually be inspired by with-... constructs from lispy languages?), so I was wondering if a general method to ensure resource cleanup exists in guile
<davexunit>wingo: I tried out what we had discussed with fibers and I got very strange crashes so I abandoned it for now.
<dsmith-work>Thursday Greetings, Guilers
<add^_> http://hydra.nixos.org/job/gnu/guile-2-2/tarball/latest gives me a 404, but that's where the https://www.gnu.org/software/guile/download/ snapshot to 2.2 links to
<add^_>404 Not Found: Jobset ‘guile-2-2’ doesn't exist.
<amz3> o/
<civodul>add^_: sounds like overzealous search-and-replace :-)
<civodul> http://hydra.nixos.org/job/gnu/guile-master/tarball/latest works
<add^_>Hum
<add^_>But that's not "stable" right?
<add^_>I mean, the released "stable"
<civodul>currently there's no difference between "master" and "stable 2.2" :-)
<add^_>ok
<add^_>thanks :-)
<add^_>Oh, when I try to use the download-links it gives me a 404 again, and I just saw a note on the page "Note: this build is no longer available."
<add^_>for both the tar.gz and the tar.xz
<civodul>yeah that's possible, it means it has been GC'd from the build farm
***dje__ is now known as xdje
<ArneBab_>thomassgn: I built a wisp-replacement, but it does not handle continuations: https://bitbucket.org/ArneBab/wisp/src/3447d48e85620c639131c0e1b47308503df5eb81/examples/with.w
<ArneBab_>that was for thomasd … sorry