IRC channel logs

2017-02-09.log

back to list of logs

<wleslie>I wish human language had (gensym)
<polll>Weird question, but can you run guile on osx?
***whiteline_ is now known as whiteline
<wingo>good morning guilers
<wleslie>morning!
<webshinra>hey
<gracjan>hey
***wleslie is now known as notbottle
***notbottle is now known as wleslie
<paroneayea>hello #guile!
<roelj>How can I compare a string to whether it matches a string in a list?
<OrangeShark>roelj: so seeing if a string matches to a string in a list of strings?
<roelj>OrangeShark: Yes. So whether "AAA" is in '("AAA" "BBB" "CCC" "DDD")..
<roelj>All I can think of is looping, but there must be a better way
<OrangeShark>roelj: you can use any procedure
<OrangeShark>I think it is in srfi-1
<davexunit_>(member "foo" '("foo" "bar" "baz"))
<OrangeShark>(any (cut string=? "AAA" <>) '("AAA" "BBB" "CCC" ...))
<roelj>davexunit_: Thanks!
<roelj>OrangeShark: From what SRFI is "cut"?
<davexunit_>26
<roelj>heh thanks :)
<roelj>interesting
<OrangeShark>it basically like writing (lambda (x) (string=? "AAA" <>))
<OrangeShark>uh replace <> with x
<roelj>That's a handy shorthand
<amz3>héllo
<amz3>Does anyone have a querystring parser?
<amz3>s/parser/decoder
<amz3>nalaginrut!
<amz3>nalaginrut: do you have querystring decoder that works with utf8?
<amz3>I mean that works with % encoded utf8 chars
<paroneayea>amz3: https://gitlab.com/dustyweb/pubstrate/blob/master/pubstrate/webapp/utils.scm#L182
<paroneayea>GPLv3+
<paroneayea>feel free to snarf
<amz3>tx paroneayea my project is agpl3+
<amz3>that's uri-decode hat I am missing
<amz3>your impl looks better tho
<paroneayea>amz3: happily agpl3+ and gpl3+ are compatible. horray!
<amz3>it's good to read someone else code
<dsmith-work>Morning Greetings, Guilers
<amz3>o/
<spk121>Hi. Is there a png library for Guile?
<dsmith-work>spk121: For creating png's?
<dsmith-work>spk121: Dunno. Maybe this? :http://www.nongnu.org/guile-cairo/
<dsmith-work>spk121: http://www.nongnu.org/guile-cairo/docs/html/PNG-Support.html#PNG-Support
<spk121>dmith-work: Cool, thanks. I wonder if it still builds?
<paroneayea>hm
<paroneayea>s it time for a new 8sync release? Maybe 0.2.2 "The FOSDEM Release" (TM)
<paroneayea>then I could package mudsync for guix also I guess.
<paroneayea>oh 0.4.2, sorry :)
<daviid>spk121: guile-cairo still build using 2.2
<daviid>spk121: but not the latest tarball, either you clone the fit repo or you grab this 'prerelease' version
<daviid> http://download.savannah.gnu.org/releases/grip/guile-cairo/guile-cairo-1.10.0.tar.gz [and sig: my GPG key is: A3057AD7]
<daviid>s/fit/git (not that the git repo is not fit but ... :)
<dsmith-work>spk121: Be aware that guile-cairo is a guile+C wrapper around the cairo library. It's not a pure scheme thing.
<dsmith-work>spk121: It's actually a very good example of how to wrap a library.
<spk121>daviid: thanks
<spk121>dmith-work: indeed
<dsmith-work>sneek: bostnack
<dsmith-work>sneek: botsnack
<sneek>:)
<paroneayea>davexunit_: btw civodul suggested something interesting at FOSDEM
<paroneayea>maybe we should move your websocket code into guile itself
<davexunit_>paroneayea: that would be interesting
<janneke>yeah!
<paroneayea>davexunit_: btw I patched up the one bug I was hitting in the websocket stuff, but I'm not sure if it would hit something not using suspendable ports or not
<paroneayea>I guess maybe it would
<paroneayea>it was in the server code (which, as you said, was not permanent anyway... but still it mostly just worked); in the cond sometimes an eof object would still be returned as a frame despite there being a previous peek-ahead check for an eof object
<paroneayea>my guess is if there was a chunk of data to read and then suddenly it hit the eof-object in the midle of it, that's what triggered the bug
<paroneayea>davexunit_: despite that one-liner patched bug, I've still been pretty surprised and pleased with how easily the websocket stuff just worked right of the box. I barely had to do anything to get it working with 8sync.
<davexunit_>paroneayea: ah, interesting. I wonder why that happens. good find!
<davexunit_>I'm glad the code has been working well for you.
<paroneayea>:)
<paroneayea>it's pretty cool that even though your server was set up to only handle one connection at a time, once it was moved to a nonblocking event loop, multiple clients worked pretty seamlessly immediately.
<davexunit_>that's awesome. I didn't think that would work so easily.
<davexunit_>I need to go outside and shovel my driveway and porches now. we've got like 6 inches of snow on the ground right now and even more on the way. I'll read the backlog later to catch up.
<paroneayea>wow!
<davexunit_>paroneayea: I would like to hear about how your talk went at FOSDEM some time
<paroneayea>davexunit_: :)
<paroneayea>I think I just need to review it for it to be uploaded
<paroneayea>I should do that...
<paroneayea>davexunit_: but maybe I should give you a tour of the talk in-game :)
<paroneayea>beep beep