IRC channel logs

2017-01-31.log

back to list of logs

<daviid>lloda`: wrt to the code you pasted arlier, I don't know :): but just for the sake of experience, I suggest you edit the (system repl common) _installed_ module and (a) import (ice-9 pretty-print), and at the end of the repl-print proc, replace (write val) with (truncated-print val), save, start a new repl and trigger an error...
<lloda`>sneek: later tell daviid I've just tried and it gives the same result. It seems that repl-print isn't used on errors. There's probably some other function or hook.
<sneek>Okay.
<dsmith-work>{appropriate time} Greetings, Guilers
<daviid>hello guilers*
<sneek>Welcome back daviid, you have 1 message.
<sneek>daviid, lloda` says: I've just tried and it gives the same result. It seems that repl-print isn't used on errors. There's probably some other function or hook.
<daviid>lloda`: tx. I would be very interested to solve this too
<daviid>ACTION just submited Guile-CV for evaluation
<daviid>if anyoe is interested to give it a go, tarballs are uploaded here:
<daviid> http://download.savannah.gnu.org/releases/grip/guile-cv/ [GPG Key: A3057AD7]
<jmd>I wish there was a string-map-in-order function
<dsmith-work>jmd: Could you use string-fold ?
<jmd>I can.
<janneke>jmd: i'm reading scm_string_map and i'm wondering what you might be thinking
<jmd>janneke: What do you mean?
<janneke>your wish inspired me to think that guile would apply some kind of parallelism and I wondered how they would do that
<janneke>so i read the code, and it seems pretty much "in order"?
<dsmith-work>janneke: May be true, but that might change.
<dsmith-work>The order is not specified.
<janneke>dsmith-work: i would not hold my breath
<dsmith-work>Heh
<janneke>Haha, the documentation is a lie
<dsmith-work>Well, it has to be implemented one way or another. The spec just gives the implementor freedom to choose.
<jmd>I think it is the case that in the Scheme standard it is not specified. But in Guile it happends ot be implemented like that.
<dsmith-work>janneke: I disagree. The docs are not lying. They are quite truthful in saying that they are not saying.
<janneke>dsmith-work: yes sorry, i'm being too harsh/black-white
<janneke>i understand that things may change...
<dsmith-work>heh np
<dsmith-work>Think of it more as a hint to the user to not write code that depends on a specific order.
<janneke>but you can also read the docs saying: this function is terribly efficient, it will map your string in parallel
<janneke>that's not true either, it's a perfect in-order iterator...
<janneke>yeah, sure
<janneke>altough...if your test suite doesn't catch such a change in guile...
***jerme is now known as jerme_
<dsmith-work>I think it's supposed to be like if you want to be functional and just get results regardless of ordering, use map. If you care about ordering and side-effects, use for-each.
<amz3`>map doesn't guarantee to keep order?
<jmd>amz3`: no.
<amz3`>hmm
<paroneayea>hi #guile
<paroneayea>ACTION packing for FOSDEM
<paroneayea>*boy* am I excited
<paroneayea>the guile fosdem schedule just looks so good
<dsmith-work>amz3`: The results are in the same order, but it isn't specified the ordering that the function is applied.
<dsmith-work>first to last, last to first, all at the same time on many many core machine.
<daviid>it would be cool if someone going to fosdem could give a mini demo of Guile-CV, which itself is pretty cool! let me know...
<davexunit>paroneayea: enjoy!
<rekado_>I had assumed that the PEG support is in some obscure third-party package, but it’s actually part of Guile.
<rekado_>parts of the manual would benefit from a sprinkle of index keywords.