IRC channel logs

2017-01-27.log

back to list of logs

<AlfredENeuman>did guile 1.8 have foreign pointer objects?
<AlfredENeuman>something similar to this: https://www.gnu.org/software/guile/manual/html_node/Foreign-Variables.html
<amz3>davexunit: sorry to disturb you, I am wondering what are the immediate cappabilities of your latest project regarding drawing abstract figures
<amz3>AlfredENeuman: 1.8 is unsupported
<lloda`>I'm having to write Python these days and I miss Scheme multiple return values :-/
<masoudd>lloda`: Python functions can return tuples
<masoudd>like return 1, 2, 3
<OrangeShark>masoudd: lloda`: yeah, tuples are pretty nice in Python for multiple return values, you can then do x, y, z = foo() to get the 1, 2, 3
<paroneayea>hi hi
<wleslie>and foo(*bar()) if you want (call-with-values)
<wleslie>dsmith-work: happy Friday!
<lloda`>that's just like returning or applying lists in Scheme. With Scheme values I can add more return values without touching the consumers, they'll just discard the extra values. In Python the receiver has to be written diferently when it takes 1 value or when it takes more than 1.
<wleslie>it's still possible to add that functionality without breaking any API, at least if the caller looks the function or method up by name.
<davexunit>amz3: right now you can draw line segments. polygons not yet implemented.
<dsmith-work>Happy Friday, Guilers!!
<dsmith-work>wleslie: yey!
<OrangeShark>Happy Friday
<paroneayea>hit a bug in irregex I think
<paroneayea>but hell, maybe I shouldn't be using irregex for mudsync's parser
<paroneayea>it couldn't be that hard to break up a sentence into the things mudsync understands
<quigonjinn>is there a way to export all procedures from a module without listing them explicitely?
<amz3`>no
<amz3`>I mean maybe
<amz3`>quigonjinn: I use define-public instead of define to selectively export procedures
<AlfredENeuman> http://paste.lisp.org/display/337525
<AlfredENeuman>this is what i do
<avoine>amz3`: is this culturia new home or it's a fork? https://gitlab.com/humanitiesNerd/Culturia
<amz3`>avoine: it's a fork used by catonano_ to do some experiments regarding npmjs
<avoine>ok ok
<quigonjinn>AlfredENeuman: amz3` thanks!
<AlfredENeuman>no problem
<catonano_>avoine: that experiment is discussed here https://lists.gnu.org/archive/html/guix-devel/2017-01/msg01630.html
<avoine>ok, I'll check
<avoine>interesting