IRC channel logs

2017-01-19.log

back to list of logs

<paroneayea>I think I'm starting to understand what's happening
<davexunit>paroneayea: nice detective work!
<paroneayea>davexunit: thanks :)
<paroneayea>so, I think what happens is this
<paroneayea>previously the catch wrapping things would catch some signal which would happen any time after a client connected and then it would restart the loop
<paroneayea>without that, it just hangs
<paroneayea>that's my guess
<davexunit>paroneayea: sounds like a good hypothesis to me
<paroneayea>oops I'm dumb
<paroneayea>sent that to guile-devel instead of bug-guile
<paroneayea>wingo: what's the new behavior in accept mentioned in 206dced87f425af7eed628530313067a45bee2c2 ? I'm trying to figure out what the right fix for https://debbugs.gnu.org/cgi/bugreport.cgi?bug=25481 would be
<paroneayea>while I guess we could revert the commit, presumably that change was done for a reason due to some change in semantics
<wingo>greets
<wingo>paroneayea: accept on a non-blocking socket returns #f instead of throwing an exception -- iirc.
<wingo>i released a 2.1.6, if there is a fix for this bug we can release a 2.1.7 shortly thereafter
<wingo>ACTION wanted to be able to release fibers which depends on some newer things from guile
***micro` is now known as Guest24675
<wingo>heya paroneayea
<wingo>hey i tried a thing, with a 2-socket E5-2620v3 system i have at work, 6 cores per socket, hyperthreading off -- i got 9.8x speedup on a 12-core test with fibers relative to the same on 1-core
<wingo>not quite sure why i'm not getting 12x tho
<wingo>i want to release a new fibers but it would be nice if it worked with guix too
***berndj-blackout is now known as berndj
<PuercoPop>Is there a way to disable logging when using srfi-64 (the test suite API)
<wingo>paroneayea, rekado_: i think the fibers 0.5.0 release should be guix-compatible
<wingo>we will need to bump guile-next to 2.1.6 tho
<paroneayea>wingo: yay / nice :)
<paroneayea>wingo: great news both on the multi-core speedup and also fibers 0.5.0 hopefully being packaged in guix
<paroneayea>wingo: btw, I just tested reverting commit 206dced87f425af7eed628530313067a45bee2c2 and can confirm it fixes the bug on guile git master
<paroneayea>but, presumably you made that change for a reason, so probably reverting it isn't the desired action :)
<paroneayea>wingo: I'll be interested to read more on the changes to fibers 0.5.0. Hopefully tomorrow!
<paroneayea>and now, bed
<paroneayea>gnite!
<PuercoPop>is there a way to define default values to record fields? Or should I just define a function that calls the constructor and sets the fields accordingly?
<PuercoPop>nvm, I see GOOPS have the initform option I was looking for
<zv>Hey guys, I'm building a multi-feature S-expression encoder/decoder (and there are *TONS* of different variants of s-expressions) and I am thinking about how to encode true/false when serializing a struct/enum. There are many different ways to express 'true' and 'false' in different Lisps/Schemes, but Rivest and SMTLIB have no concrete stands on booleans
<zv>My question is: What different values are used for 'true' and 'false' in different lisps & schemes?
<zv>e.g #t & #f, t & f, etc
<lloda`>PuercoPop: you can disable logging to disk with (set! test-log-to-file #f), but I don't know how to disable logging entirely
<civodul>yay for Guile 2.1.6! \\o/
<OrangeShark>zv, many lisps uses any non-false value as true. Scheme uses #f for false and #t for true. Common Lisp and elisp uses nil for false and everything else as true
<davexunit>everything besides #f is treated as ture
<davexunit>true*
<civodul>even the unspecified value, though maybe that's unspecified
<janneke>civodul: where do i put the export GDK_SCALE=2 so that slim pick it up?
<civodul>janneke: in ~/.xsession
<civodul>or ~/.bash_profile
<civodul>that'll be picked up only when you log in, though
<civodul>all this sucks anyway
<janneke>:-)
<civodul>my laptop's screen is high-DPI but the big screen i plug it into is low-DPI
<civodul>so it seems there's no way to have a proper size on both screens at the same time
<janneke>yeah...i tried to believe in GNOME and that solves/hides most of these problems
<civodul>i think all GNOME has is GDK_SCALE
<civodul>so that's a global parameter
<cehteh>ACTION wonders too, how to make a multi screen setup where each screen has different dpi
<PuercoPop>lloda`: thanks! Not writing to disk will be enough for the time being
<dsmith-work>Morning Greetings, Guilers
<spk121>Hello Guile. I want to have Guile call C code that uses setjmp/longjmp. Will I run into problems?
<dsmith-work>spk121: Ooo! Be ware! Guile uses (used to?) {set,long}jmp and stack copying to implement call/cc.
<dsmith-work>hmm. I'm always annoyed by
<dsmith-work>net_db.c:468:***Missing or erroneous `#define FUNC_NAME s_AI_ADDRCONFIG);'
<dsmith-work>net_db.c:488:***Missing or erroneous #undef for AI_ADDRCONFIG);:
<dsmith-work>as guile is building.
<dsmith-work>can be fixed by a small change in guile-func-name-check
<dsmith-work>Instead of /^SCM_DEFINE/ something like /^SCM_DEFINE / or /^SCM_DEFINE[^_]/
<dsmith-work>It's picking up SCM_DEFINE_CONSTANT as SCM_DEFINE
***logicmoo is now known as dmiles