IRC channel logs

2017-01-16.log

back to list of logs

<nalaginrut>morning guilers~
<takside>hello, i'm having an issue with the (gnutls) module and was wondering if anybody knows why this is happening and if I can avoid it?
<takside>ERROR: In procedure %read-line:
<takside>ERROR: Throw to key `gnutls-error' with args `(#<gnutls-error-enum Error in the pull function.> fill_session_record_port_input)'.
<civodul>takside: you'd have to strace the process for more details, but it could be that there was ECONNRESET while reading from the remote end
<civodul>IOW, the remote end closed the connection prematurely
<takside>ok, thanks
<paroneayea>so!
<paroneayea>I had an interesting email exchange with Alex Shinn, author of irregex / fmt / etc many fine portable libraries
<paroneayea>and, until this morning, I didn't realize was chair of r7rs small and also main author of chibi scheme
<paroneayea>anyway I had submitted a patch to them to add guile packaging to fmt
<paroneayea>but they replied that they aren't maintaining that, and have a new r7rs only cleaned up library: http://snow-fort.org/s/gmail.com/alexshinn/chibi/show/0.7.3.1/index.html#h2_Background
<paroneayea>and that in fact in order to save effort on porting things, all their libraries will be r7rs only in the future
<paroneayea>they suggested we either support r7rs in guile more fully or build a r7rs -> guile converter
<wleslie>r7rs packaging is a big improvement over r6rs packaging, isn't it?
<wleslie>I remember it being a big *deal* and that was it
<paroneayea>I don't know much about r7rs
<paroneayea>though I remember on the fosdem panel last year andy made an r7rs-negative comment :)
<paroneayea>though I just read the "r7rs incompatibilities with r6rs" list, and it doesn't seem too daunting
<OrangeShark>r7rs has library stuff as part of r7rs small
<paroneayea>huh
<paroneayea>procedure-with-setter? doesn't work on accessors
<paroneayea>I wonder why not
<daviid>paroneayea: you can define setter methods on accessors, but you can't inherited them (which I reported a while ago, is a very old desisgn bug, but so far so bad...)
<paroneayea>daviid: I mean, I'm trying to see if it's a procedure that I can use with set!
<paroneayea>which theoretically, accessors can
<paroneayea>and (procedure-with-setter? this-accessor) => #f
<paroneayea>despite that I can use it with (set! (this-accessor obj) 'val)
<daviid>paroneayea: procedure-with-setter is not par of the protocol, it is a guile thing
<daviid>part
<paroneayea>daviid: sure, ok
<paroneayea>I'm just trying to find out in my code whether or not I'll be able to do (set! (...))
<daviid>procedure-with-setter? has nthing to do with gooops
<paroneayea>ok
<daviid>procedures are not methods ... as you know
<paroneayea>but (procedure? this-accessor) => #t
<paroneayea>procedures aren't methods, but aren't methods procedures?
<daviid>we could talk for a long time, but i think all this is guile internal, what are you trying to do if i may ask?
<paroneayea>oh!
<paroneayea>(procedure-with-setter? this-accessor) => #t ; guile 2.2
<paroneayea>:D
<paroneayea>thanks, GOOPS scheme rewrite!
<daviid>paroneayea: cool
<daviid>paroneayea: for info, you can 'specialize' (redefine) the setter 'part' of an accessor, which is what I thought you were asking for... this is when you ned to do more then just slot-set!, or slot-fset, for exmple playing with graphics, an object would need to redraw itself after changing its size ... any millions of other examples ...
<daviid>these are not inherited in goops
<daviid>paroneayea: to be complete, this (define-method ((setter !border) (self <clus-apple>) value)
<daviid> (slot-set! self 'border value)
<daviid> (auto-resize self))
<daviid>would not be inherited by <clus-apple> subclasses. the trick is to adopt the C programming style (gobject), and define get- (for 'reciprocity' and get- methods, so in this case
<daviid>(define-method (set-border (self <clus-apple>) value)
<daviid> (slot-set! self 'border value)
<daviid> (auto-resize self))
<daviid>
<daviid>that will be inerited ... voilĂ 
<paroneayea>daviid: aha, yeah I wasn't talking about that bit :)
<daviid>yeah, got that in the middle of our chat, then decided to complete what i was talking about anyway ... :) by the way, one might argue that these methods should be called border-ref border-set! probably better names indeed ...
<civodul>daviid: hello!
<civodul>daviid: do you have a copy of guile-sqlite3 on-line somewhere?
<civodul>it's used to be available on the "https://www.gitorious.org/guile-sqlite3/guile-sqlite3.git/" read-only mirror but no longer is
<civodul>ACTION should maybe create an account on notabug.org or something and upload it
<daviid>civodul: yes
<daviid>just a min, cooking ... be back i amin
<daviid>civodul: here: http://git.savannah.gnu.org/cgit/grip.git/tree/grip/db/sqlite3.scm
<daviid>it's a copy, all you will have to do is change the module name (path actually) from (grip db sqlite3) to what ever you'll need ...
<civodul>i went ahead and pushed my copy to https://notabug.org/civodul/guile-sqlite3
<daviid>that is the only line I changed wrt to the original copy
<daviid>ok
<civodul>i didn't write a single line in it though :-)
<daviid>civodul: my intention was (and still is) is to submit this as GNU Guile-SQLite, which I will do after publishing Guile-CV
<daviid>civodul: i don't think it is a problem, we may paste your of my grip link to who ask for it untill i submsit it to GNU ...
<daviid>our objective is to conquer the world with guile anyway :)
<daviid>any tool, lib ... wherever stored ... is a contribution to this ...
<daviid>long live to guile!
<civodul>:-)
<civodul>my immediate concern was to find a public copy of that code
<daviid>yep, now we have 2, maybe tell sneek ...
<daviid>i don't know how to do that