IRC channel logs

2017-01-09.log

back to list of logs

<OrangeShark>hello everyone
<davexunit>wingo: thank you I will check my email shortly
<davexunit>paroneayea: cool, I borrowed that from guix and tweaked it
<davexunit>the evolution continues ;)
<davexunit>now, back to seeing why my static guile can't load libraries.
<paroneayea>davexunit: ah-ha :)
<davexunit>actually, first I'm going to attempt to fix this patch so it can hopefully make it upstream finally.
<davexunit>... if I don't get too distracted petting the kitten sleeping next to me
<davexunit>hopefully the final version of the unboxed floating point comparisons patch https://git.dthompson.us/guile.git/commitdiff/bfd7b4f343c5f5cc8761c8d1fed1f61ba564a5dd
<davexunit>wingo: I sent a new patch to guix-devel. thanks again.
***heroux_ is now known as heroux
<paroneayea>wingo: oh btw, I saw your "ping if you want patches included" post
<paroneayea>I have a very small patch that would be very useful to include, on this bug:
<paroneayea> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=24818 well, not *very* small. It's actually pretty small but looks bigger because the sexps got indented one level.
<paroneayea>this makes "guile --listen=/tmp/guile-socket" more bearable because it auto-cleans-it-up
<janneke>ACTION -> zZzzz
<wleslie>davexunit: at least you're in rhyme for 2.1.6
<davexunit>wleslie: haha, I didn't realize I rhymed!
<davexunit>paroneayea: congrats on the release(s) by the way
<paroneayea>thanks davexunit :)
<davexunit>paroneayea: look, more LPC assets http://opengameart.org/content/lpc-castle-mega-pack
<paroneayea>I'm pretty excited
<davexunit>castles this time
<paroneayea>Ooooooh!
<paroneayea>I love that LPC keeps on going :)
<paroneayea>4 years on!
<davexunit>4 years strong
<paroneayea>:)
<davexunit>ACTION is pretty lost trying to debug ffi issues with static guile
<paroneayea>sounds not very fun
<davexunit>it sure isn't
<davexunit>but I was *thrilled* to get a guile repl on ubuntu
<paroneayea>:)
<davexunit>that's some mighty fine progress
<davexunit>I now believe that it is possible for me to make nasty blob releases of my games
<paroneayea>\\o/
<paroneayea>davexunit: and thanks to rekado's work on guix, we can make entire distro sized docker binaries too :)
<davexunit>oh yeah
<davexunit>though they aren't distro sized!
<davexunit>the images are very small for packages with optimized closures
<davexunit>I made one with ruby + coreutils + bash and it was 152MiB, and I found out that 70MiB are ruby docs!
<davexunit>80MiB is pretty damn good!
<davexunit>it's nice to run things on docker without having to build them with docker.
<davexunit>a-ha! libltdl is the culprit
<paroneayea>davexunit: woee, nice
<davexunit>among the output of 'strings libltdl.so' is something that looks suspiciously like the search path that is giving me trouble
<paroneayea>*wowee
<davexunit>so maybe I just need to make my own special build and then rebuild guile...
<davexunit>ACTION turns his computer into electric heating unit while he compiles guile
<davexunit>I modified the guix recipe to keep the prebuilt bootstrap stuff so it doesn't take *too* long
<davexunit>problem seems unrelated to libltdl now
<davexunit>problem persists after recompiling guile
<davexunit>think it might be a configure flag
<davexunit>I'm pretty stumped at this point
<davexunit>I can mess with LD_LIBRARY_PATH enough that it finds all the libs it needs, but then the program segfaults after loading ld-linux-x86-64.so
<lloda`>wingo: pushed function names patch
<lloda`>wingo: re: deadlock, I think it was a true deadlock, will test the patch nonetheless
<lloda`>wingo: deadlock, still there :-(
<wingo>lloda`: looking forward to your reduced test case :)
<lloda`>wingo: I tried last friday and I couldn't make it happen with a simpler body. It calls a C routine, but the deadlock happens after the call :-?
<lloda`>anyway, I'll keep trying
<paroneayea>guile-8sync now in guix
<davexunit>yay
<paroneayea>:D
<ecraven>are there plans to add the simple parts of r7rs-small to plain guile?
<ecraven>things like inexact->exact -> exact ?
<Blukunfando>That was already added as part of r6rs.
<ecraven>is that in 2.0?
<Blukunfando>Yes, it is, but you have to import the base r6rs library to use it.
<Blukunfando>(import (rnrs base (6)))
<paroneayea>davexunit: I keep needing (ice-9 json) in projects
<paroneayea>I'm considering writing a guile-sjson library and submitting to guix for now
<paroneayea>of course it could be committed to guile proper
<paroneayea>though, one thing I would prefer to change still
<paroneayea>I'd still massively prefer sxml style associative maps
<paroneayea>'(@ (key1 val1) (key2 val2))
<paroneayea>easier to write and it doesn't "break" on pretty printing when your value is itself a list
<paroneayea>but I know you're not a fan of that :)
<paroneayea>I also have a set of sjson manipulating tools I've built around (ice-9 json)
<paroneayea>and I'm thinking I'll add a hamt based representation using either ijp's or wingo's hamt modules
<paroneayea>or maybe that's not needed for sjson... I do think I need it for Pubstrate.
<wingo>davexunit: just a couple typos, please fix and then push to master :)
<wingo>good evening civodul :)
<civodul>heya!
<paroneayea>how do I tag something with "patch" from the debbugs emacs interface, does anyone know?
<paroneayea> https://www.debian.org/Bugs/Reporting oic
<holomorph>i usually refer to https://debbugs.gnu.org/server-control.html
<holomorph>oh nvm
<civodul>paroneayea: hit 'C' on the bug
<paroneayea>civodul: oh, thanks :)
<paroneayea>civodul: wowee, that's cool.