IRC channel logs

2016-12-26.log

back to list of logs

***ohama is now known as 5EXAAD3EQ
***siel_ is now known as siel
***profan_ is now known as profan
<amz3>héllo #guile :)
<amz3>taking notes is really helpful pratice!
<janneke[cm]>pondering on how to implement continuation passing style for Mes' eval-apply style for Mes
<janneke[cm]>*core
<jmd>I've got two procedures: (define* (A x cmd #:rest args) ...) (define* (B x cmd #:rest args) ...)
<jmd>and I want to define A in terms of B. How can I do that?
<amz3>jmd: I don't see the issue here
<jmd>amz3: So how would you do it?
<janneke[cm]>jmd: what problem do you encounter?
<jmd>A system-error
<jmd>janneke[cm]: And how would you solve the problem?
<janneke[cm]>jmd: I cannot imagine what problem you see, let alone how to solve it
<jmd>So as you believe there would be no problems, how would you do it?
<janneke[cm]>I would type what I intend
<jmd>janneke[cm]: When people help me I am gratefull for that help. I don't expect people to help - after all it costs time and attention. But if you choose not to help, I would thank you to refrain from making annoying comments.
<janneke[cm]>I'm sorry that you don't appreciate my questions
<davexunit>A can refer to B and vice versa without issue.
<davexunit>any error would be due to some other implementation problem
<jmd>davexunit: I think I have solved it. The "issue" seems to be that one has to use "apply" when calling the other procedure.
<davexunit>only in certain cases would that be true
<davexunit>if you are passing the argument list from A to B, for example.
<davexunit>but you don't *always* have to use apply
<jmd>I thought that was clear from the use case I gave.
<davexunit>I couldn't really tell what you were trying to do.
<jmd>Well anyway I think I've fixed it now. Thanks.
<davexunit>defining a procedure in terms of another has many possible interpretation s
<davexunit>cool
<janneke[cm]>nice
<jmd>I'm trying to auto-generate some Guile code. Is there a neat way to find out in which module a procedure is defined?
<paroneayea>hello, friends!
<paroneayea>I hope to get my revised 8sync tutorial written between today and tomorrow. Let's see if I can do it!
<daviid>guilers, hello! where is this python to guile blg again?
<daviid>blog
<OrangeShark>daviid: is it this book? http://www.draketo.de/py2guile
<daviid>OrangeShark: ah a book! tx
<daviid>paroneayea: do you have a story about from python to guile somewhere?
<daviid>it is very unfortunat that blog/book uses none parens syntax, it is unreadable
<paroneayea>daviid: I don't, though yeah I think ArneBab_ has a nice post as above
<daviid>paroneayea: the problem is this wisp thing
<paroneayea>daviid: aw, I like wisp :)
<paroneayea>I agree it isn't as straightforward a walk-over as you can get though
<daviid>paroneayea: ah, i really hate it :)
<paroneayea>but it's nice in that maybe it makes the parens look less scary
<daviid>well , let's not start a billion dscussion about this, parens are what makes code a lot better, thousands of time fatser to read and debug ... imo
<paroneayea>I often show wisp and scheme code side by side in talks to help the lisp-phobic people realize "oh, those parentheses aren't so bad"
<daviid>paroneayea: good!
<paroneayea>I still encourage people to use parentheses though :)
<paroneayea>daviid: btw, you'll be happy to hear that, though generic methods aren't required with 8sync, I made some changes that will make generic method users have a much nicer time with it :)
<paroneayea>but, I am kind of in the zone on writing
<paroneayea>I should keep at it!
<paroneayea>I am also thinking of doing my FOSDEM talk where the talk itself is a game
<paroneayea>instead of a normal presentation
<paroneayea>I'll have a MUD I'm walking through where each "slide" is a room :)
<paroneayea>that could be a fun and unique way to demo 8sync interactively ;)
<daviid>i don't understand lisp-phobic peope anyway, never did and never ill :)
<paroneayea>I understand where it comes from
<paroneayea>I was very intimidated
<paroneayea>but also transfixed at the same time :)
<paroneayea>I think that parentheses are the best! but I understand how, starting with anything else, they can be scray.
<paroneayea>scary
<paroneayea>I think if more users started with sexps it wouldn't be true
<daviid>paroneayea: oh nice! 8sync ... if you have some use for it, generic functions are so cool, it makes user customization a nice and easy walk...
<daviid>ACTION thinks people should start with s-exp
<daviid>just because of the syntax i don't want to recommend this blog, too bad really
<sapientech>wingo: how would one allow fibers to share/syncronize mutable state?
<sapientech>dosync from clojure seems like an easy way to do this, and wondering if a similar mechanism is being built for fibers
<paroneayea>o/ sapientech
<sapientech>hihi paroneayea
<paroneayea>sapientech: maybe atomic boxes?
<paroneayea>(use-modules (ice-9 atomic))
<paroneayea>see the manual in master
<paroneayea>however, I haven't played with them
<sapientech>paroneayea: im guessing the clojure parallel are refs :) checking now
<sapientech>yeah this looks useful, i made my own ref record for a guile dosync impl, will probably want to use atomic though :)