IRC channel logs

2016-12-17.log

back to list of logs

<amz3>got it
<daviid>english quiz: what is the opposite of dark background, would it be light background or clear background?
<davexunit>light
<daviid>davexunit: thanks
<paroneayea>I'm simultaneously looking forward to and dreading the day we have Dungeon Crawl Stone Soup packaged
<paroneayea>probably my productivity will drop dramatically. but I keep thinking about / missing it.
<paroneayea>oops wrong #gui* again! not that it's important.
<paroneayea>speaking of dungeons and gui*, mudsync is already becoming much easier to read/write with this refactor.
<daviid>given this def: (define* (im-threshold image threshold #:optional (background 'dark) #:key (precision 1.0e-4)) ...)
<daviid>i wrote this texinfo entry: @deffn Procedure im-threshold image threshold [(background 'dark)] [#:precision 1.0e-4]
<daviid>is this the correct way?
<daviid>this 'renders' like this: Procedure: im-threshold image threshold [(background 'dark)] [#:precision 1.0e-4]
<daviid>writing the doc is the hardest part :)
<daviid>anyone knows an example in the guile manual of a procedure thart accept both an optionakl arg and a kw arg?
<jmd>How can I use ice-9 match to match an #<unspecified> value? (yes I have read the manual)
<janneke>jmd: (define (unspecified? x) (eq? x *unspecified*))
<janneke>(match (if #f #f) ((? unspecified?) "yay") (_ "bah"))
<jmd>janneke: Thanks.
<jmd>(unspecified? is not mentioned in the manual).
<jmd>At least there is no index entry for it.
<jmd>*unspecified* I meant.
<janneke>jmd: while SCM_UNSPECIFIED is, without mentioning *unspecified*
<janneke>i guess our `scheme as a extension language' legacy is still showing here
<amz3>fosdem website is back online
<amz3>seems like my talk about wiredtiger is accepted \\o/
<amz3> https://penta.fosdem.org/submission/FOSDEM17
<jmd>amz3: Did you get an explicit confirmation or did you have to keep checking?
<amz3>I did not get a confirmation, I just saw that in penta website
<jmd> amz3: Oh thanks. I see that mine has been accepted too.
<amz3>what is it about?
<jmd>It would have been nice to have got an email or something.
<amz3>jmd: what's the subject of your talk?
<jmd>User interfaces with Guile
<rekado_>Hi Guilers!
<rekado_>I’m trying to rerun some code with a different value in case of an error.
<rekado_>this sounds like a case for continuations or prompts
<rekado_>am I on the right track?
<civodul>amz3, jmd: cool!
<civodul>rekado_: maybe 'catch'? (aka. "escape-only continuation")
<rekado_>ah, yes, “catch” might work here
<mario-goulart>wingo: https://github.com/wingo gives a 404 (tried to follow the fibers link).
<daviid>happy saterday guilers!
<wingo>greets
<wingo>new fibers release: https://github.com/wingo/fibers/wiki/Manual
<wingo>adds preemption, docs, dynamic states
<daviid>wingo: super! but it gives a 404 here
<wingo>really! must be because my github account is flagged or something
<daviid>tried twice thinking I miss copied but twice 404
<mario-goulart>same here
<wingo>weird, i have contacted support
<daviid>they are scared guile takes up the world and flag guile and scheme pages :)
<wingo>heh
<wingo>i think it was done automatically for having pasted a new html manual update
<wingo>because it was not flagged before my paste
<daviid>folkjs, I'm looking for an example of a texi entry for such a def: (define* (frob foo #:optional (bar 42) #:key (baz 73))
<daviid>so I can look at what 'our' convention is
<daviid>i found this one: @deffn {Scheme Procedure} coverage-data->lcov data port #:key modules
<daviid>so it seems we do not specify the default value in our manual
<daviid>and do not use [], but rather #:optinal bar #:key baz
<daviid>though I see a lot of other occurrences using bracket
<daviid>saterday existential quiz... i just wish i could make my mind upon a convention :)
<daviid>ah, found an example
<daviid>Scheme Procedure: xml->sxml [string-or-port] [#:namespaces='()] [#:declare-namespaces?=#t] [#:trim-whitespace?=#f] [#:entities='()] [#:default-entity-handler=#f] [#:doctype-handler=#f]
<daviid>so we do list the default value for kw args, but njot optional args, in this case string-or-port dfaults to (current-input-port)
***DeeEff[m] is now known as DeeEff[m]1
***DeeEff[m]1 is now known as DeeEff