IRC channel logs

2016-12-11.log

back to list of logs

<davexunit>floating point math strikes again
<paroneayea>mudsync works again under new 8sync refactor \\o/
<davexunit>heap-allocated floats will be the death of me.
<daviid>guile-gnome (simple apps) triggers goops related bugs for 2.1.4, same code that pass using 2.0.13 :( it is going to be a nightmare to produce a snipset to allow wingo to reproduce
<davexunit>wingo: I have a program that could benefit from f64 specialized br-if-* operations. I have some 2D vector math mostly optimized by using bytevectors, no allocation when adding/multiplying vectors, but inevitably one wants to do comparisons like "is the x coordinate less than 0?".
<davexunit>this requires boxing the float taken from the bytevector before the comparison can be done.
<davexunit>my test program animates N particles that bounce off of the window edges. the GC runs once per second with 1000 particles on my machine. if I remove the bounds checking, and thus the bouncing, the GC doesn't run at all after program initialization.
<davexunit>thoughts welcome :)
<davexunit>thanks in advance ;)
<amz3`>what's up guile?
<amz3`>ACTION trying to install guix :/
<amz3`>wiredtiger made a new release with all the fixes I need
<paroneayea>hi hi
<amz3`>fosdem still down
***karswell` is now known as karswell
<amz3`>ohoh! some of my tests are broken
<galex-713>is guile faster than python currently?
<paroneayea>galex-713: might depend on what you're benchmarking
<paroneayea> http://wingolog.org/archives/2012/03/08/an-in-depth-look-at-the-performance-of-guiles-web-server
<paroneayea>I would think in general yes
<paroneayea>of course, it also depends on how it's written
<paroneayea>if you use large cons based lists and try doing random access on them frequently in your program, it won't be faster :)
<paroneayea>but hopefully you wouldn't do that!
<paroneayea>galex-713: I'm not aware of any "general" benchmarks of Guile v Python v Ruby etc
<paroneayea>I'm aware of Python v Ruby ;)
<galex-713>paroneayea: ah ok
<amz3`>guile 2.2 is faster than guile 2.1
<galex-713>of course
<galex-713>Oh btw amz3` how is your stuff going?
<galex-713>:)
<amz3`>galex-713: stalled :)
<amz3`>I've been stuck for no apparent reasons
<amz3`>but I've been working on guile git bindings too
<galex-713>oh cool
<amz3`>and it's missing the primary operations like git pull/checkout/clone which are not as easy to bind as I thought
<amz3`>right now I try to get guix up-to-date
<amz3`>what are you up to galex-713 ?
***random-nickname is now known as random-nick