IRC channel logs

2016-11-17.log

back to list of logs

<davexunit>MoronicAcid: yes
<MoronicAcid>davexunit: Nevermind, I figured out my problem.
<linas>So: I keep getting these harmless warnings that are starting to get annoying:
<linas>warning: possibly unbound variable `blah`
<linas>they're always defined in some module that was loaded earlier
<linas>Am I using modules wrong?
<linas>Are the modules failing to export correctly?
<linas>There's no actual error - everything works. Just the annoying/useless warning.
<MoronicAcid>davexunit: So I've ran ./config, make, and make install, and I see nothing out of the ordinary. But when loading the sdl2 modules it complains about there being "no code for module (sdl2)"
<MoronicAcid>Might it have something to do with installing to /usr/local/share/guile/site/2.0/ instead of /usr/share/guile/site/2.0/?
<OrangeShark>MoronicAcid: ya, default it installs in /usr/local/share, guile installed by your distro only checks /usr/share/
<MoronicAcid>Is there anyway to tell Guile to look at both?
<MoronicAcid>OrangeShark:
<OrangeShark>MoronicAcid: guile uses the environment variable $GUILE_LOAD_PATH, so you could add it
<MoronicAcid>OrangeShark: Thanks.
<OrangeShark>MoronicAcid: https://www.gnu.org/software/guile/manual/html_node/Environment-Variables.html#Environment-Variables
<OrangeShark>there is also a variable in guile that you can add to https://www.gnu.org/software/guile/manual/html_node/Load-Paths.html#Load-Paths
<MoronicAcid>Okay
<davexunit>alternatively, you can install with ./configure --prefix=/usr
<davexunit>or: export GUILE_LOAD_PATH=/usr/local/share/guile/site/2.0; export GUILE_LOAD_COMPILED_PATH=/usr/local/share/guile/site/2.0
<MoronicAcid>Guile is ignoring my exported paths -.-
<MoronicAcid>What do?
<daviid>the stable branch segfault a code that worked fine with 2.0.13.1-27247 and 2.1.4, but today I grabbed the latest, 2.0.13.3-2fbd and it fails. http://paste.lisp.org/+73YI
<MoronicAcid>"echo $GUILE_LOAD_PATH" -> "/usr/local/share/guile/site/2.0" "echo $GUILE_LOAD_COMPILED_PATH" -> "/usr/local/share/guile/site/2.0"
<davexunit>MoronicAcid: the paths must be wrong somehow, then.
<MoronicAcid>davexunit: The export command works, but when I copy and paste it into .bashrc prior, it didn't work.
<MoronicAcid>I am just curious why this is
<daviid>here are the last line of strace: http://paste.lisp.org/+73YI/1
<daviid>* last lines
<galex-713>Hi
<galex-713>Did anyone tested ao-cad?
<sneek>galex-713, you have 2 messages.
<sneek>galex-713, ng0 says: gnupg-2.1.15 is in core-updates
<sneek>galex-713, ng0 says: nevermind, I've read that lfam already told you
<galex-713>I’m still getting “Cannot find EGL/GLX context”
<OrangeShark>MoronicAcid: in a guile repl, what does evaluating the variable %load-path give you?
<MoronicAcid>OrangeShark: The /usr/local/share exists now, for some reason .bashrc doesn't work properly on Linux Mint 18, so I had to use /etc/environment.
<OrangeShark>ah okay
<galex-713>ng0: yeah solved the gnupg-2.1.15 install problem long time ago
<galex-713>sneek: help
<galex-713>!later ask ng0 yeah solved the gnupg-2.1.15 install problem long time ago
<galex-713>later ask ng0 yeah solved the gnupg-2.1.15 install problem long time ago
<galex-713>sneek: later ask ng0 yeah solved the gnupg-2.1.15 install problem long time ago
<sneek>Will do.
<galex-713>sneek: later ask ng0 then I tried to see how could I use the same keypair for both gpg and ssh (and tls) and failed (to understand and find the correct informations about gpg-agent and stuff like key formats-keygrip)… so I’ll try another time
<sneek>Got it.
<MoronicAcid>davexunit: FYI, the link to the GPG signature for Sly 0.1 404's.
<MoronicAcid>davexunit: Also, running "./configure" for Sly gives the error "checking if (sdl sdl) is available... no configure: error: required guile module not found: (sdl sdl)" even though I can confirm that SDL2 is installed correctly.
<galex-713>MoronicAcid: did you install guile-sdl2?
<galex-713>the one from davexunit
<MoronicAcid>Yes
<galex-713>and from git
<MoronicAcid>No, not from git.
<galex-713>and did you try to use it? to load it and like run a window?
<MoronicAcid>Yes...
<MoronicAcid>It works
<galex-713>and it works without further config? and it’s sdl2 and not sdl1? from anywhere in the system?
<MoronicAcid>I only have sdl2 installed on my system
<galex-713>and when I says “work/load”, I’m speaking about (use-modules '(sdl sdl)), not (use-modules '(sdl))
<MoronicAcid>I have not tested
<MoronicAcid>What is the difference?
<MoronicAcid>Oh I see
<MoronicAcid>Sly does not use SDL2
<galex-713>? I thought it did
<MoronicAcid>Not according to this: https://dthompson.us/projects/sly.html
<galex-713>ACTION checks changes
<MoronicAcid>Is this the wrong version?
<galex-713>oh right seems sdl1… strange…
<galex-713>try installing sdl1 to see…
<davexunit>Sly uses SDL2 now
<davexunit>(sly as a project is undergoing a major restructing/rewrite)
<galex-713>oh cool
<galex-713>do that mean it could have a chance to work on X60? ^^'
<MoronicAcid>davexunit: Any rough idea when 0.2 will be released?
<davexunit>galex-713: using SDL2 doesn't change the OpenGL requirements
<davexunit>OpenGL 3.3 still necessary
<davexunit>MoronicAcid: perhaps never.
<galex-713>:/
<davexunit>I've found a lot of limitations with FRP for game development
<davexunit>and I'm prototyping alternate architectures now
<galex-713>what’s FRP?
<galex-713>ah ok
<davexunit>functional reactive programming
<galex-713>just understood
<galex-713>yeah
<davexunit>right now I'm writing a slightly more traditional engine
<MoronicAcid>What are the pitfalls?
<galex-713>what limitations btw?
<davexunit>scripting is difficult
<davexunit>(walk-left) (wait 60) (walk-right)
<davexunit>stuff like that
<davexunit>I'm rewriting a game of mine using an asynchronous programming style instead
<davexunit>with coroutines
<galex-713>ok
<Asyan>Hi guys
<wingo>hello :)
<wingo>please don't assume we are all guys tho!
<mvdw>wingo: You can say 'guys' without directly implicating that you think that everyone is a guy here.
<Asyan>wingo: ok, I'll use the right way of greeting next time
<mvdw>'hey guys' is literally fine.
<wingo>mvdw: it's not welcome in this channel. thanks :)
<wingo>ACTION guile maintainer hat on
<mvdw>The word 'guys' is not welcome?
<wingo>not in this context, no. it makes some people feel unwelcome; see e.g. https://subfictional.com/2012/07/02/language-matters-stop-using-guys-to-address-mix-gender-groups/. that's the end of this discussion please :)
<mvdw>disgust
<jmarciano>Some words make people uncomfortable, because those people who get it uncomfortable don't understand definitions of words.
<jmarciano>words can have multiple definitions, such as the word "free"
<jmarciano>just because it makes someone uncomfortable, one shall not use the proper language
<jmarciano>shall not stop using it properly
<mvdw>I'm staying out of it some people simply can't have their minds adjusted
<jmarciano>In one definition "guy" is a man. In the other definition "guy" is member of group of either sex, usually friends or comrades, and used in plural like "guys"as, tell the guys to
<jmarciano> come inside; are any of you guys interested in a game of
<jmarciano> tennis?
<OrangeShark>hello everyone
<wingo>greets :)
<lloda>hi wingo
***slick is now known as ande
***Slick is now known as shoup
<dsmith-work>Thursday Greetings, Guilers
<paroneayea>ha
<paroneayea>davexunit: go figure, committing in a haunt repo causes reload... I guess files are being changed in .git after all :)
<davexunit>paroneayea: oh, that's because git must touch the files themselves
<davexunit>if a timestamp or something changes, haunt will notice and reload
<paroneayea>davexunit: yeah
<paroneayea>amusing!
<paroneayea>davexunit: oh wait
<paroneayea>but wouldn't it anyway
<paroneayea>because of .git/
<paroneayea>has actual files changing in it?
<davexunit>paroneayea: haunt isn't watching those files
<paroneayea>davexunit: oh :)
<paroneayea>I guess I should watch how it does it ;)
<paroneayea>er, look at
<paroneayea> https://activitypub.rocks/news/activitypub-reaches-cr.html btw :)
<paroneayea>\\o/
<davexunit>it's very naive right now.
<davexunit>ideally it would inotify or something, and hash files to really detect changes.
<davexunit>paroneayea: that's awesome!
<davexunit>and you used haunt to build it! :)
<paroneayea>yep :)
<paroneayea>and abused Inconsolata, again :)
<davexunit>:)
<davexunit>that's really great
<paroneayea>ACTION likes fixed width fonts for graphic design...
<paroneayea>now next I need to get a server deployed using guixsd
<davexunit>:)
<davexunit>I really need to get a new haunt release out the door... so. little. time.
<davexunit>paroneayea: is ";; TODO: Link" supposed to be a real link now?
<paroneayea>davexunit: oops
<OrangeShark>paroneayea: nice domain :)
<paroneayea>davexunit: yeah that TODO was resolved
<paroneayea>ACTION always forgetting to remove TODO comments
***karswell` is now known as karswell