IRC channel logs

2016-11-13.log

back to list of logs

***karswell` is now known as karswell
<amz3>hmm maybe I need to make a bfs walk print all the nodes then do the same and print all the edges
***karswell` is now known as karswell
<jmarciano>is there a function to search hash table by its value?
<jmarciano>OK I found solution for me: http://paste.lisp.org/display/331260 and I search for simpler solutions to find key by value in the hash table.
<jmarciano>Now I have to make readline completion, so that the value selected, returns the key of the hash. If somebody has clear direction, let me know.
<jmarciano>basically I need to make completion function for readline.
<jmarciano>(sort-list '("a" "d" "c") LESS) <--- what is less? Not in info.
<jmarciano>how to use LESS to compare list items, any example?
<jmarciano>OK I got it, maybe like (sort '("b" "a" "d") string-ci<)
<jmarciano>the power of Scheme and Lisp is that functions can be defined
<jmarcian`>when I see in REPL: $2 = Brazil, there are no quotes " -- and (string? $2) is #f, what it can be then?
<jmarcian`>symbol? is true
<jmarcian`>oh postgres module cannot compile with 2.1.4 version of guile...
<jmarcian`>must go back to stable
<jmarcian`>that will be more than 1 cups of coffee
<random-nick>jmarcian`: yeah, it's a symbol
<random-nick>jmarcian`: symbols write without ' (reader macro for (quote))
<jmarcian`>I just wonder why I get a symbol from (read)
<random-nick>yeah, in code symbols trigger a variable lookup
<random-nick>so they must be quoted
<random-nick>S-expressions don't have such a problem
<jmarciano>I wish to append string to a list
<jmarciano>I would like to append a string to the list.
<janneke>jmarciano: like (append the-list (cons "the-string" '())) ?
<paroneayea>no gtk substitute? strange
<paroneayea>ACTION wonders how many packages will be built on this --upgrade :)
<paroneayea>ugh
<paroneayea>wrong channel
<paroneayea>ACTION trips over #gui* again ;)
<wingo>dsmith-work: i repro'd the crash you had and fixed it locally i think!
***carboran1 is now known as carborane-acid