IRC channel logs

2016-11-09.log

back to list of logs

<amz3`>héllo all :)
<lloda`>wingo: I've bisected the format bug above, http://paste.lisp.org/display/330766 to 723efdfc44695dbc816ede8373b5cab4951ad3b2, 'Fabricated expression tweak in CSE' in master. It's one line.
***lloda` is now known as lloda
<wingo>lloda: cool!!
<wingo>and strange :)
<wingo>lloda: feel free to push a revert if that's the right thing for you. i would like to fix it but i don't have a lot of cycles right now
<lloda>np, I'll push the revert then
<lloda>I take that back, I was missing one bisect step
<lloda>the bad commit is 0f2f5949a21572fad8355473200c7adc6d74f882 'Better unboxing' which is over my head :-/
<lloda>I'll mail bug-guile
<mvdw>How would I go about referencing a expression before evaluating it, say I want to pass (+ 5 3) to a function, but not evaluate it.
<lloda>(lambda () (+ 5 3)) ?
<mvdw>lloda: Yes, thank you.
<mvdw>I should've thought of that.
<lloda>yw
<dsmith-work>Wednesday Greetings, Guilers
<dsmith-work>wingo: # first bad commit: [c957ec7ab0f0a028910dc737e12191f7bdc1ca93] Use atomics for async interrupts
<wingo>dsmith-work: what platform?
<wingo>can you ulimit -c unlimited and get a "thr apply all bt" on the cores?
<wingo>s/cores/core file/
<dsmith-work>wingo: amd64
<wingo>compiler?
<dsmith-work>gcc (Debian 4.9.2-10) 4.9.2
<dsmith-work>Pretty much an up to date jessie system
<dsmith-work>So. I bisect seems to leave the workspace at the last good commit
<dsmith-work>s/I/So/
<dsmith-work>wingo: Ok, I have a core dump. What;s the proper gdb invocation?
<wingo>gdb libguile/.libs/guile core
<wingo>then thr apply all bt
<dsmith-work>Hmm. Doesn't seem very useful. There are no symbols
<dsmith-work>AhH! that's better
<dsmith-work>gdb libguile/.libs/lt-guile core
<dsmith-work>Thread 1 (Thread 0x7fb5719d0700 (LWP 12987)):
<dsmith-work>#0 __GI___pthread_mutex_lock (mutex=0x0) at ../nptl/pthread_mutex_lock.c:66
<dsmith-work>#1 0x00007fb5746d2b55 in scm_pthread_mutex_lock (mutex=<optimized out>) at threads.c:1833
<dsmith-work>#2 0x00007fb5746593a3 in scm_system_async_mark_for_thread (proc=0x1065900, thread=<optimized out>) at async.c:147
<dsmith-work>#3 0x00007fb5746b32c3 in signal_delivery_thread (data=<optimized out>) at scmsigs.c:186
<dsmith-work>mutex=0x0 Does not look good
<dsmith-work>wingo: Want the whole thing to a list?
<dsmith-work>sneek: bugs?
<dsmith-work>sneek: botsnack
<dsmith-work>Aww
<wingo>dsmith-work: yes please :)
<dsmith-work>Afraid the mailer wrapped a bunch.
<dsmith-work>sneek: botsnack
<sneek>:)