IRC channel logs

2016-11-08.log

back to list of logs

<zv>i.e (match "100 200" (x " " y (cons x y)) ===> (100 . 200)
<daviid>zv: string-split in this simle case maybe? you may look at string-match in the man for more complex stuff
<zv>ok, obviously string-split for the simple case, I am looking for a general, complex case with multiple different 'split' chars
***karswell` is now known as karswell
<dsmith-work>zv: Probably best to use a regular expression. (but then you have two problems....)
<dsmith-work>You *could* possibly use read to parse the string into datums and then use match on that.
<zv>dsmith-work: Could you elaborate on that?
<zv>Is there any way to view a quasi-pattern as a series of strings ala Erlang?
<zv>i.e, matching a qp from a list of chars?
<dsmith-work>well. Match works with scheme datums, right? Stuff that read would return.
<dsmith-work>zv: scheme@(guile-user)> (with-input-from-string "(x y 100)" read)
<dsmith-work>$1 = (x y 100)
<dsmith-work>zv: I don't know. Just an idea
<zv>dsmith-work: No, that's great, thank you!
<dsmith-work>zv: Note that read only returns one expression.
<dsmith-work>s/returns/parses/
<dsmith-work>scheme@(guile-user)> (with-input-from-string "x y 100" read)
<dsmith-work>$2 = x
<daviid>how do we test, in a test suite, a procedure that returns no value?
<zv>daviid: you can just run (test-assert) and run your code, srfi-48 will automatically capture errors and report them
<zv>sorry, srfi-64
***rlb` is now known as rlb
<amz3`>o/
<wingo>moo
<didi>Is there a way to run a subprocess asynchronously?
<didi>Never mind. `call-with-new-thread', `system*', and `cancel-thread' later did the trick.
<dsmith-work>wingo: Master is failing test-guild-compile and test-out-of-memory
<dsmith-work>for me
<wingo>tx for the note
<dsmith-work>Tuesday Greetings, Guilers
<wingo>has been succeeding locally but a reliable failure would be nice indeed
<wingo>test-guild-compile failures aren't good tho!
<dsmith-work>/home/dsmith/src/guile/test-suite/standalone/test-guild-compile: line 29: 1612 Segmentation fault guild compile -o "$target" "$source"
<dsmith-work>error: 'guild compile' failed to remove 't-guild-compile-1601.go.eGjtgx'
<dsmith-work>/home/dsmith/src/guile/test-suite/standalone/test-guild-compile: line 38: kill: (1612) - No such process
<dsmith-work>FAIL: test-guild-compile
<dsmith-work>Segault!
<dsmith-work>Well, segfault
<dsmith-work>wingo: How do you run the standalone tests directly?
<dsmith-work>A single one.
<wingo>dsmith-work: i think just "meta/build-env test-suite/standalone/test-guild-compile" but i could be wrong
<dsmith-work>wingo: Yeah, that seems to do it
<paroneayea>I noticed that while working on the https support stuff
<paroneayea>but then I noticed it was happening on master pre-my-patch
<paroneayea>so I went ahead and merged
<paroneayea>iirc it's not happening super consistently
<dsmith-work>Hmm. Well, I'm currently running a bisect from the last release
<dsmith-work>Might be useless if it's intermittent
<dsmith-work>But it's hard segfaulting for me
<dsmith-work>gcc (Debian 4.9.2-10) 4.9.2
<rekado>zv: there’s also string-tokenize
<rekado>zv: might work better than read.
<OrangeShark>hello everyone
***ota_ is now known as ota
***Guest61692 is now known as micro`
<OrangeShark>hi amz3
<wingo>o/
<amz3>o/
<OrangeShark>amz3: I've been changing a bit of stuff for guile-git. It takes an environment variable for the directory to find git repos, should be able to do the same thing when we provide the directory on the command line
<amz3>ok
<amz3>I will have a look next week end
<OrangeShark>right now it just shows all the branches, I need to add tags and get the most recent commits
<OrangeShark>so I am just working on the summary page
<paroneayea>davexunit: haunt is so nice
<paroneayea>it's also nice that I can build something in haunt and even if I'll make it into a dynamic site later
<paroneayea>I can reuse all that sxml so easily
<davexunit>paroneayea: thanks for the kind words :)
<davexunit>ACTION needs to get a patch release out with the markdown support