IRC channel logs

2016-10-26.log

back to list of logs

<amz3`>héllo #guile
<amz3`>o/
<OrangeShark>amz3`: o/
***random-nickname is now known as random-nick
<paroneayea>ijp: is your guile cps(tree-il?)->js branch somewhere still? I can't find it
<wingo>doing routine refactoring of course i find race conditions in our signal handling
<wingo>raaaaarrrrrrrrrrrrrrrrrrrr
<civodul>davexunit: maybe 'read-posts' in Haunt should sort posts by date
<davexunit>civodul: for determinism?
<davexunit>sounds fine
<civodul>determinism and convenience :-)
<davexunit>yeah that's a fine default sort :)
<civodul>:-)
<jmd>Is there a procedure like "and" which doesn't stop on the first #f result ?
<civodul>a procedure that does what?
<OrangeShark>jmd: will it stop on the second #f?
<jmd>No. That will evaluate all arguments.
<OrangeShark>what value do you expect it to return?
<jmd>The logical and of all the evaluated arguments.
<OrangeShark>oh, but you don't want it to short circuit?
<jmd>exactly.
<OrangeShark>I can only think of just writing a procedure that uses and, all the arguments will be normally evaluated and you just then get the and result
<jmd>ok. I just wondered if there already was such a thing.
<OrangeShark>don't think so, doesn't sound like something anyone would commonly use
<spk121>jmd: (fold (lambda (x y) (and x y)) #t (list ......
<jmd>spk121: I'd prefer a named let.
<stis>(apply and (list x1 ...)
<stis>(define-syntax and2 (lambda (x) (syntax-case x () ((_ x ...) (with-syntax (((v ...) (generate-temporaries #'(x ...)))) "'(let ((v x) ...) (and v ...))))))
<stis>(define-syntax-rule (and2 x ...) (apply and (list x ...)))
<stis>both of them should be the same if the compiler is intelligent enough
<stis>s/"'/#'/
<civodul>davexunit: a feed should only contain complete URLs for each post, no?