IRC channel logs

2016-10-10.log

back to list of logs

<spauldo-afk>bah
***spauldo-afk is now known as spauldo
<spauldo>gotta do up a database, wanted to try something different than the plain old perl/php/whatever+SQL code I've written a million times
<spauldo>decided to try slib, but it seems I spend more time debugging slib than I do working on any database stuff
<spauldo>anyone here use guile-dbi? Would you reccommend it?
<nalaginrut>morning guilers~
***wleslie_ is now known as wleslie
<codemac>Would anyone have a moment to help me redirect stderr in guile?
<codemac>I'm still failing with open-pipe*, the docs says it takes it from current-error-port, so I use parameterize to set that
<codemac>but it's not working
***turbofai` is now known as turbofail
<janneke>codemac: what is producing the stderr that you need to redirect?
<codemac>janneke: programs i'm launching? many programs. I'm trying to write some guile to wrap various linux commands (notably dd, rsync, and tar). I want to log their output fully.
<janneke>codemac: something like: (with-error-to-file "bla" (lambda () (let ((p (open-pipe* OPEN_READ "sh" "-c" "echo foo 1>&2; echo bar"))) (read-string p) (close-pipe p))))
<ecraven>wingo: benchmark done, just compiling and running guile 2.1 now, then I'll publish
<wingo>ecraven: cool :)
<ecraven>takes forever to compile though :)
<amz3>héllo :)
<civodul>Hello!
<wingo>moin :)
<nalaginrut>civodul: morning
<nalaginrut>civodul: is Nix necessary for Guix? I thought there's a similar core written in Scheme to replace it
<wingo>guix uses a daemon from nix
<wingo>but otherwise is independent
<wingo>the daemon is included as part of guix
<nalaginrut>but it's still Nix just included in Guix, right?
<wingo>nix includes more things than just the daemon
<wingo>so part of nix is in guix, with some modifications. but not the whole thing.
<nalaginrut>wingo: thanks for explain ;-)
<nalaginrut>ACTION is compiling guile-tjit and fall into halting-coffee-time, well, it's one of the nice point from Guile ;-P
<nalaginrut>I've sent a PR to fix a bug to make it compilable
<ArneBab>can I create a syntax-rule which falls back on its previous definition if it does not match?
<ArneBab>essentially extend a syntax-rule?
***mario-go` is now known as mario-goulart
<janneke>ArneBab: thanks for your response on Mes and the heads-up!
<ArneBab>janneke: thank you for tackling that issue!
<janneke>performance has been improved by a factor of 3
<janneke>i found that startup time is quite big, so it takes "only" 1.5 seconds of the total 22 to compile function main (not 22)
<janneke>i'm now again struggling with trying to get match up, i.e. trying it to play nice with my attempts to implement let-syntax
<janneke>possibly my target should be to get psyntax.scm to run...
<nalaginrut>ArneBab: please tell me if you find the answer of syntax-rule issue
<janneke>*psyntax-pp.scm
<janneke>from time to time i attempt to get that to run but it still fails and i have no idea how to bootstrap that, using smaller steps than gulping the 9000 lines of ((lambda ....))
<ArneBab>janneke: cool!
<ArneBab>nalaginrut: I’ll try ☺
<ArneBab>nalaginrut: my use-case is: (Enter (FirstName SecondName)) → defines Macro (FirstName SecondName ...).
<ArneBab>nalaginrut: now I want to (Enter (FirstName OtherSecondName))
<ArneBab>nalaginrut: reason: I want a compile-time check which ensures that I only use Macros for (FirstName SecondName ...) which I explicitely introduced with (Enter (...))
<jmd> #guix
<nalaginrut>just like (=> fail!) in pattern matching?
<ArneBab>nalaginrut: I’m not sure, need to check
<ArneBab>nalaginrut: is that like else?
<ArneBab>(in cond)
<ArneBab>nalaginrut: I want to redefine the syntax but keep the old definition
<ArneBab>and try the old definition if the new one does not match
<ArneBab>kinda like recursion: recursion end is if the pattern matches, otherwise it tries again
<ArneBab>nalaginrut: I can now differentiate between already defined and not yet defined syntax by using syntax-case and the guard: (not (eq? 'macro (syntax-local-binding (syntax name)) ))
<ArneBab>with name as part of the pattern
<ArneBab>(so it stands for the FirstName)
***Shozan is now known as SHODAN
<OrangeShark>hello everyone
<civodul> http://permalink.gmane.org/gmane.network.gnutls.general/4203 <- Guile 2.2 support in GnuTLS
<civodul>arf
<civodul>well anyway, GnuTLS 3.5.5
<civodul>and 3.4.6
<paroneayea>civodul: ooh, I'd like to see that, though it's saying NOT FOUND for now..
<wingo>nice
<ArneBab>wingo: can I redefine syntax (re-use the same name) with syntax-case and in the re-definition use the previous definition?
<ArneBab>(I’ve been trying to do that for quite some time now and don’t manage to get it working)
<ArneBab>I have a macro which creates macros. I want to match the same macro with different second arguments.
<wingo>i don't know of a way to do that
<ArneBab>then I guess I’ll need to rely on runtime-checking for the second names
<ArneBab>thank you!
<ArneBab>can I use a procedure as guard in a syntax-definition?
<ArneBab>(with syntax-case)
<wingo>yes
<ArneBab>also a procedure defined in the same module?
<ArneBab>(then I just did something wrong…)
<civodul>paroneayea: yeah gmane.org isn't operational yet, but it's just the release announcement
***micro`_ is now known as micro`
<void-pointer>There, TAP output unit-testing module in the spirit of SRFI-64 has mostly come together. Just have to add an expected fail feature and the ability to write output to an arbitrary port, and then systematic unit-tests of the unit testing framework.
<void-pointer>There are two features of SRFI-64 that are not doable in this output format, sadly. But, some things can be added. But I was able to add a less clunky test skip mechanism and will soon be adding an expected failure mechanism the same way.
<void-pointer>And then finally I can get back to work on the actual package I am hoping to complete since I will have a better suited unit-testing framework to develop it with.
<stis>evening guilers!
<amz3`>héllo stis
<OrangeShark>hello
<OrangeShark>how are you amz3`?
<amz3`>OrangeShark: fine and you?
<OrangeShark>I am alright.
<OrangeShark>I was wondering if it would be a good idea to start on a project that uses guile-git at the same time as we develop it to figure out if we are designing a good enough interface
<amz3`>I *was* thinking about that too
<OrangeShark>we might come up with useful functions or macros for git that we can just include in guile-git
<OrangeShark>high level interface
<amz3`>that said right now I have mixed feeling
<OrangeShark>about what?
<amz3`>about doing a project that uses guile-git
<amz3`>what kind of app are thinking about?
<OrangeShark>best one I can think of is the gitweb replacement :P
<amz3`>yeah :)
<amz3`>you can do that, while I work on the tests
<OrangeShark>alright
<OrangeShark>should I use artanis?
<amz3`>yesterday I wanted to push something but you pushed something then it created massive conflict and then I abandonned but I've kept my small unit tests the change were mostly similar
<OrangeShark>ah, sorry about that
<amz3`>OrangeShark: np
<OrangeShark>that was to use the bytestructures library, right?
<amz3`>OrangeShark: yes
<amz3`>OrangeShark: what do you think about Artanis
<amz3`>?
<OrangeShark>I haven't really tried it out yet
<janneke>Cuirass could do with guile-git
<OrangeShark>janneke: a lot of guix stuff could use guile-git :)
<amz3`>OrangeShark: first artanis won't help to do gitweb
<amz3`>and IMO artanis is still a draft kind of project
<amz3`>Also: 1) I don't like the routing mecanic/API 2) there is no sub-component support 3) There is not support for Cookie or it's weird 4) There is not support for POST data
<amz3`>the cookie support is weird
<OrangeShark>I don't think we would need cookies or POST data for gitweb
<amz3`>exactly
<OrangeShark>I would have to check how the routing mechanic/API is
<OrangeShark>and what do you mean by sub-component support?
<amz3`>do you know Django?
<OrangeShark>not really
<amz3`>the sub-component marchinery should allow to plug generic applications into the url routing machinery so that the generic application can make use of other apps
<OrangeShark>ah I see
<amz3`>anyway this is not useful for gitweb
<amz3`>maybe artanis is good enough
<OrangeShark>I will have to see, would be always good to try to improve artanis as well
<amz3`>yes
<OrangeShark>I tried using artanis the other day in guix, but it seems it is broken. It doesn't install it correctly.
<amz3`>I did not try to install it through guix, last time I tried artanis it was 0.2 or 0.1 and I think I did it manually
<amz3`>via git
<amz3`>Massive LOL! I was downvoted on HN because I said that it's good to read code to avoid backdoors
<ArneBab>nalaginrut: I did not quite find a solution, but I did find a workaround
<ArneBab>amz3`: :)
<janneke>ACTION got let-syntax up, and /almost/ consequently also match
<janneke>running into hygiene issues, apparently
<ijp>are you implementing a macro system?
<janneke>yes, for my minimal/bootstrapping scheme Mes
<ijp>please remember there are *two* kinds of hygiene issue, and gensym can only hel with one
<janneke>thanks, i'll try to remember that...i'm very new to this :-)
<janneke>best thing would be to get psyntax.pp up, and thus more of a real r5rs basis
<paroneayea>ijp: I don't know much about "there are two types of hygeine issues"... where can I read up on what both are? I know what (gensym) helps with...