IRC channel logs

2016-10-04.log

back to list of logs

***holomorp1 is now known as holomorph
<lluis>ljp: it's not the "#1", since I actually used "#t" for the default port (what I pasted was a typo)
<lluis>and the error message actually says the variable is unbound
<lluis>I've solved it, it was a namespace error (my app is a bit more complicated than I described)
<lluis>can I load a file from a C app into the REPL's namespace?
<lluis>namespace / module
<amz3>lluis: you about dynamic-link?
<amz3>lluis: you think* about dynamic-link?
<lluis>amz3: I'm not sure how that would help, in the end I opted for eval'ing "(use-modules)" from C, and then use ",module" in the REPL server to interact with that code
<lluis>it's not the most comfortable, but works
<amz3>lluis: sorry, I misunderstood your question
<lluis>silly question: my app starts a REPL server, but using telnet to connect has no readline support; can I activate that somehow?
<lluis>to answer myself: rlwrap telnet host port
<lloda>doesn't (use-modules (ice-9 readline)) (activate-readline) work?
<lluis>lloda: that's for guile's REPL program
<lluis>I have my own C application that starts a REPL server, and clients must telnet to it
<lloda>I see
<stis>evening guilers!
<wingo>o/
<stis>wingo: Have you seen the recent tracing JIt for guile?
<stis>I'm wodering if that really helps logic programs.
<stis>where you execute a series of closures in a loop
<stis>I think that AOT is needed for that use case no?
<wingo>i have seen it, it looks very interesting :)
<wingo>and civodul says it only requires a couple hooks in the VM
<wingo>which is pretty neat :)
<stis>I agree with civodul here
<wingo>my only concern is maintainability and it sounds like that's not an issue
<stis>It is cheap to maintain as far as I understand
<wingo>great
<stis>4x up to chez if I don't missremember
<wingo>there are many different microbenchmarks :P
<wingo>where it should really shine would be separately compiled things like for-each and other iterators
<stis>yeah, and as I said earlier when you execute a series of closures in a loop I don't see that this can help
<stis>tail calling or via trampolines like in minikanren
<stis>BTW I'm working with a VM for prolog programs that I hook into guile-vm via an extra VM instruction
<stis>in guile
<wingo>nice
<stis>It's fun to poke with guile internals from time to time
<stis>logic programs has a bit special needs of environment for the execution
<stis>in the end I would probably push it all back to scheme, but it's a nice exploration
<stis>the oveerhead of packing up the environment is about 5M predicates a second.
<stis>which means that inlining prolog code is an important aspect of getting the logic programs to move fast
<stis>anyway I incorporated fibers in my logic programs and I have no complaints atm.
<stis>Just want to say that it is a great idea
<wingo>great!
<wingo>i just landed a channels reimplementation in terms of concurrent ml things
<wingo>see (fibers operations)
<wingo>and (fibers channels)
<stis>coolio
<paroneayea>hi everyone
<wingo>greets :)
<paroneayea>:)
<stis>heya!
<amz3`>o/
<paroneayea>ACTION still jetlagged, but working on getting activitypub ready for candidate recommendation... another meeting today, went well!
<paroneayea>anyone who's interested, http://lists.mediagoblin.org/pipermail/devel/2016-September/001481.html your review appreciated :)
<paroneayea>amz3`: I saw your bug about the guix.scm in pubstrate btw
<paroneayea>I'll try to get to that soon
<amz3`>paroneayea: no hurry
<daviid>heya!
<amz3`>paroneayea: this link is broken https://w3c-social.github.com/activitypub
<amz3`>paroneayea: taken from the mail
<amz3`>héllo daviid
<daviid>paroneayea: i think you still did not merged my work on guile-squee [devel], it's a bout a year old now ... [no big deal, but it might be good to merge into master for potential users ...
<daviid>hi amz3`
<daviid>'a bout' is awesome :)
<amz3`>what is it?
<paroneayea>daviid: ooh
<paroneayea>daviid: was that the stuff for the automake stuff?
<daviid>amz3` a none native spelling mistake :)
<paroneayea>daviid: I may be picking up squee again shortly. I'll try to get to this.
<daviid>paroneayea: cool
<paroneayea>amz3`: yes unfortunately, there's a new URL
<paroneayea>the good news is
<paroneayea> https://w3c.github.com/activitypub it's at the w3c namespace officially now
<amz3`>thx
<paroneayea>(even though on github)
<paroneayea>amz3`: lmk if you have any feedback!
<daviid>paroneayea: yes, autool chaining guile-squee: just checkout the devel branch and try it: ./autogen.sh; ./configure [--prefix=]; make; make install; make-install-html[pdf]
<paroneayea>daviid: thanks :)
<daviid>paroneayea: where is your implementation for activitypub?
<paroneayea>daviid: that's pubstrate
<paroneayea>I need to move it..
<daviid>link?
<paroneayea> https://github.com/cwebber/pubstrate
<paroneayea>I'll be moving it to gitlab soon
<paroneayea>and there's a client in emacs lisp
<daviid>paroneayea: why not notabug?
<paroneayea> https://gitlab.com/dustyweb/soci-el
<paroneayea>daviid: oh I dunno, I'm not really sure about any of these non-federated git hosting systems yet :)
<daviid>thanks
<paroneayea>daviid: were you involved with notabug? I forget
<daviid>ACTION don't like any of github gitlab
<paroneayea>I feel like I don't like any of anything right now re: vcs hosting
<paroneayea>I'm just one big grouch
<daviid>paroneayea: not involved no, just made an account to work on guile-squee :) I use savannah
<daviid>imo all should be on savannah
<daviid>but ...
<amz3`>paroneayea: is there a irc channel dedicated to activitypub?
<amz3`>maybe I should dump all my comments in a single issue on github or the mailling list?
<paroneayea>amz3`: there's #social on irc.w3.org
<paroneayea>I'm cwebber2 there
<amz3`>too far away ;)
<paroneayea>amz3`: depends, if you have actionable issues, the issue tracker is better, ideally one issue per topic. If you want to give a whole load of feedback, the mailing list or emailing me is best, I can copy it to the wiki
<paroneayea>amz3`: I hear you
<paroneayea>irc isn't federated enough ;)
<paroneayea>ACTION sits on the freenode quasi-silo :)
<amz3`>yeah
<paroneayea>daviid: savannah is the best freedom-wise, though I worry it isn't getting enough love / maintenance...
<paroneayea>amz3I look forward to your feedback :)
<paroneayea>amz3`:
<amz3`>ok
<daviid>paroneayea: so far, i have had perfect support from savannah folks, just perfect
<daviid>paroneayea: then using github provides help frm people like me (just as an example)
<daviid>anyway, i would move it to savannah or notabug
<daviid>my 2c
<daviid>have to go afk for a bit, be back lçater
<paroneayea>lata daviid
<paroneayea>wingo: thanks for the pointer to http://usingcsp.com/
<paroneayea>loaded it on my e-reader... maybe some day I'll get through it ;)
<OrangeShark>paroneayea: daviid We obviously need a git hosting written in guile, right amz3`? ;)
<amz3`>ahah
<paroneayea>OrangeShark: don't tempt me! ;)
<paroneayea>unfortunately, that's a huge project
<paroneayea>larger than it looks
<OrangeShark>definitely
<paroneayea>well, depending on how you intend to tackle it, at least!
<paroneayea>at the very least, even getting nice git bindings for guile will be work ;)
<amz3`>maybe start with a read only like you suggested OrangeShark
<amz3`>you suggested, a while ago, to create the equivalent of git web
<amz3`>I had a look to libgit, it's massive O_O
<paroneayea>python
<paroneayea>er
<paroneayea>at one point I wrote "wsgit", which was like gitweb in python. It wasn't very good though.
<paroneayea>the bindings stuff I was using weren't very good either, and I moved on to over things
<paroneayea>too many yaks to shave, too many yak mouths to feed
<OrangeShark>ya, a replacement for gitweb written in guile would be a nice start
<OrangeShark>you probably don't need to make bindings for all of libgit at first
<amz3`>yes
<OrangeShark>I feel like trying out the ffi for guile now
<amz3`>I planned to bind basic git workflow... but it's more job that it looks whereas bindings the "read" functions is much easier
<amz3`>OrangeShark: yes!
<amz3`>OrangeShark: don't forget to ping me if you start something ;)
<amz3`>I might have enough power to publish one binding per day
<amz3`>one function I mean
<amz3`>let's do this ;)
<amz3`>I will try to bind a libgit function per day
<amz3`>meh... I created the repository I can't fallback anymore
<amz3`>guix to the resue.... I'm not in control anymore guile-git is taaaaaaaaaaking control of me...
<OrangeShark>haha