IRC channel logs

2016-09-27.log

back to list of logs

<paroneayea>davexunit: I haven't seen the url matcher for "guix publish", no... I'll try to look
<davexunit>paroneayea: it's just a simple example of using match for urls
<davexunit>but it might help to see a "real world" example of it
<leedleLoo>I've used xml quite a bit to serialize data over a network. Serializing expressions is a bit more difficult. I figured that the homoiconicity of S-Expressions would be ideal for serializing expressions/data accross a network. I'm still fairly new to Scheme; can anyone explain why using S-Expressions for serialization over a network is bad (why isn't it being used if it is good for serialization?)
<amz3`>leedleLoo: FWIW I am using S-expr to serialize to the network
<leedleLoo>amz3`: Why do you think it's so rare then? Is there some defect I'm not seeing or are most enterprises not used to it (or don't know about it)?
<amz3`>leedleLoo: IIRC if you have reader macros in place in your program, one could execute arbitrary code...
<leedleLoo>amz3`: I see that as a positive (you don't mean that as a negative do you?)
<amz3`>leedleLoo: it's negative. Basically, if you use readeer macro it's not safe to deserialize s-expr... that's what I understood. Personnaly, I don't use reader-macros
<amz3`>leedleLoo: it's better to ask your question on the mailling list
<leedleLoo>amz3`: I'll do that soon once I've gathered my thoughts a bit more; thank for the initial feedback
<paroneayea>davexunit: I use match for urls
<paroneayea>I just don't have a way to "construct" them based on the previous patterns I've established
<paroneayea>I mean, it's not so bad, I have a procedure like
<paroneayea>(local-url "u" username "p" postname)
<paroneayea>which will make "/u/fooname/p/post-id"
<paroneayea>but I'd prefer to be able to do something like
<paroneayea>(local-url user-post #:username username #:post postname)
<paroneayea>or something
<wingo>meow
<paroneayea>hi wingo !
<wingo>herro :)
***lloda` is now known as lloda
<davexunit>paroneayea: I think you'll want to write a macro or two to handle this :)
<paroneayea>davexunit: hm maybe :)
<paroneayea>davexunit: I should review the pattern matching part of sicp too :)
<davexunit>piggy back on ice-9 match
<davexunit>but maybe you'll have to some pattern matching of your own, in which case yeah check out SICP
<paroneayea>yeah
<paroneayea>this is a long term thing
<paroneayea>in the meanwhile, ice-9 match plus my silly little constructor are good-enough
<davexunit>wingo: https://github.com/8c6794b6/guile-tjit-documentation/blob/master/nash.pdf
<davexunit>published 12 hours ago.
<davexunit>"Nash: A Tracing JIT for Guile"
<davexunit>color me surprised
<paroneayea>davexunit: whoa what
<paroneayea>davexunit: promoted it :)
<davexunit>cool
<davexunit>would love to know what wingo thinks. this came out of nowhere.
<paroneayea>me too
<paroneayea>davexunit: reading it in between spec edits :)
<paroneayea>ACTION wonders, is this person a student? would they want to do gsoc next year? ;)
<peterbrett_work>Whoa this is pretty cool stuff
<paroneayea>peterbrett_work: I agree!
<paroneayea>davexunit: without knowing enough, it looks like they know what they're talking about ;)
<davexunit>heh, yeah I feel the same.
<davexunit>I know nothing, but it sure seems like they know something
<paroneayea>:)
<paroneayea>"hot loops", yeah, I've heard of those and JITs, sounds good ;)
<paroneayea>compiling to native code, sounds good
<paroneayea>ACTION derp-faces for the rest
***micro` is now known as Guest87937
***darthlukan_ is now known as darthlukan
***darthlukan_ is now known as darthlukan
***Fuuzetsu_ is now known as Fuuzetsu
***zv_ is now known as zv
<stis>ooh a jit engine for guile!
***mjl_ is now known as mjl
<stis>The souce code is at https://github.com/8c6794b6/guile-tjit
<davexunit>ah, it uses GNU lightning.
<davexunit>I seem to recall disinterest in using lightning for an official guile jit
<stis>not sure why, but kind of cool, that tracing jit matches racket on the test sample
***berndj-blackout is now known as berndj
<stis>some 3x worse than chez
<stis> https://github.com/8c6794b6/guile-tjit/blob/tjit/libguile/lightning-binding.c
<stis>here is the jit scheme https://github.com/8c6794b6/guile-tjit/tree/tjit/module/language/trace
<stis>checkout primitives.scm to see how wrtiting assembler looks like.
***random-nickname is now known as random-nick
<stis>I tried yesterday to start a discussion about my <= ideom in http://c-lambda.se/return-values.html do you see any pro cons?
***w1gz_ is now known as w1gz
***nafai1 is now known as Nafai
***zv_ is now known as zv
***masoudd_ is now known as masoudd
***zaquest_ is now known as zaquest