IRC channel logs

2016-09-18.log

back to list of logs

<amz3`>héllo :)
<amz3`>davexunit: your web code web code from guix-web I guess, works flawlessly :)
<amz3`>time for smashing bugs!
<amz3`>let fix that search box first
<amz3`>oh no! I've launched a fixed crawler on wingolog.org and now it was wingorolled
<amz3`>since the crawler runs in the same thread as the webserver... meh...
<amz3`>I should be able to fix that too
<amz3`>multithreading for the win
<amz3`>segfault :(
<amz3`>meh, i can not search guile in my guile search engine...
<amz3`>obviously is an heisenbug
<amz3`>obviously it is an heisenbug
<amz3`>:(
<AlfredENeuman>i'm having trouble getting the module system and goops accessors to work nicely together
<AlfredENeuman> http://paste.lisp.org/display/326401
<AlfredENeuman>i'm guessing i don't have the right combination of exports, re-exports and export!s. any suggestions?
<amz3`>sorry I know nothing about goops
<AlfredENeuman>darn
<amz3`>I was going to suggest something like that ;)
<AlfredENeuman>heh
<amz3`>on my side I have a big issue with the segfault
<AlfredENeuman>shit sucks
<amz3`>I'll update to guile 2.1.4 and see if the sefault disappear
<amz3`>:)
<amz3`>the issue I have is that I am low on skills regarding guile internals otherwise I would develop some tools that exists in Python land for guile
<amz3`>anyway, I'm too loo lvl to fix https so...
<amz3`>*low
<AlfredENeuman>i was going to say...
<AlfredENeuman>need not be so harsh on yourself
<amz3`>yeah, but I'm clue less when I hit such issues I don't like it
<amz3`>see you later
<AlfredENeuman>bye
<AlfredENeuman>hmm, so, i suspect that with merging generics, you can merge up and down the module chain
<AlfredENeuman>(ie client code -> dog -> test-gen, and client code -> cat -> test-gen)
<AlfredENeuman>but not laterally. the code i have can't use both dog and cat. i have to set the duplicates flag separately somewhere for the client code
<amz3`>seems like ubuntu 16.04.1 is broken again, I can't install cairo via apt
<amz3`>at least I can compile everything from stratch
<amz3`>there not single example in guile-cairo :(
<jmd>What characters match [:blank:] in a regexp?
<jmd>(Yes, I have looked in the manual.)
<amz3`>I guess newlines, space, tabs
<amz3`>this is the GNU regex module, so the documentation is in the other project
<amz3`>I look for it
<jmd>amz3`: in grep, it won't match newline
<amz3`>jmd: ou are right, here is the definition of each keyword usable inside [: :] https://linux.die.net/man/3/isblank
<amz3`>meh... facebook's css-layout is not a real bsd it has a non-competing clause
<stis>Hmm, I have problems using the hashes in guile 2.1.4
<stis>If I replace them with vhashes the problem dissapears
<stis>Basically the first slot in the hash datastructure is put to false
<stis>mening that the heap object turns into a pair
<stis>starnage!
<stis>it is a general problem and not for a specific code loc
<stis>replacing one hash with a vhash lead to problem with the next hash used
***tokage_ is now known as tokage
<random-nick>are there weak pairs in guile or just weak hashtables?
<micro`> http://www.youtube.com/watch?v=uwiaT3MoDVs&feature=em-uploademail
<micro`>"Knit, Chisel, Hack: Building Programs in Guile Scheme" by Andy Wingo
<random-nick>what module contains weak vectors?
<micro`>There is node in the manual about Weak References
<micro`>Was just looking at the gnu site.
<micro`>(define-module (ice-9 weak-vector)
<random-nick>thanks
<janneke>micro`: ah that's what i've been missing, thanks! is flash needed to watch video?
<random-nick>janneke: no, youtube now uses a player written in proprietary javascript
<random-nick>richard stallman recommends youtube-dl if you want to watch youtube videos without proprietary javascript
<janneke>random-nick youtube-dl works fine!
<janneke>weird, i have been viewing other youtube videos and never had problems before