IRC channel logs

2016-08-12.log

back to list of logs

***mjl_ is now known as mjl
<amz3>héllo #guile
<wleslie>Happy Friday, #guile!
<galex-713>Hi
<galex-713>What is the purpose of records?
<galex-713>I mean, what does it give more than just a list or a vector?
<random-nick>galex-713: you can identify which type of record it is by comparing the vtables of the record and the vtable of the record type
<random-nick>well that is more of a feature of structures, records provide a macro for that
<wleslie>and it names the items. a stat result is much easier to read if you don't have to remember which index st-mtime resides at.
<dsmith-work>Happy Friday, Guilers!!
<amz3>galex-713: it's like namedtuple from python
<C-Keen>hm... gnu.org down?
<galex-713>random-nick: yeah but at least a struct save memory because not mandatorily involving pointers, while records do
<galex-713>random-nick: also structs are typed, while records aren’t
<amz3>records are typed
<galex-713>ah?
<amz3>C-Keen: yeah down
<galex-713>amz3: how do you give a static type to a member then?
<galex-713>how?
<amz3>galex-713: sorry, I misunderstood, it's typed but every component can have whatever type
<galex-713>yeah, dynamically typed
<galex-713>While C structs are statically typed
<random-nick>galex-713: actually it's they are latently typed
<galex-713>yeah latently
<galex-713>I mean, like any scheme variable
<random-nick>galex-713: and I mean guile structures not C structures
<galex-713>ahhh ok
<galex-713>Yet yeah, it’s like “named tuples”, so it’s kinda useless to me
<galex-713>Recalls me OOP
<galex-713>><
<galex-713>yet as far as I know GOOPS is implemented as records
<pecg>I didn't know many of guile's source code is written in go
<pecg>why was it chosen instead of C? not a problem for me, just wondering.
<wleslie>pecg: it's not written in go.
<wleslie>pecg: the .go extension is analagous to the shared objects .so
<pecg>I'm seeing tree-il/peval.go
<wleslie>(compiled) guile object
<stis>heya, guilers!
<wleslie>hi stis!
<stis>I just put out a blog, (I did it via python and pelican) but if you recomend other tools that are more schemy please let me know
<stis> http://c-lambda.se
<avoine>pecg: yeah this is just an extension collision .go probably means "Guile Object"
<amz3>stis: cool
<amz3>stis: I use custom script which does recursive markdown->html
<amz3>the code is over there https://github.com/amirouche/Culturia/tree/master/doc
<amz3>the rendering http://amirouche.github.io/Culturia/doc/
<amz3>they are bug in the markdown->html thing but it kind of works
<random-nick>stis: there's also haunt
<random-nick> http://haunt.dthompson.us/
<stis>amz3: thx. My main concern is to get program code syntax highlighted in a nice way. And for many languages. Did you solve that?
<stis>Also I wanted to add discussion possibilites and keep it static. and pelican had some easy tools for this
<stis>And of cause theams that I could use so that the site looked ok.
<stis>random-nick: dito questions for haunt
<stis>ACTION is quite ignorant regarding web technologies
<amz3>stis: my code doesn't support syntax highlighting yet, the main problem is the markdown parser is incomplete
<amz3>amz3`: from experience, people don't comment much, so I don't bother setting up a comment system for no comments at all. Instead interested and interesting people can use the email to chat
<paroneayea>hello, *
<paroneayea>ACTION hacking on pubstrate some more today
<paroneayea>davexunit: btw, you ever look at scwm? would be hilarious to try dusting off that source and see if it still comes close to working http://scwm.sourceforge.net/
<davexunit>paroneayea: I never looked at it
<paroneayea>speaking of scwm, it inspired "ratpoison"'s name with this hilarious post http://www.nongnu.org/ratpoison/inspiration.html
<davexunit>I would like something written for wayland :)
<paroneayea>that would be nice :)
<paroneayea> http://scwm.sourceforge.net/scwm-screenshot-21-feb-2000.gif classic oldskool WM pic ;)
<dsmith-work>scwm is (was) working as of guile 2.0
<dsmith-work>Except for the gtk bits
<dsmith-work>scwm needs to be re-architected so it's a guile app instead of a C app that links to libguile.
<davexunit>ah yeah
<davexunit>that would be nice
<davexunit>a pure guile wm is possible, as proven by guile-wm
<stis>amz3: discussion is not only for my view. I want the visitor to be able to read any discussions.
<davexunit>I would just expand upon guile-wm, personally
<dsmith-work>wingo did a minimal WM in guile at one time. "griddy" IIRC
<amz3`>stis: not worth the trouble, also if would create something like that in guile I will need to use https which is painful to setup; also it would be centralized which I already do at $wurk
<amz3`>I don't want to repeat myself that's why i explorer things I can't do at normally
<amz3`>right now, I only think about re-writing a project that offlines stack overflow for local use in guile
<stis>ok
<amz3`>doing that I figured, that hyper (an exact match search engine) has to know beforehand all the content of a page to index it. Which means that I can't simply do (for-each index stackoverflow-posts.xml) which in turns means I have to deal with that too
<amz3`>there is no real trouble, I just discovered that compiling guile myself made it more faster
<amz3`>which means I means it's a viable solution for me problem
<amz3`>and make less C libraries to bind, which I don't want to do anymore
<stis>amz3`: re C, fair enough, peronally I prefere generate my C from scheme
<amz3`>stis: awesome!
<amz3`>stis: do you use type inference or not?
<amz3`>paroneayea: receive ftw!
<ijp>I phased out receive in all my code a few years back
<stis>amz3`: just a little, the main inference is done in the C compiler
<amz3`>ijp: phrased out?
<amz3`>ijp: why?
<ijp>because it isn't worth an extra import when I almost always have let-values
<ijp>and in the cases I don't, it's still not worth an extra import
<amz3`>ah ok it's in rnrs base
<amz3`> https://www.gnu.org/software/guile/manual/html_node/rnrs-base.html#rnrs-base
<amz3`>I never use rnrs base, the only rnrs I use is rnrs bytevectors
<amz3`>ACTION running the SO importer for Posts.xml just sanity check
<amz3`>that was fast!
<amz3`>:D
<amz3`>who use pump.io?
<dsmith-work>Wow! 130 in the channel!
<amz3`>héllo 130 in the channel
<paroneayea>amz3`: I use pump.io
<paroneayea> http://identi.ca/cwebber
<amz3`>paroneayea: thx
<Amynka>mark_weaver: https://bugs.gentoo.org/show_bug.cgi?id=590528
<mark_weaver`>Amynka: thanks. from looking at the build log, the original problem appears to be fixed, and now there's another problem: you're passing --disable-regex to configure, and apparently we don't handle that gracefully, but you should remove that flag anyway.
<mark_weaver`>Amynka: also, I see that --disable-networking is still being passed to configure. that should be removed as well.
<Amynka>mark_weaver`: I cant remove useflag just like this
<Amynka>mark_weaver`: why you have it in confugure if its not working?
<mark_weaver`>I agree that this is a bug, but apparently noone ever adds that flag, so no one else noticed the problem.
<Amynka>:D
<Amynka>so I should remove all the useflags basically
<mark_weaver`>a lot of guile code uses regexps. we should probably remove the flag.
<mark_weaver`>guile has grown big enough that omitting things like networking support and regexps doesn't make a very noticable difference in the total size.
<mark_weaver`>Amynka: you wrote in the bug report that you added +nls +networking. given this, why do you support --disable-networking was passed to configure?
<mark_weaver`>s/support/suppose/
<Amynka>mark_weaver`: its recommende useflag
<Amynka>he can hard disable if he knows what he is doing
<Amynka>which he dont know apparently
<mark_weaver`>I have to go afk for a while, but I'll check back later...
<Amynka>oki thnaks
<davexunit>gentoo packaging madness strikes again
<davexunit>will gentoo *ever* fix their guile packages?
<mark_weaver`>davexunit: Amynka is working on it, and being a great help
<Amynka>davexunit: no insults please
<mark_weaver`>thank you for the efforts, Amynka
<davexunit>Amynka: sorry, not meant as an insult.
<davexunit>I'm happy to hear that you are working on improving the situation.
<mark_weaver`>(there's a lot of built-up frustration about the gentoo situation here)
<Amynka>yep working on it and eventually I will
<Amynka>what about my frustration people insult me all the time its not properly packaged try that
<davexunit>yeah, sorry about letting some of that frustration out. I didn't realize that Amynka was working on making things better.
<Amynka>they even told me that i didnt test it when I was testing it for months :D
<Amynka>i spend weeks on it
<davexunit>every so often we get a gentoo user who is wondering why their guile is broken, or asking questions about guile 1.8 because 2.0 is "masked" or something
<davexunit>which has been frustrating for us.
<Amynka>well
<davexunit>so I'm very happy that we've got a packager that discuss with us and resolve things!
<Amynka>its not gentoo problem that much problem is that every user compiles it in gentoo so it reveals more bugs
<davexunit>that can*
<davexunit>going afk now, too.
<Amynka>plus noone knoews anything about scheme in gentoo
<davexunit>good luck Amynka
<davexunit>and sorry again.
<Amynka>its ok
<Amynka>mark_weaver`: well so I can put enable to configure let me know here which options then "regexp nls and networking " ?
<Amynka>no useflags
<Amynka><- off too
<mark_weaver`>Amynka: if a user really wants to disable nls, that's okay, and that's a case we've tested for things like running guile in an initrd
<Amynka>so networking and regexp ?
<mark_weaver`>but regexp and networking should probably be fixed to "enabled". disabling them won't buy you much anyway
<Amynka>ok
<mark_weaver`>i.e. pretend that those configure flags don't exist :)
<Amynka>that will be hard now after I commit all those stuff :D but I can try :)))
<mark_weaver`>no need to pass --enable-networking or --enable-regexp.. just don't disable them explicitly.
<Amynka>we dont they did :D
<mark_weaver`>*nod*
<mark_weaver`>okay, I really have to go afk now.. good luck, and thanks again!
<dsmith-work>Amynka: Some of those configure flags probably date way bac to SCM, which guile is decended from.
<Amynka>dsmith-work: yea that happens
<Amynka>i dont blame anyone but yea its hard :))
<dsmith-work>There used to be #ifdefs for Turbo C for example!
<Amynka>i will just tell user to enable it :D
<dsmith-work>Amynka: Remember guile is *old*. Was first committed to CVS about 20 years ago. And was in development before then.
<Amynka>yea :))
<dsmith-work>s/in development/in non version controlled development/
<mark_weaver`>Guile was derived from SCM which was derived from SIOD