IRC channel logs

2016-08-08.log

back to list of logs

<paroneayea>amz31: I was thinking about what I said earlier about the actor model being a good fit for something like dwarf fortress
<paroneayea>and I take it back
<paroneayea>if you want it to be deterministic, and controlled by each tick
<paroneayea>you don't want the actor model
<paroneayea>which is nice when you have async environments where things can handle stuff when they get to it
<paroneayea>but something like dwarf fortress is closer to cellular automata
<paroneayea>maybe the propagator model would be a good fit, I really don't know
<paroneayea>it would also be cool to do sly-style
<paroneayea>functional reactive combinators
<koosha>Hello !
<koosha>why isn't there the converting procedures available in guile ?
<koosha>*aren't
<mark_weaver>koosha: there are many conversion procedures in guile, but your question is too vague to make sense of. can you be more specific?
<mark_weaver>i.e. what do you want to convert into what?
<koosha>mark_weaver: Yes , sorry . As an example : (char->integer #\\c)
<mark_weaver>works for me. what happens for you?
<koosha>mark_weaver: It goes to next line and wants input .
<koosha>Oooooops !
<koosha>Stupid mistake from me . Sorry !
<mark_weaver>np :)
<wingo>moin
***amz31 is now known as amz3
<amz3>paroneayea: ok thx for the info
<paroneayea>morning, everyone!
<shymega>Morning
<ruste>Morning all!
<quigonjinn>Morning ruste
<dsmith-work>{appropriate time} Greetings, Guilers
<amz3`>paroneayea: thx again for the advice, I had a look at celullar automata, but I think I will dive into propagator first, I think it will more fun, that said I invested a lot of time in my search engine, so I think I will make that work first
<amz3`>paroneayea: also don't hesitate to share your findings regarding propagators
***Fuuzetsu_ is now known as Fuuzetsu
<wingo>good evening hackers
<daviid>good evening!
<paroneayea>hi wingo
<wingo>heya
<amz3`>héllo again :)
<amz3`>I think i never published the code that I use to generate the pages of my blog, it's basically a recursive markdown->html, an example use of it can be found @ https://github.com/amirouche/Culturia/tree/master/doc
<roelj>In Common Lisp, there's a `break' to debug code. Is there an equivalent function in Guile Scheme?
<roelj>a `break' function I mean.
<wingo>yes and no :/
<wingo>it would be nice if we had such a thing and it were well defined
<roelj>Is there a way I can set a breakpoint from Scheme code for the Guile interpreter?
<wingo>yes
<wingo>1 min
<wingo>lol it's difficult
<wingo>to actually do it within the context of the error
<wingo>(use-modules (system repl repl) (system repl debug))
<wingo>(start-repl #:debug (make-debug (make-stack #t) 0 "my special debug"))
<wingo>roelj: ^ godspeed
<wingo>you can keep both pieces, etc etc
<roelj>wingo: Thanks! No wonder I couldn't find it in the manual :)
<wingo>:)
<wingo>roelj: it is possible to set a breakpoint tho
<wingo>search the manual for "break"
<wingo>,break-at-source is the repl command
<roelj>Yes, but that's from the REPL, not from the code
<wingo>programmatically setting breakpoints is wizardry and i think you are expected to dig a bit :)
<wingo>or witchery
<roelj>haha, yeah! :)
<wingo>:)
<roelj>Well.. In Common Lisp.. ;)
<wingo>occult meddlings :)
<wingo>see "High-Level Traps" in the manual tho
<wingo>there is add-trap-at-source-location!
<roelj>Right
<paroneayea>ACTION just throws exceptions when he wants to explore and wraps everything in (pk) ;)
<ijp>today I decided that I really need a pklet for tracing named lets
<paroneayea>lets, lets-pk, lets-private-key, lets-encrypt
<paroneayea>I got nothin
<paroneayea>ACTION dances off stage
<amz3`>2.1.3 is faster than 2.0.11
<ijp>yo'd hope so