IRC channel logs

2016-07-09.log

back to list of logs

<amz3`>anyone knows how guile-gnunet could use guile-fiber?
<tmy>is there any recommended method to store the result of cond clause so I can use it on the clauses body?
<tmy>(cond ((string-match r s) <use the match here instead of re-evaluating the string-match>)
<amz3`>héééééélllllllllo :)
<amz3`>Which Lisp/Scheme to go for? https://news.ycombinator.com/item?id=12060734
<amz3`>I have signed integer pointer passed to a C function
<amz3`>I initialize the pointer as follow:
<amz3`> (let* ((integer (s64vector 0))
<amz3`> (pointer (bytevector->pointer integer)))
<amz3`>then I call the the C function, basicaly (define code (function pointer))
<amz3`>the C function is setting the pointer to a value that can be positive, negative or 0
<amz3`>the thing is that, it returns 0, 1 and 0xffffffff
<amz3`>I assume the 0xffffffff is the negative number, but (array-ref integer 0) returns a postive number
<amz3`>I think I got it, I need to use s64vectir-ref
<amz3`>no, that doesn't work
<cbaines>Hello all, I'm having some difficulties with keyword arguments, and wondering if anyone can point me in the right direction
<cbaines>I'm trying to get something like this to work http://cbaines.net/test2.scm
<cbaines>I think I could be having a problem with using #:allow-other-keys without any keyword arguments, as it looks like that from the documentation?
<cbaines>Also, I'm not sure if just passing the #:rest var in to the function is the right thing to do
<amz3`>I never used that feature, sorry I don't know.
<amz3`>how can i verify that my guile bindings don't corrupt memory? using for instance valgrind?
<amz3`>nvm
<amz3`>but still if you have tips to debug my bindings I'll be happy
<amz3`>valgrind doesn't provide useful information regarding the memory corruption
<amz3`>all errors that happens, seems to happen in libguile...
<amz3`>I think some value is GC'ed before it should
<amz3`>I had a similar problem with python bindings (I know the GC works differently there)
<amz3`>what makes me think there's a memory issue is that the same piece of code works at a different location
<amz3`>bummer!
<amz3`>TIL: strings are mutable in scheme http://srfi.schemers.org/srfi-135/srfi-135.html#Abstract
<amz3`>seems like my issue with wiredtiger is a bug!
<amz3`>ACTION filling a bug upstream
<amz3`>this bug ruined my plans
<thomeith>does guile come with a lexical scanner generator (like flex)? i cannot find one in the info docs, altho i found a parser generator