IRC channel logs

2016-03-16.log

back to list of logs

***M-TimePath is now known as TimePath`
<nalaginrut>afternoon guilers~
<Bobbejaantje>nalaginrut, I never got how often people use the time of the day in a greetng in an IRC channel.
<Bobbejaantje>THat message arrived at 06:33 for me
<nalaginrut>Bobbejaantje: actually, we're using internet time, morning for coming, night for leaving, oh I said afternoon? ;-P
<amz3`>héllo guilers!
<nalaginrut>heya
<jmarciano>Good information for scheme learning: http://ds26gte.github.io/tyscheme/index-Z-H-19.html#node_sec_17.1
<jmarciano>guile is powerful. Only I get a feeling it is not so popular. I try to find out why... why people don't use scheme in general.
***djcb`` is now known as djcb
<Jookia>Is there a lambda that automatically does (begin ?
<amz3`>nalaginrut: hey! did you see the bug with 'send'?
<amz3`>Jookia: not sure what you mean
<Jookia>Oh I think I know what the issue I'm having is
<amz3`>nalaginrut: the title of the bug is misleading but the bug is real, I'm wondering how network applications work without this feature
<amz3`>nalaginrut: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=23000
<civodul>Jookia: (lambda () (begin a b c)) is equivalent to (lambda () a b c)
<Jookia>Neat
<wingo>ACTION finished yesterday's brain-dump: http://article.gmane.org/gmane.lisp.guile.devel/18229
<dsmith-work>Morning Greetings, Guilers
<dsmith-work>Bobbejaantje: Ever heard uf UGT ?
<dsmith-work>sneek: UGT?
<sneek>Last time I checked UGT is http://www.total-knowledge.com/~ilya/mips/ugt.html
<iyzsong>good morning :-)
<civodul>heh, UGT is a good concept :-)
<davexunit>UGT?
<Riviera>universal greeting time, saying "morning" when you join and "night" when you leave a channel, regardless of any actual time of the day.
<davexunit>ah
<davexunit>thanks
<wingo>ugt is a nice idea indeed :)
<iyzsong>so i can have as many days as i want during a real day,
<iyzsong>to confuse others ;-)
<wingo>:)
<wingo>why tf does libtool-2.4.6.tar.xz include a file named "._NAME" for every NAME file?
<wingo>something about macos?
<wingo>so weird
<civodul>yeah i think it's macos stuff...
<janneke>morning!
<iyzsong>good night :o
<rain1>any geiser developers?
<lloda``>you can try #geiser
<rain1>I don't get a reply there
<berndj>when i have AC_CHECK_HEADERS(...) following GUILE_FLAGS, the preprocessor can no longer find the headers (it seems like configure forgets how to run the preprocessor); when AC_CHECK_HEADERS is before GUILE_FLAGS, it works
<berndj>is this something that's immediately familiar or have i discovered a novel local misconfiguration?
<nalaginrut>amz3: usually we just ignore SIGPIPE if the peer connect is down, I have to say, the inner server of Guile is preliminary for a product server. I'll handle it in new server core of Artanis
<amz3`>nalaginrut: the bug is in Guile, `send" doesn't error on SIGPIPE
<nalaginrut>amz3: well interesting, since I encountered sigpipe error in server, not client. There's no `send', I think
<bavier>berndj: could you paste the config.log somewhere?
***karswell` is now known as karswell
<berndj>bavier, i'll do you one better, a reduced test case: http://pastebin.com/SsVs0kqT
<berndj>but the corresponding config.log for completeness: http://www.bpj-code.co.za/downloads.php/GUILE_FLAGS-config.log?text
<mark_weaver>berndj: please don't use pastebin.com, because it blocks tor users
<mark_weaver>there are many other paste sites that don't. http://paste.lisp.org/new is one option
<berndj>ok. re-paste: http://paste.lisp.org/display/310314
<mark_weaver>berndj: thanks
<mark_weaver>berndj: the notable line here is this: ./configure: line 1479: conftest.c: command not found
<mark_weaver>apparently because the variable that's supposed to hold the compiler command is empty
<mark_weaver>berndj: can you send mail to bug-guile@gnu.org with the reduced test case and config.log attached (in the email, not via links) ?
<mark_weaver>also please attach the generated 'configure' script.
<mark_weaver>other relevant info: what version of autoconf are you using, and what version of guile did the incorporated guile.m4 come from?
<mark_weaver>I don't have time to dig further into it now, filing a bug will ensure that it won't be forgotten, and I can try to reproduce it
<berndj>mark_weaver, i don't expect a herculean debugging effort if GUILE_FLAGS is sortof deprecated (which i vaguely recall seeing somewhere?)
<berndj>yeah, $CPP ends up empty if AC_CHECK_HEADERS is after GUILE_FLAGS
<rain1> https://lists.gnu.org/archive/html/guile-gtk-general/2010-09/msg00003.html
<rain1>what's happening with this?
<janneke>guile-gir?
<jmarciano>how do I use geiser actually, I don't get it
<jmarciano>I am editing guile, M-x run-geiser, I get REPL. How do I evaluate the softwar in REPL?
<amz3>jmarciano: go at the end of form like (define foo 1) and hit C-x C-e
<amz3>this will eval it
<amz3>to eval the whole file hit C-x C-k
<amz3>sorry C-c C-k
<amz3>there is another binding to eval a form when you are in the middle of it, but I don't remember what it is
<amz3>jmarciano: ^
<amz3>don't forget to do M-x run-guile
***dje is now known as xdje
<jmarciano>I need help with geiser, guile
<jmarciano>OK I got it how to evaluate in emacs.
<jmarciano>with C-M-x and C-x C-e, very nice...
<linas>So... in scheme, or in any other language, is there a way to say "just beta-reduct this expr, but don't execute it?"
<linas>never mind. .. I just need some complicated qasiquote I guess.
<jmarciano>I am using let wrong, need help
<jmarciano>(let ((a 1) (b a)) b), I know the difference now to: (let* ((a 1) (b a)) b)
<linas>your example needs to use let*
<mark_weaver>jmarciano: with 'let', none of the left-hand-side variable bindings are available within the right-hand-side initializers.
<mark_weaver>e.g. you can do something like this: (let ((a b) (b a)) ...) to effectively swap the values of 'a' and 'b' within the let.
<mark_weaver>(although no variables are changed, instead two fresh bindings are created)
<mark_weaver>in contrast, (let* ((v1 e1) (v2 e2) (v3 e3)) ...) is equivalent to: (let ((v1 e1)) (let ((v2 e2)) (let ((v3 e3)) ...)))