IRC channel logs

2016-03-14.log

back to list of logs

<JeanLouis> https://en.wikipedia.org/wiki/Tiny_Encryption_Algorithm I need this in Guile or scheme, somebody knows?
<JeanLouis>or similar encryption that I can encrypt single line
<rain1>you could implement it
<rain1>or find a C version to link to
<JeanLouis>well first I need to understand that C code
<JeanLouis>I rather re-use code
<rain1>I wouldn't recommend using TEA though, maybe https://en.wikipedia.org/wiki/Speck_%28cipher%29 would be better
<JeanLouis>is there in guile something ready?
<JeanLouis>I am just sending URL parameters encrypted, like a=1&b=2&c=checksum
<JeanLouis>so it is not big deal in security
<mark_weaver>JeanLouis: Weinholt's "industria" library implements several hash algorithms and ciphers in pure R6RS scheme
<mark_weaver>but probably neither of those two ciphers you mentioned
<JeanLouis>let me see
<mark_weaver> https://github.com/weinholt/industria/tree/master/weinholt/crypto
<JeanLouis>I see, I have to check it later. I need one line encryption.
<JeanLouis>will check it tomorrow if it can encrypt AES,blowfish, etc. in one line only
<mark_weaver>TEA looks fairly easy to transcribe into scheme code
<mark_weaver>the code is so small
<JeanLouis>yes
***__zxq9__ is now known as _zxq9_
<ozzloy>JeanLouis, sorry i'm in and out a lot. i just came back in for a minute
<ozzloy>now i'm heading back out. when i see that, i can go back to the scm buffer and C-x C-e stuff and it's available in the buffer
<ozzloy>JeanLouis, and i'm out again
<kristofer>dd if=$(guix system disk-image my-os.scm) of=/dev/sdb - is that supposed to attempt to run qemu?
<nalaginrut>afternoon guilers~
<janneke>morning nalaginrut
<nalaginrut>heya
<JeanLouis>how do I switch to other frame in emacs -nw?
<JeanLouis>C-x o -- found it...
***mario-go` is now known as mario-goulart
<wingo>moo
<Jookia1>Wow you must live near me wingo
<wingo>where are you, Jookia1 ?
<civodul>howdy, wingo!
<wingo>ACTION lives in a linode :)
<wingo>morning civodul :)
<Jookia1>wingo: Across the road from a cow paddock
<wingo>hehe
<wingo>ACTION goes to fix the miscompilation that daviid reported a couple weeks ago
<wingo>fixed that bug; it was a bug in type/range inference
<wingo>just pushed
<wingo>i have seen a few bugs like that; the optimization pass itself (like the unboxing pass) is correct but if it operates on a bad type inference, then badness.
<ehiggs>Hi all. Are fedora packagers here? guile-2.0.11 is the latest fedora package in f23 but there's nothing in pkg-config so tools like guix won't work
<ehiggs>Disregard that, I eat chocolate. I needed guile-devel
<rain1>What would you recommend as the best tool for making documentation for a guile library?
<davexunit>texinfo
<rain1>ok!
<mark_weaver>wingo: it would be good to fix guile-master on i686. see http://hydra.gnu.org/job/gnu/master/guile-next-2.1.2.i686-linux and http://hydra.gnu.org/job/gnu/master/guile-next-2.1.1.i686-linux for build logs
<mark_weaver>(I get similar failures on my machine)
<wingo>mark_weaver: indeed, and i got that failure when cross-building it hink
<wingo>*think
<wingo>need to find time to look into it; it may take a while
<mark_weaver>wingo: with guix, you can natively build it. "guix build -s i686-linux -K guile-next"
<mark_weaver>my x86_64 laptop is dead at the moment, so it's been some time since I can even build guile-master :-(
<mark_weaver>"guix environment --pure -s i686-linux guile-next" might also give you a 32-bit environment to test build in.
<wingo>yes but i don't want to develop guile with guix
<wingo>ah an environment can be useful
<mark_weaver>if you can reproduce the problem when cross-building, I guess that's fine too
<wingo>i was cross-building to i686 from x64, but i don't need to do that if I can get the error with the guix environment
<nalaginrut_>my plan of this year contains Artanis server core, guile-lua-rebirth, and one secret cool project, hmm...maybe two... seems I really need AlphaGo to help me on these
***nalaginrut_ is now known as nalaginrut
<dsmith-work>Monday Greetings, Guilers
<paroneayea>o/
<amz3>héllo guilers!
<janneke>civodul: i've sent multiple patch iterations to -devel
<janneke>and i'm testing a next version that handles 'eval.go' too
<janneke>shall i send that version 4 too? any comments/tips?
<civodul>janneke: haven't looked at it yet, it may be faster if wingo or mark_weaver or who knows else would look at it :-)
<civodul>sorry for the delay!
<janneke>np
<janneke>civodul: esp: should i post my latest version there too now?
<janneke>v3 works, but only after guile has booted, v4 also handles boot-up
<wingo>janneke: please do
<janneke>wingo: thanks
<janneke>wingo: i've also backported the patch to stable-2.0
<janneke>would you already want to see that too?
<janneke>the comments would be largely the same I guess...
<wingo>janneke: is it done? my bandwidth is small so unless you need feedback, for me finished patches are better
<wingo>also i think you would need a signoff from mark_weaver before pushing to stable-2.0
<wingo>as i think he's got more of an idea of what's ok there and what's not
<wingo>dunno :)
<janneke>wingo: i'll wait for comments on development and finish that first
<wingo>ok
<janneke>sure, thanks
<wingo>great
***dje is now known as xdje
<JeanLouis>learning: (define how-many-years (lambda(name years) (string-append name " has " (if (string? years) years (number->string years)) " years."))) to check for input types. Or is there better method?
<rain1>I think that's great
<JeanLouis>rain1: thanks, I feel better...
<rain1>you could make a helper function
<JeanLouis>tell me
<rain1>(define (->string x) (if (string? x) x (if (number? x) (number->string x) (error "unknown type"))))
<rain1>then: " has " (->string years) " years."
<JeanLouis>what it means -> ?
<JeanLouis>this is good to know, yes.
<JeanLouis>or maybe ->string is just like that, without special meaning for "->"?
<rain1>yes
<rain1>you could call it to-string instead
<rain1>it's not special
<mark_weaver>JeanLouis: (define how-many-years (lambda (name years) (format #f "~a has ~a years." name years)))
<JeanLouis>mark_weaver: aha that is another method
<JeanLouis>
<JeanLouis>
<JeanLouis>
<JeanLouis>
<JeanLouis>
<JeanLouis>
<mark_weaver>a further shorthand is (define (how-many-years name years) (format #f "~a has ~a years." name years))
<mark_weaver>(although sometimes I wonder if that shorthand way of creating procedures does more harm than good)
<JeanLouis>in guile info, I don't find that ~a is for number and strings, it is described like for robots: "output an argument as display"...
<rain1>I think it means like (display years)
<rain1>as opposed to (write years)
<mark_weaver>JeanLouis: there are two generic procedures to print things out in scheme: display and write
<JeanLouis>yes I am reading in info, I am also using both already.
<mark_weaver>'display' produces output meant for humans to read, and 'write' produces output that's more or less in scheme syntax, meant for 'read' to read back in
<mark_weaver>(although only some types can be written and read back in that way)
<mark_weaver>e.g. for strings, 'write' includes quotes and escapes characters where needed, whereas 'display' simply prints the contents of the string with no escapes and no quites
<rain1>one thing that bugs me a lot is there's no easy producedure to print a thing and newline
<mark_weaver>*no quotes