IRC channel logs

2016-03-12.log

back to list of logs

<amz3>héllo guilers
<janneke>hi amz3
<amz3>I have a strange behavior with guile 2.0, here is the code https://friendpaste.com/4oZE7McceNgtvFG29piwiX
<amz3>it seems like the process crash but without any notification
<amz3>bash "echo $?" returns 141
<amz3>I will try to reproduce without using my eventloop
<amz3>so I've rewritten the program without the asynchrnous procedure
<amz3>it kind of works, execpt that when the server close the socket, the client can still send stuff
<amz3>got it failing again
<amz3>I mean the synchronous code can also fail in some occasion
<amz3>I've put all the code of the exp here: https://friendpaste.com/4oZE7McceNgtvFG29pil96
<amz3>basically the flow of the program is the following:
<amz3>1) client connect to server
<amz3>2) client send something
<amz3>3) server recv that
<amz3>4) server close both connection and listenning socket
<amz3>5) client try to receive something but receive an empty list
<amz3>!
<amz3>6) client goes to sleep 15
<amz3>7) client try to send something
<amz3>end) client crash with error 141
<amz3>mark_weaver: ^
<amz3>seems like a SIGPIPE error
<amz3>it fails on guile-2.2 too
<amz3>how do you declare an array part of a struct using guile-bytestructure
***karswell` is now known as karswell
<amz3>hey taylan, I got a question for you
<amz3>how do you declare an array part of a struct using guile-bytestructure
<amz3>and also how to declare a struct embededded in another struct
<taylan>amz3: (bs:struct `((x ,(bs:vector 3 ,uint16)) (y ,(bs:struct `((z ,uint8) (t ,uint32))))))
<taylan>C equiv.: struct { uint16_t x[3]; struct { uint8_t z; uint32_t t; } y; }
<amz3>thx
<paroneayea>hello !
<rain1>hi :)
<amz3>taylan: another question how do you declare: struct { void something; }
<amz3>should I use the star symbol '* ?
<mark_weaver>amz3: did you mean "void *something;" ?
<amz3>yes
<taylan>amz3: hmm, using any descriptor in place of void should do, e.g. uint8. there's no type-checking after all, and using void* means that you don't intend to dereference the pointer (without casting it to another type, which in this case would mean using another bs descriptor...)
<amz3>ok
<taylan>amz3: actually, chances are (bs:pointer #f) will "just work"
<taylan>if not, I guess I could implement it
<taylan>amz3: yeah, (bs:pointer #f) works. and it will raise an error when you try to dereference the pointer. it doesn't raise an optimally informative error, but at least it errors instead of producing a wrong value.
<janneke>BOOTSTRAP GUILEC language/cps/intset.go
<janneke>ACTION wishes for ccache support in guile
<daviid>didn't know we had so many entries, although most probably need review [guile-1.8], in http://community.schemewiki.org/ category-guile, category-goops ...
<daviid>this person wrote a bunch, is he/she around still? http://community.schemewiki.org/?uriel
<taylan>daviid: not sure if same uriel: http://p9.nyx.link/wiki/uriel/ passed away in 2012
<daviid>oh!
<daviid>I gues it is the same person
<X-Scale>I presume it's the same Uriel -> http://uriel.cat-v.org/