IRC channel logs

2016-03-10.log

back to list of logs

***M-TimePath is now known as TimePath`
<wingo>srfi-19 string->date doesn't allow you to leave off the year; irritating
<amz3`>héllo :)
<Bobbejaantje>amz3`, hi
<Bobbejaantje>wingo, you mean use the current year if it's let off?
<rain1>Is there a library for xorg/X11 with guile?
<rain1>I found this http://www.markwitmer.com/guile-xcb/guile-xcb.html
<mark_weaver>rain1: there's also guile-gnome
<mark_weaver>(although it's not yet updated to version 3)
<rain1>I've been wanting to use it buit waiting for a new release
<mark_weaver>honestly, you might be waiting a long time for it
<rain1>is there a way I could make the new release happen?
<rain1>Although I would need some guidance
<mark_weaver>we'd like to move to using gobject-introspection
<mark_weaver>it's a difficult job
<rain1>oh okay, I thought it was just changing a variable in a config file and then pushing that out/packaging and stuff
<mark_weaver>if it was easy, it would have been done years ago :)
<mark_weaver>there's also guile-clutter
<linas>guile and tee ... how?
<linas>saying guile | tee does not work as expected...
<mark_weaver>linas: works for me. what problem are you seeing?
<rain1>is there any info about the guile gobject introspection version of gtk project?
<rain1>gnome*
<mark_weaver>rain1: it's not a project yet, just an idea
<mark_weaver>although there are gobject-introspection bindings for guile, as I recall.
<mark_weaver>but this job requires someone who's knowledgeable about gobject-introspection and how it can be used to create language bindings semi-automatically.
<mark_weaver>s/semi-/mostly /
<rain1>Are there any easy for beginners guile things to contribute towrds?
<amz3`>:)
<amz3`>ACTION thinking
<mark_weaver>rain1: btw, I'm not saying that writing guile-gnome-3 is necessarily out of your reach. but if you want to do that, you need to do your homework yourself :)
<mark_weaver>I can answer questions, but I don't have time to walk you through the process
<mark_weaver>but the basic idea would be to use gobject-introspection and Guile's dynamic FFI to automatically create wrappers for all of the Gtk/Gnome APIs.
<mark_weaver>without writing any new C code at all.
<rain1>that's definitely a very cool idea
<amz3`>there is already a scheme library doing that for various scheme implementation
<amz3`>I don't recall the name right now
<mark_weaver>that's what we'd like to move towards, and if we had that, it would be easy to update to new APIs as they come along, because gobject-introspection is meant to provide the necessary information to automatically create wrappers.
<rain1>maybe I'll play around with gobject-introspection a bit
<mark_weaver>cool!
<dsmith-work>Morning Greetings, Guilers
<paroneayea>hi everyone!
<paroneayea>#guile seems active today :)
<janneke>ACTION very much enjoys morning greetings at 18:09
<cojy>when i try changing (ice-9 control) i start getting ;;; WARNING: .../control.scm failed ;;; ERROR: no code for module (ice-9 control)
<cojy>anyone know what im doing wrong and how to do it right?
<cojy>even if i revert the changes it does it
<mark_weaver>cojy: sounds like you'd introduced an error in that file, so it can't be compiled successfully.
<mark_weaver>*you've
<cojy>like i said even if i revert the changes, so that can't really be it
<mark_weaver>you built guile from source code?
<cojy>yes
<mark_weaver>there might be a stale ice-9/control.go file
<mark_weaver>anyway, I have to go afk for a while, sorry
***alexei___ is now known as amgarchIn9
<linas>mark_weaver well, I said this (with guile-2.1 from git): guile |tee foo then (+ 2 2) but 4 is not printed until I ccontrol-D to quit
<mark_weaver>linas: ah, I checked guile-2.0, not guile-2.1. last I tried, guile-2.1 doesn't compile on i686, which is what I'm stuck on at the moment, so I can't try it.
<mark_weaver>but my first guess is that maybe the output port is configured for full buffering. you might try changing it to line-bufferred, or unbuffered.
<mark_weaver>see 'setvbuf' in the guile manual
<mark_weaver>yeah, at the moment, x86_64 is the only architecture that guile-2.1 seems to build successfully on. it fails on i686, armhf, and mips64el anyway
<mark_weaver> http://hydra.gnu.org:3000/eval/108884?filter=guile-next#tabs-still-fail
<mark_weaver>at some point, we'll have to make it more portable :)
<mark_weaver>here's what happens on i686: http://hydra.gnu.org:3000/build/1026345/log/raw
<mark_weaver>seems to be some problem with intmaps
<mark_weaver>wingo: fyi ^^
<mark_weaver>I haven't yet found the energy to read and comprehend the intmap code
<mark_weaver>let alone debug it :)
<amz3>rain1: did you find the scheme library that does GI?
<rain1>no, which?
<amz3>rain1: https://github.com/rotty/sbank
<rain1>thank you
<amz3>I had a look libuv header, this aweful much more complicated to bind that wiredtiger
<amz3>aweful lot is maybe a lot of talking
<amz3>anyway, it requires bytestructure, that's what was holding me from starting to bind it
<daviid>amz3, rain1, sbank is missing bits to work with guile, so said rotty last time I could chat with him here
<paroneayea>hello!
<paroneayea>In between other things, I am *attempting* to rewrite bipt's elisp commits in changelog format
<paroneayea>but I don't know how guile's C stuff works
<paroneayea>so I'm taking a long time
<paroneayea>I guess it's a good way to learn...
***M-TimePath is now known as TimePath`
<paroneayea>got a few of the commits updated, pushed
<daviid>is there a way to search in our channel logs?
<rain1>you may not like this answer but google can do it: site:https://gnunet.org/bot/log/guile foo
<rain1>it seems like the site itself doesn't let you
<daviid>wingo: did you patch master for (define (qux str k) (let lp ((kk (string-length str))) (and (>= kk k) (lp (1- kk)))) (qux "foo" 0) -> unnamed port>:1:60: Value out of range 0 to 18446744073709551615: -1
<daviid>dsmith-work: our bot is on holiday? :)
<paroneayea>hey lfam, question for ya
<lfam>Okay
<paroneayea>lfam: in a changelog style commit, if I have a whole bunch of functions like this
<paroneayea>(foo, bar, baz): Changed location.
<paroneayea>or "moved around" or something
<paroneayea>but baz not only moves, but also does something else
<paroneayea>should I do
<paroneayea>(baz): Also change conditional behavior.
<paroneayea>or do
<paroneayea>or never have it in the first group
<paroneayea>and have it on its own listing and do both?
<lfam>I'm not sure. When I need to answer questions like that I usually try to find a prior example in the logs. If I couldn't find an example, I'd probably use the former method. That assumes it makes sense to move them all together, which it probably does if it's all in one commit. That way the reader doesn't have to hunt to figure out what moved; it's all in one place.
<lfam>paroneayea ^
<paroneayea>lfam: okay, well good enough for me, since that was my instinct as well.
<paroneayea>Since I'm waiting for an environment to rebuild, I'm doing the changelog adjustments for the elisp branch ;P
<paroneayea>some of these commits are huge. I'm not *totally* sure what's going on, but I'm doing a best guess and leaving in the description
<paroneayea>(Best-ability ChangeLog annotation added by Christopher Allan Webber.)
<paroneayea>that way it's clear that the ChangeLog stuff *could* be wrong but is the best I could do.
<paroneayea>and is not bipt's original writing.
<lfam>You are resurrecting an old branch? For Guile or Guix?
<lfam>That yak is always very hairy
<paroneayea>lfam: I'm rebasing bipt's elisp support for guile
<paroneayea>I already got it *working*
<paroneayea>but it lacked changelog style commits for some branches
<paroneayea>we want to merge it so it doesn't bitrot.
<holomorph>fwiw what lfam said was my approach for making commits to emacs, and no one has pinged me for anything aside from capitalizing or ending with a period
<lfam>I'm no authority on this subject ;) I just do my best to copy the examples in commit log
<paroneayea>holomorph: lfam: great, thanks :)
<paroneayea>how does the (guard) clause in pmatch work?
<paroneayea>toatally undocumented :(