IRC channel logs

2016-02-25.log

back to list of logs

<rain1>Hello
<rain1>what is happening with guile-cairo?
<rain1>did wingo become the maintainer?
<rain1>why does -l respect ~/.guile but -s doesn't?
<mark_weaver>iirc, ~/.guile is only loaded when starting the REPL
<rain1>maybe I should be using an environment variable to add to the guile load path rather than ~/.guile
<rain1>that might work better
<mark_weaver>yes
<mark_weaver>GUILE_LOAD_PATH
<mark_weaver>and GUILE_LOAD_COMPILED_PATH
<rain1>How do I re-export a symbol? when defining my own module
<mark_weaver>you want to export a binding that you imported?
<rain1>oh there's an extra option #:re-export but it's strange #:export doesn't work
<rain1>yeah
<rain1>and I was wondering what #: is?
<mark_weaver>#:re-export
<mark_weaver>#: introduces a *keyword*, which is similar to a symbol but self-evaluating.
<mark_weaver>i.e. a symbol will evaluate to a variable lookup, but a keyword evaluates to itself without being quoted.
<rain1>thank you :)
<kristofer>what native input will provide autoreconf?
<kristofer>woops
<artyom-poptsov>ACTION just updated Guile-SSH 'master' branch with patches to make it work with libssh 0.7.3
<artyom-poptsov>Hello everybody. I'd appreciate if somebody could test Guile-SSH 'master' with libssh 0.7.3 on his/her beloved GNU/Linux distribution.
<artyom-poptsov>Tests on Gentoo and Arch GNU/Linux seem to run flawlessly though.
<nalaginrut>afternoon guilers~
<mark_weaver>artyom-poptsov: I'll try it on guix
<mark_weaver>artyom-poptsov: on GuixSD on i686 with libssh 0.7.3, Guile-SSH master fails its test suite. I see:
<mark_weaver>../build-aux/test-driver: line 107: 13092 Segmentation fault "$@" > $log_file 2>&1
<mark_weaver>FAIL: tunnel.scm
<mark_weaver>FAIL: dist.scm
<mark_weaver>artyom-poptsov: if you have a working copy of Guix on either x86_64 or i686, I can send you a recipe to reproduce this.
<nalaginrut>mark_weaver: hi mark, is there still problem with the errno patch? I've tested your fixed version, it good enough for me. Do you think it's proper to merge it now? ;-)
<ozzloy> http://www.nongnu.org/skribilo/doc/user-1.html#section4166 i notice it says "meta keyword" and should probably say "meta keywords". i feel a bit silly asking here, but i can't find where to notify someone
<ozzloy>how do i notify, or is it in git? could i write a patch and send it to someone?
<ozzloy>ah, i found the source code
<jmd>I have an alist in a file. What's the easiest way to read it an associate that alist with a symbol?
<wingo>(define my-alist (call-with-input-file "foo.txt" read))
<jmd>Thanks Andy
<ozzloy>it seems like guile and racket are very similar. is that because they're both schemes, or is there overlap in people working on them
<ozzloy>or some other thing
<ozzloy>how do i get a list of skribilo modules?
<wingo>ozzloy: b/c they're both schemes. some user overlap but not much developer overlap
***Korhonen is now known as Bobbejaantje
<nalaginrut>wingo: it seems that 2.1.2 introduced a bug to add a strange postfix while I'm calling datum->syntax
<nalaginrut>it's normal in 2.0
<nalaginrut>wingo: I'm still finding a way how to reproduce it simply
<rain1>Unbound variable: ((#{ g415}#) take #f)
<rain1>how may I interpret this error message?
<wingo>it is a strange message :)
<wingo>how did you get there?
<rain1>its from using the guile repl inside emacs (geiser mode)
<rain1>if I just use the command line I get a different error
<rain1> https://gitlab.com/tampe/attributed-minikanren/tree/master this is the file
<rain1> http://paste.debian.net/403536/
<rain1>thats the error in terminal
<rain1>I wonder if I broke my guile because this program worked before
<rain1>oh i think its working now after i updated
<rain1>Is there a way i could define #s and #u to be my own values?
<rain1>(sort of like #t and #f)
<amz`>IIRC, # is an escape sequence of some sort in Guile, so no. but why would do that, anyway?
<amz`>rain1: ^
<rain1>ah
<rain1>just for terseness
<amz`>you can use % instead
<davexunit>has anyone ever made some kind of custom allocator in guile or any other gc'd language?
<sneek>davexunit, you have 1 message.
<sneek>davexunit, paron_remote says: If you haven't read about the systemd vs docker stuff on lwn.net, I think you'll find it interesting http://lwn.net/SubscriberLink/676831/174a9deefa9881cc/
<davexunit>I have a problem that traditionally could be solved with an object pool, but I cannot sacrifice purely functional semantics in doing so.
<davexunit>paroneayea: hehe good timing. I was just checking lwn and saw this. will read.
<davexunit>paroneayea: holy crap. the answer to "who cleans up zombie processes in a Docker container" is "kill it and restart"
<rain1>docker is annoying, you can't run it inside a container
<davexunit>guess this conversation should get moved to #guix
<amz`>davexunit: did you see this https://lists.gnu.org/archive/html/guile-devel/2016-02/msg00043.html
<davexunit>amz`: yes, but I don't really understand it.
<rain1>hello stis
<stis>hey rain1, thanks for the bug report.
<rain1>i've been tinkering more :) if you're interested/not busy i'll pm you
<stis>please do.
<dsmith-work>Morning Greetings, Guilers
<amz`>hey
<amz`>I think gnu has gitlab instance, do you know where it is?
***dje is now known as xdje
<davexunit>from my searches for "gnu guile" on twitter, I find that the Japanese are among the most interested in Guile.
<paroneayea>davexunit: are they interested in guile the language?
<paroneayea>or Guile the Street Fighter character?
<paroneayea>oh
<paroneayea>gnu guile
<paroneayea>yeah I guess that excludes street fighter!
<davexunit>:)
<daviid>hello guilers
<daviid>this link is broken [Guile's web site] ftp://alpha.gnu.org/gnu/guile/
<daviid>or unavailable aybe
<daviid>maybe
<daviid>sneek: last seen rotty
<daviid>hum
<mark_weaver>daviid: FWIW, I have no problem accessing ftp://alpha.gnu.org/gnu/guile/
<mark_weaver>where is it linked from Guile's web site?