IRC channel logs

2016-02-14.log

back to list of logs

<ArneBab>lockdown: there is an r7rs branch which provides partial r7rs implementation
<ArneBab>as far as I know it’s controversial, though
<ArneBab>(supporting r7rs or r6rs, not the existence of the branch)
<amz3>héllo
<alezost>Is there a guile analog to "which" shell command?
<alezost>I mean a procedure to check if a program exists in $PATH or not
<alezost>currently I just use (zero? (system* "which" "foo")) but I'd like to have a pure guile code.
<alezost>I'm disconnecting now, but if someone has an answer, please write it :-) I'll read the logs later
<wingo>see (guix build bournish)
<wingo>which uses (search-path path file)
<wingo>where path can be from (string-split (getenv "PATH") #\\:)
<wingo>but you probably need to expand tildes, etc. hum.
<wingo>short answer: no, apparently :)
<Korhonen>bournish=again shell
<amz3>M-q is super nice binding in emacs, try it on long comment
<mark_weaver>wingo: we have a 'which' procedure in (guix build utils)
<mark_weaver>which is available by default in our build-side code, e.g. from within phases of packages
<mark_weaver>sneek: later tell alezost we have a 'which' procedure in (guix build utils), which is available by default in our build-side code, e.g. from within phases of packages
<sneek>Will do.
<amz3>my dish is ready!
<amz3>well, almost... it requires a manual :)
<amz3>whatever program I write, is not enough complex..
<amz3>until i get stuck and can't program anything
<stis>hej guilers!
<amz3>heya!
<autogen>sometimes I feel like there's someone who has done exactly all of the work I need. That's very helpful. :)
<stis>aka standing on the giant shoulders :)
<autogen>why stand when you can lay, with a woman and a glass of iced lemoande and frorthy coconut whip? :)
<autogen>soon, the pet dog, robot, and kids.
<vanila>im studying the attributed vars mk
<amz3>stis: you did you potluck dish too early :)
<amz3>this is very interseting paper about NLP http://arxiv.org/pdf/1502.05698.pdf
<amz3>stis: what's the purpose of attribute variable, I did not understand.
<Korhonen>amz3, what colour does your hair have?
<amz3>black
<Korhonen>Ahh, so does mine.
<Korhonen>What a coincidence
<Korhonen>well, it is the most common hair colour amongst human bengs I guess.
<amz3>Korhonen: is it related to something?
<amz3>autogen: what are refering to? what work was done for you?
<Korhonen>Not at all, I was just curious about the colour of your hair.
<amz3>Korhonen: I am supposed to undertand something else
<amz3>?
<Korhonen>Hmm, I think you assume there s a deeper meanng it than there s, amz3
<Korhonen>I was just curious, that's all.
<amz3>sorry I'm factual
<vanila>weird
<stis>amz3: It's a way that you can implement meta constructs on variables and create customizable unifications
<stis>amz3: I implemented symbolo =/= and absento ontop of them in the source as an example
<stis>you can also use them as triggers when you unify a variable to a value.
<stis>see freezo in the source:
<stis>amz3: yeah i'm suffering from a premature completion syndrome
<amz3>thx
<stis>FYI, i just implemented attributed variables for minikanren, https://gitlab.com/tampe/attributed-minikanren
<vanila>thanks stis
<vanila>$ rlwrap guile -l mk-attributes.scm
<vanila>then how do i test it (run (q) (=/= #t #f)) ?
<stis>not sure what rlwrap is, but if you load it that should work. There i snot much of documentation, you should check thh guile-user mailing list though, there shohuld be a small documentation there
<vanila>unknown file:2:0: source expression failed to match any pattern in form (run (q) (=/= #t #f))
<vanila>i got this error i was just wondering if you could show an example query
<stis>in the potluck thread
<stis>hmm strange
<vanila>oh run* works
<stis>(run 1 (q) (== #t #f))
<vanila>oh thanks i see what i did wrong
<stis>that should work
<stis>you should really check out the implementation of symbolo =/= and absento freezeo and wheno to see how to use the attributed variables
<vanila>I have this: Unbound variable: join-unifies
<vanila>should it be join-eq?
<vanila>line 591
<stis>thanks vanilla I'll changed it in a moment
<vanila>i hope im not bugging you :)
<vanila>im really interested in this
<vanila>i want to join our mk's together to make the best one
<stis>a fix is pushed, no you are not bugging me.
<stis>my contribution is just an idea, it is bugging me that one needs to introduce a stack for every other feature.
<vanila>i was thinking a lot about CHR for minikanren
<vanila>it'd be nice but I think CHR is very hard to implement
<stis>attributes can make things much more customizable and serve as a good ground to start experimenting woiht constraints
<vanila>i found a bug
<stis>yeah there is a lot of logic and knowledge that is inside CHR and CLPFD
<stis>thanks :-)
<vanila>(run* (x y u v) (=/= (cons x y) (cons u v)) (== x 'x) (== u 'x))
<vanila>$11 = ()
<vanila>it thinks we're done when i set x
<stis>yeah this should work. Let me fix it.
<vanila>attributed variables looks like a really good idea
<vanila>instead of CHR
<vanila>much simpler and stuff
<stis>well its a fundamental rechnology. Not a full solver
<vanila>yeah :D
<vanila>in mine i was just programming each constraint directly
<vanila>and that is hard work
<stis>You can write a CHR using it
<stis>yep really hard
<stis>vanila: I found the loophole, fixing it now
<stis>vanilia: pushed the plumbing of the loop hole, please continue.
<stis>vanila: ^^
<sjoerd`>How can I safely delete a value from a weak-key-hash-table, if the key is gone?
<svanleent>How can I safely delete a value from a weak-key-hash-table, if the key is gone?
<amz3>svanleent: isn't the value gone too?N
<svanleent>Well, I was hoping that wouldn't happen, but it appears to be the case
<svanleent>I am dealing with something not garbage collected, and hoped that I could scan the table on left over objects to get collected too
<svanleent>Should then use a weak-value-hash-table?
<Korhonen>So why can't you pass zero arguments to compose?
<Korhonen>Shouldn't that basially be a function identical to values in semantics