IRC channel logs

2016-01-22.log

back to list of logs

<introom>looks like there is no (runtime) function in guile
<mark_weaver>introom: I'm not sure what you're looking for exactly, but see the 'times', 'get-internal-real-time' and 'get-internal-run-time' procedures, described in https://gnu.org/software/guile/manual/html_node/Time.html
<mark_weaver>also there's a dynamic FFI that can be used to easily access arbitrary C functions
<mark_weaver>SRFI-19 also has 'time-process' and 'time-thread'. https://gnu.org/software/guile/manual/html_node/SRFI_002d19-Time.html
<wleslie>heh, I would expect a (runtime) function to return the path to the running executable
<wleslie>the 'real' argv[0]
<mark_weaver>wleslie: interesting. I would find that surprising. I'm not sure why "time" would be in the name if it didn't have to do with time.
<rntz>hey, anyone here know anything about guile-{xcb,wm}? I'm trying to build guie-xcb and getting an automake error.
<rntz>alezost?
<alezost>rntz: all I can say: last time (more than a year ago) I built guile-wm/xcb, it was successful
<alezost>pasting an error will help
<alezost>btw why did you ask me?
<rntz>I saw your name as the last committer on github :P
<rntz>it's complaining about missing automake-1.14; I have automake-1.15. (pasting an error presently)
<rntz> http://pastebin.com/EnaSSnNM
<rntz>is it.. just not forwards-compatible like that? is there some simple change I could make for it to work with 1.15?
<amz`>rntz: you can change the automake requirement inside guile-xcb
<rntz>where would I have to do that? would changing `am__api_version' in configure be enough?
<alezost>rntz: or you can run "autoreconf -vf", and then "./configure" and "make"
<rntz>I don't really know anything about how autotools work.
<civodul>ACTION hugs anyone who irons out the remaining issues in guile-wm
<rntz>alezost: ah, thanks!
<alezost>rntz: no problem, apparently guile-xcb wasn't updated for a long time, so "configure" script is out-of-date
<rntz>civodul: what kind of issues are you thinking of? I have not used guile-wm before, I am intending to try it out
<rntz>hm, the configure script seems wrong. even though I asked for --prefix=$HOME/p/, it's trying to put files in /usr/share/guile/site.
<rntz>or is that intended behavior?
<rntz>ah, I see, does guile not have a standard per-user site path?
<civodul>rntz: last i tried there were a couple of bugs, notably with multi-screen support (RandR), and the "root key" could not be "escaped" (unlike in ratpoison)
<civodul>i'm sure these are shallow issues, but i never took the time to investigate
<alezost>rntz: I think you also have to use --with-guile-site-dir and --with-guile-site-ccache-dir. Like this: "./configure --prefix=$HOME/usr --with-guile-site-ccache-dir=$HOME/usr/lib/guile/2.0/site-ccache --with-guile-site-dir=$HOME/usr/share/guile/site/2.0"
<rntz>ah, hm. I ended up just letting it install into /usr/share. would I also have to configure guile itself to recognize $HOME/usr/share/guile/site/2.0 as a site dir?
<rntz>(I installed guile via apt-get, so it presumably doesn't know about any such thing)
<alezost>rntz: yes, if you use non-standard paths, you also need to set GUILE_LOAD_PATH and GUILE_LOAD_COMPILED_PATH env vars
<wingo>civodul: re unboxing post, glad you liked it :)
<civodul>wingo: did you benchmark typical tight loops with just integers?
<wingo>civodul: no, i didn't. i don't know of many such loops that don't involve some other data structure
<wingo>if there's a loop variable that's not an index into a vector, it can be hard to prove things about its range
<wingo>i mean an integer loop variable
<civodul>yeah, right
<civodul>and only primitives have a known return type
<waqarali>hi
<waqarali>I need to know how to print stack trace at time I catch an excepton
<waqarali>I need to know how to print stack trace at time I catch an exception
<waqarali>can someone help please?
<waqarali>hello
<taylan>waqarali: this channel is often pretty slow-going
<waqarali>ok
<waqarali>can you help with stack trace?
<taylan>I don't know the answer to your question offhand, but maybe poking at some places in Guile's code can help, such as the REPL's ",backtrace" command, or the default/top-level exception handler
<civodul>the answer was to use 'print-exception' from a lazy catch handler :-)
<peterbrett_work>civodul: Quiet IRC channels with many lurkers can be disappointing ;P
<civodul>yeah, agreed
<civodul>OTOH the person left after 10mn, which is not a lot
<civodul>but yeah, it's Friday, so we could at least spawn a troll
***Shozan is now known as SHODAN
<nalaginrut>peterbrett_work: I'm not lurking, but concentrating on something ;-P
<waqarali>I need to print stack trace of exception in guile
<waqarali>can someone help
<peterbrett_work>waqarali: You need to use print-exception from a lazy catch handler
<peterbrett_work>civodul answered the question for you after you left earlier
<peterbrett_work>waqarali: If you stick around for a little bit longer next time, then you will probably get your answer sooner ;-)
<waqarali>ah ok peterbrett can I access history from this channel
<waqarali>or can you please copy paste the answer to me please
<kwrooijen>waqarali: You can view the logs here https://gnunet.org/bot/log/guile
<peterbrett_work>waqarali: That was the answer.
<waqarali>thanks
<peterbrett_work>waqarali: (1) use a lazy catch handler, (2) use print-exception
<civodul>thanks peterbrett_work for following up in the 10mn that waqarali was back ;-)
<peterbrett_work>civodul: I do my best
<daviid>wingo: ping :) it would be awsome if you could drop an eye on this problem: http://paste.lisp.org/+6JGN/1 and help me to understand what's going on and how to fix it, thanks!