IRC channel logs

2016-01-18.log

back to list of logs

<nalaginrut>morning guilser~
<leedleLoo>I'm still new to the world of lisp, and as a learning exercise I tossed together a few macros that make writing html in guile easier. What are some of the more familiar html modules for guile? I've looked through sxml and skribilo, both of which are really nice.
<nalaginrut>leedleLoo: are you looking for static page generator?
<leedleLoo>Yes, that'd be nice. I'd like to see how others have done it
<nalaginrut>leedleLoo: you may take a look at haunt: http://haunt.dthompson.us/
<leedleLoo>Haunt looks really nice, thanks!
<leedleLoo>What I've done so far is closer to sxml. I just use guile keywords instead of `@' for attributes.
<introom>can I load a script inside guile repl?
<introom>so far I can only do "guile -l xx.scm"
<leedleLoo>Try
<leedleLoo> https://www.gnu.org/software/guile/manual/html_node/Loading.html
<introom>looks promising.
<introom>I'd hope guilemacs come to the world sooner.
<ArneBab_>introom: you can actually already run guile emacs
<ArneBab_>introom: it’s not yet complete, but can already run org-mode
<Jookia>Is there a command line tool for formatting/indenting Lisp code?
<nalaginrut>Jookia: try (ice-9 pretty-print), you may need to write some wrapper code
<introom>ArneBab_: I heard it's not that stable now.
<janneke>Jookia: emacs?
<Jookia>janneke: Not a big emacs user. Lisp newbie too, currently trying to figure out how to load an s-expression from a file without evaluating it
<peterbrett_work>Jookia: read should do it
<Jookia>peterbrett_work: Thanks!
<ArneBab_>introom: in my opinion guile emacs isn’t suited for production, not least because it starts very slowly (it compiles all files every time it starts), but it is pretty good already. Running org-mode to export my PhD thesis to LaTeX is no small feat.
<civodul>ArneBab_: you used org-mode for your thesis?
<ArneBab_>civodul: yepp
<civodul>quite an achievement :-)
<ArneBab_>far less than doing so with LaTeX ☺ (which is the point of using org-mode instead)
<daviid>wingo: back to subclassing <clutter-layout-manager>, here is a super tiny self content executable sniptet: http://paste.lisp.org/+6JGN/1 it will only take 1min, could you drop it as mlayout [or any name], chmod a+x mlayout and ./mlayout -> you'll see the warning I was talking about ... but we should also see th result of peek, see the end of the file, in comments ... I would really like your opinion on this, and hopefully some
<daviid>help, thanks!!
<daviid>wingo: you will also notice that the b actor is not 'visible', because the default allocate <clutter-actor> method has not called [this is expected, because it is the rensposability of the layout manager... so once guile-clutter has been improved wrt this, the allocate mlayout [as an example] method should call allocate on all children of the container's actor... [you can tempo comment line 100 to see the diff ...]