IRC channel logs

2016-01-08.log

back to list of logs

<zacts>hi guilers
<wingo>sneek: later tell daviid it is already wrapped, in (gnome glib)
<sneek>Got it.
<b4284_>hello fellas
<b4284_>i've ran into a problem where "(eq? <STRING> <STRING>)" returns #t
<b4284_>code: https://gist.github.com/anonymous/2e321710134f3d5ab73d
<b4284_>eg. when i ran (partition-by identity '("aabb" "aabb") eq?), it actually groups the two strings into one group instead of two
<b4284_>which is, although, eventually correct, but semantically wrong
<lloda>you can't avoid this using literals
<lloda>use (string-copy "...") to make sure the strings are distinct objects
<ArneBab_>madsy: I plan to test your scripts this weekend (the computer will be running long enough to finish all the compiles)
<b4284>lloda: thanks, how about (list <STRING> <STRING ...) ?
<b4284>lloda: indeed (string-copy) made it work, thanks so much
<madsy_>ArneBab_: Nice
<madsy_>ArneBab_: I tested it on Debian jessie as well. And you can override the prefix for the host compiler now
<daviid>hello guilers!
<sneek>daviid, you have 1 message.
<sneek>daviid, wingo says: it is already wrapped, in (gnome glib)
<daviid>wingo: oh, fantastic! i missed that [for so long...]. and now we have full animation possibilities in guile-clutter as well, and the grip-clutter clock example works like a charm!
<wingo>:)
<daviid>rekado: I'm now fully convinced guile-clutter is the way to go for your project [don't remember the name, alikito ?] if you go ahead with an experiment, you will be able to animate all actors, basic properties and cairorelated, like drawn sounds waves...
<paron_remote>hi *
<daviid>I can't stop looking at my clock example, hipnotic! :)
<daviid>wingo: techically speaking it would be good to bind g_source_remove, so one can remove a idle or a timeout ...
<wingo>i think it's bound too
<daviid>ah
<daviid>I see it is used, here ./glib/examples/main-loop.scm:(for-each g-source-remove sources), but I can't find its definition ?
<wingo>it's generated automatically
<wingo>i think you will find it if you use (gnome glib)
<peterbrett>Does anyone have any tips for getting Guile 2 running on Windows?
<peterbrett>I'm looking into making geda-gaf Windows builds available again
<daviid>ok, yes I did find it, and it works fine as well, great! thanks
<peterbrett>Unfortunately neither the Guile website nor Google are being particularly forthcoming
<peterbrett>I was really hoping that someone had some steps for building with MSYS on Windows
<wingo>ACTION -> out, ttyl
<peterbrett>Because it would be great if Windows users could also easily be contributors :-)
<peterbrett>ttfn
<daviid>wingo: ok, thanks
<daviid>sneek: later tell amz3 I fixed the [grip-clutter] clock example, devel branch still, I recom you pull and ru the autotool chan danse again. This means you could animate your graph vertices [and edges of course], change their colour for example... upon 'external' events, such database modifications... have fun!
<sneek>Got it.
<daviid>sneek: later tell amz3 I'm happy to help bootstraping you wrt to goops, don't fear and don't be ashamed to ask ok? I'm really happy to help if needed...
<sneek>Will do.
<amz3>héllo :)
<sneek>Welcome back amz3, you have 2 messages.
<sneek>amz3, daviid says: I fixed the [grip-clutter] clock example, devel branch still, I recom you pull and ru the autotool chan danse again. This means you could animate your graph vertices [and edges of course], change their colour for example... upon 'external' events, such database modifications... have fun!
<sneek>amz3, daviid says: I'm happy to help bootstraping you wrt to goops, don't fear and don't be ashamed to ask ok? I'm really happy to help if needed...
<amz3>daviid: hi
<amz3>daviid: I'll dive in during the week end
<amz3>I slow down my coding habit for while
<daviid>amz3: sure, good we!
<daviid>amz3: when you'll grab, don't forget yu must run autogen.sh, configure --prefix=... to regenerate the source code of al examples, the clock in this case ...
<rekado>daviid: turned out that I didn't need the unpackageable JavaFX to use Axoloti after all (it's only needed to build application bundles), so I don't plan to work on an alternative implementation soon. Thanks for investigating, though! I'll keep cairo in mind.